Results 1 to 4 of 4

Thread: Windows 8 and Helix V3

  1. #1
    Join Date
    Jun 2007
    Post Thanks / Like

    Question Windows 8 and Helix V3

    Hello again friends:

    I am having trouble with Helix V3.
    It worked perfectly last year when I was using Windows XP, but that computer has since crashed.
    I have a new computer with Windows 8.1 and I'd rather not buy a Windows XP CD and a new hard drive for the old machine.

    So this is the error I get when I click the Comm Port drop-down arrow in the Tools tab of the HNS.

    ************** Exception Text **************
    System.NullReferenceException: Object reference not set to an instance of an object.
    at Helix_Network_Supervisor_3_1.XBeeSerialPort.SetPor tNames(Object obj)
    at System.Windows.Forms.ComboBox.OnDropDown(EventArgs e)
    at System.Windows.Forms.ComboBox.WmReflectCommand(Mes sage& m)
    at System.Windows.Forms.ComboBox.WndProc(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.W ndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

    No matter what I try, I can't get the HNS to recognize my USB-to-RS485 module, which is connected at COM3.
    I'm using a wired Helix V3 board.
    I set the MP3 chipset to the correct value.
    I've confirmed with Device Manager that the RS485 module is indeed working correctly and the driver is installed.
    It does recognize my wireless mouse, which is connected at COM1, but doesn't list any of the other COM ports.

    The error makes me think the Helix is trying to find the XBee radio which I am not using.

    I've uninstalled and reinstalled the HNS twice.
    What do you guys think?

    In 500 years, I may just finish all my projects and ideas that I have.

  2. #2
    Join Date
    Jan 2014
    Post Thanks / Like

    Default Re: Windows 8 and Helix V3

    After having the same or similar issue, I found that you shouldn't need to select the COM port. That's for the configuration of a XBee Wireless adapter. After I found that out I was able to set the time. Make sure you have the port "Off" (In HNS) when using the USB to RS485 adapter/BOB.
    I wasn't receiving the error in XP (I still have an XP laptop), but if I had the port (which is intended for XBee config) On, it won't allow communication via the USB to RS485 BOB.
    When using Windows 10, I was receiving the same error and I believe (I'll verify when I don't have a child in my lap) it was because the driver for the USB to RS485 BOB was not installed. I remember even receiving that error when I tried turning off the port in HNS. I've since installed the driver from Sparkfun's website. But, as mentioned, I'll verify if I'm still receiving the error.

    Sorry I didn't see this sooner. Hopefully you've already figured all this out and the info may be of benefit to someone at a later time.

  3. #3
    Join Date
    Jan 2014
    Post Thanks / Like

    Default Re: Windows 8 and Helix V3

    FYI: I tried with my Windows 7 hard drive in my laptop that I was mentioning has Windows 10 (hard drive was already in) and had no luck. Similar issue, where I receive an error when trying to choose a port (although the port, for wired communication is not supposed to be necessary, this software seems to think it is). And when I attempted to turn off the port, I received messages about the XBee port and I'm not able to switch it off.
    When I attempt the same thing from my Windows XP laptop, I'm about to turn off the port and check the time successfully using the Wired option.
    If I'm able to resolve in Windows 7, I'll update here. I'll give Windows 10 a try and see what I run into. I do also have Windows 8.1, but I assume that will have the same behavior and if HNS gets to working on the other versions (7 & 10), then I imagine I'll be able to get it working in 8. Probably a dependency that's missing.

  4. #4
    Join Date
    Jan 2014
    Post Thanks / Like

    Default Re: Windows 8 and Helix V3

    I'm wondering if this might be the case and something for Greg:
    Maybe Windows after XP are being more picky about the code.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts