View Full Version : Kudos to Conversion Writer

11-09-2014, 08:56 AM
Since we don't have a forum for "Kudos", I post this here in the development in hope that it will be seen by the intended party!

A VERY BIG THANK YOU to whomever wrote the conversion routine going from Vixen 2.1.xx to 3.1.xx.
I cannot express how much I appreciate this work.
The amount of work I thought that I was going to have to spend to get the conversions done (as in re-sequencing) was overwhelming.
This routine negated that fear and time.



11-09-2014, 02:10 PM
There were actually several hands in that module. And it's getting continued development currently as well. The ones I can think of off hand are macebobo, teberle, and martinmuller

--Jon Chuchla--

Sent from my iPhone using Tapatalk

11-09-2014, 08:17 PM
If any or all of them ever make it to little Lebanon, Illinois - Ice Cream is on me! :thup2:

11-09-2014, 08:25 PM
I'm not sure where those guys are. But Jeff is not too far from you. He's somewhere around St. Louis.

--Jon Chuchla--

Sent from my iPhone using Tapatalk

11-10-2014, 06:16 PM
I am about 20 miles from Lebanon in Maryville.

11-12-2014, 12:00 AM
I've driven by Lebanon many times on my way to New York. Glad the conversion program helped you out.

11-12-2014, 11:22 PM
Some good friends up in Maryville. Guess I now have another!!! :yeah:
(My Grand Daughter was born at Anderson Hospital.)
I've even been to Broken Arrow.

It is scary how small the world of "CLAP" is.

Once again, Thank you - all!

11-17-2014, 12:06 AM
We converted sequences the other night with absolutely no problem. (I stand by my thanks to all that created the converter.)

On the same computer, with nothing changed on either or 3.1u1, we are now receiving the following message:

Can't find an editor to open this file type. ("LWW carol of the bells.vix")

With this we are stopped dead in our tracks.

I have been unable to find any help files concerning this message.

Anyone have any idea?
(It's really important at this time. Thanks.)

11-17-2014, 12:11 AM
Are you opening it the same way? Or maybe trying to grab it from the recent files list instead?
Is this particular file created differently? I seem to remember someone else having trouble with corrupted headers or something similar. Does it still open in v2? Try opening it there and resaving as a new name. Then try to import again.

--Jon Chuchla--

Sent from my iPhone using Tapatalk

11-17-2014, 12:27 AM
I can open it in V2 without problem (it is playing as I type this.) Preview is right on, etc.

Opening it via the following (same routine as before):

Start V3.
Choose the profile.
Click on "Open Sequence".
Navigate to the V2 folder.
Navigate to the Sequences folder.
Choose the sequence (for now - Carol of the Bells, but have tried to get several different ones.)
Am told that the audio file is associated and asked to point to it.
Navigate back one level and choose "audio". Find the audio file and click on it.
Am told that there is a profile associated.
Navigate back one level and choose "profiles". Find the profile and click on it.
At this point I'm told, "Can't find an editor to open this file type. ("LWW carol of the bells.vix")

When I click on "OK", I find myself back at the Vixen 3.1u1 administrator window.

These are the exact motions I went through to convert the other files.

This is for a different profile. This setup has quite a few more channels than the other night as well. Those are the only differences.

What is it actually saying with this "Can't find an editor..."?

11-17-2014, 12:40 AM
An editor is what we call the module that edits a sequence. The new sequence, and open sequence buttons invoke "editors". The main v3 editor is the TimedSequenceEditor. But other editors exist too, there's the script editor. The v2 importer is another editor. You can't actually edit your v2 sequence with it, but it opens a file type, and somehow works with it. The v2 import editor just opens v2 sequences and gives you the wizard to convert it to a v3 sequence. So this error is related to either your v2 import editor part of the program being broken or missing, or that it can't open this particular file.

-- Jon Chuchla --

Sent from my iPad using Tapatalk

11-17-2014, 12:45 AM
I just downloaded and re-installed V3.1u1. Still have the problem after the re-install.

11-17-2014, 01:03 AM
Made a copy of the sequence.
Went into V2 and flattened the sequence.
Started V3 and tried to open the sequence.
Immediately got the editor message.

11-17-2014, 01:06 AM
I'm not a v2 expert. I'll try to round up someone more experienced for you. MartinMueller might be a good guy to PM.

-- Jon Chuchla --

Sent from my iPad using Tapatalk

11-17-2014, 08:08 AM
Thank you.

11-17-2014, 04:45 PM
Make sure that when you select open sequence you change the file type to Vixen 2.x sequence. We use this to determine which editor to use.

11-18-2014, 12:27 AM
Thanks for the reminder.
If you are talking about the drop-down box in the lower right corner - I did.
Still no joy.

11-18-2014, 12:31 AM
In my last attempt, I copied the V2 sequence, V2 profile and the audio file (.mp3) to the sequences directory of the V3 profile in use.
Still receive 'Can't find an editor to open this file type. ("LWW Amazing Grace.vix")'

In an attempt to make this happen, I have done the following as well -
Downgraded the V3 version to 3.0.10 (64 bit). No joy.
Downloaded and reinstalled a new copy of V3.1u1 (64 bit). No joy.
Removed all un-needed software from the computer (looking for conflicts). No joy.
Attempted this on three (3) different computers. You guessed it - No joy.

11-18-2014, 05:30 PM
Is it possible to build the channel mapping cross reference manually?
Like using a text editor or the like?

11-18-2014, 07:59 PM
Do not downgrade from 3.1 to 3.0. It will break your 3.1 installation. And a reinstall won't necessarily fix it.
Have you been able to reimport any v2 sequences that you've previously imported successfully? If that works we can rule out a problem with your v3 installation.

--Jon Chuchla--

Sent from my iPhone using Tapatalk

11-18-2014, 09:40 PM
I did not down grade.
I DID remove Vixen 3 from the computer, rebooted, then reinstalled V3.1u1.
Then tried to do a conversion, and nothing.

I'll try to do a conversion on the ones that worked. More in a minute.


Did a conversion on the ones I did before. Went like clockwork.

Note that the profiles on both the V2 and V3 sides are different. Somewhat smaller in all respects.
Still, they converted.

11-18-2014, 10:14 PM
Hmm. There must be a difference in those files. Can you post one that worked and one that didn't.

--Jon Chuchla--

Sent from my iPhone using Tapatalk

11-18-2014, 10:41 PM
What can I provide that would help? Which files?

11-18-2014, 10:46 PM
The v2 sequences to start with.

--Jon Chuchla--

Sent from my iPhone using Tapatalk

11-18-2014, 10:55 PM
the entire v3 profile directory and the v2 sequence, profile and audio fie


11-18-2014, 10:56 PM
So are all the imports from source profile 1 successfully importing into destination profile 1. And none of source profile 2 importing into destination profile 2? Have you tried s1 to d2 or s2 to d1?

--Jon Chuchla--

Sent from my iPhone using Tapatalk

11-19-2014, 12:27 AM
Profile 1 to Destination 2 allows for the building of the map, then I get the "Can't find editor...".
Profile 2 to Destination 1 gives the message just after pointing it to the V2 Profile.

11-19-2014, 12:30 AM
Now I'm even more stumped. That would seem to imply that the both source profile 2 and the destination profile 2 are messed up somehow.

--Jon Chuchla--

Sent from my iPhone using Tapatalk

11-19-2014, 12:36 AM
Sorry guys. Tried to upload to here, but the files are too large.

11-19-2014, 12:45 AM
I'm uploading the V2 files to http://bugs.vixenlights.com/browse/VIX-619. It is just under the limit for file sizes there after I trimmed out some of the selections.

I'll do the same with the V3 stuff.

Sorry, but I don't have dropbox or any other like it.

Correction, I now have a dropbox account. Sent PM to Martin with links.
Will also share with you Jon if you want them as well.

I'm also not sure if the files made it to the bug page. It took several minutes, but I don't see the files listed yet.