Page 5 of 7 FirstFirst ... 34567 LastLast
Results 41 to 50 of 69

Thread: Linux Ubuntu 9.04 with Vixen

  1. #41
    Join Date
    Jan 2010
    Location
    New Zealand
    Posts
    256
    Post Thanks / Like

    Default Re: Linux Ubuntu 9.04 with Vixen

    I tried Googling for 'endiswrapper' -- it looks to me that this is just a typo for 'ndiswrapper'

    Regarding installing ndiswrapper... I tried
    frank@ubuntu:~$ sudo apt-get install ndiswrapper
    [sudo] password for frank:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Couldn't find package ndiswrapper
    frank@ubuntu:~$ ^C
    frank@ubuntu:~$
    However, the Synaptic Package Manager does list

    ndisgtk
    ndiswrapper-common
    ndiswrapper-utils-1.9

    but not ndiswrapper itself.

    Trying to install these via Synaptic resulted in a request for the Ubuntu install CD-ROM. I needed to tell Synaptic not to install from the CDROM to avoid that.

    My interpretation is that ndiswrapper must therefore be included in the Ubuntu installation already.

    Once the above 3 utils are installed, it all looks to be to do with WiFi Network drivers ???? I don't see the relevance to Vixen.


    A new release of Wine (v1.2) became available during the last week. However. I can't get Vixen running on it or the previous version as suggested waaaay back...

    Quote Originally Posted by Aurbo99 View Post
    Use this option for easy installation of .NET 2.0 Framework. Winetricks will take care of all needed installation prerequisites and work around some problems.

    $ wget http://kegel.com/wine/winetricks
    $ sh winetricks corefonts dotnet20

    Vixen appears to work fine so far as I created a typical sequence.
    I tried winetricks as above... it does seem to be important to be in your ~/.wine/dosdevices/c:/ directory when you run it. And that you DON'T run it via sudo. If not, it can't find the necessary directories. It's also important to get the very latest version of winetricks... VERSION=20100424 seems to work, whereas the earlier one I tried didn't install dotnetfx20.

    But even then, Vixen wouldn't run... the splash screen comes up, then it pops up an error window that says "Error when loading UI plugin from LedTriksUI: Exception has been thrown by the target of an invocation". I told it to Continue anyway, and then it wanted to update itself. Fine... it downloaded v2.1.4.0 (perhaps??? it certainly deleted Vixen.exe), and wanted to restart, but instead up came another error popup (File not found). This time clicking Continue didn't do anything Telling it not to update itself also didn't help
    Last edited by frankv; 04-24-2010 at 11:08 PM. Reason: The above was posted in several sections, editing as I tried things out.

  2. #42
    Join Date
    Dec 2009
    Location
    Whyalla, South Australia, Australia
    Posts
    858
    Post Thanks / Like

    Default Re: Linux Ubuntu 9.04 with Vixen

    i have exactly the same problems
    Last edited by smartalec; 04-24-2010 at 09:54 PM.
    Over 50000ch last yr

  3. #43
    Join Date
    Dec 2009
    Location
    Cranberry Twp., PA
    Posts
    167
    Post Thanks / Like

    Default Re: Linux Ubuntu 9.04 with Vixen

    At least it's not just me having the same problem. I am running the 64 bit version of 9.10 that can be a little tricky at times. Is anybody having the problems loading nidwrapper also running 64 bit?

  4. #44
    Join Date
    Dec 2009
    Location
    Whyalla, South Australia, Australia
    Posts
    858
    Post Thanks / Like

    Default Re: Linux Ubuntu 9.04 with Vixen

    im running a 32bit system, did'nt see the reason to go 64bit
    running ubuntu beats winblows hands down.

    just installed the ndis stuff from the installer.


    now hows is this going to get vixen working on ubuntu?
    Last edited by smartalec; 04-25-2010 at 02:24 AM.
    Over 50000ch last yr

  5. #45
    Join Date
    Jan 2010
    Location
    New Zealand
    Posts
    256
    Post Thanks / Like

    Default Re: Linux Ubuntu 9.04 with Vixen

    OK, first the good news...

    I have Vixen running with Wine.

    The bad news...

    1. What I have working is Vixen 2.5.0.0, which is (I guess) a development rather than stable version. But this is probably good news, since they expect to release Vixen 2.5 before next Xmas.

    2. I started trying installing more and more likely suspects through winetricks. I can't remember which one(s) got everything working. FWIW, below is the output from that last winetricks run. Of course, it may be that one of the earlier winetricks runs may have installed something that was also necessary for Vixen.

    Executing wget -O WindowsXP-KB975337-x86-ENU.exe -nd -c --read-timeout=300 --retry-connrefused --header Accept-Encoding: gzip,deflate http://download.microsoft.com/downlo...37-x86-ENU.exe
    --2010-04-25 20:29:30-- http://download.microsoft.com/downlo...37-x86-ENU.exe
    Resolving download.microsoft.com... 203.109.252.145, 203.109.252.138
    Connecting to download.microsoft.com|203.109.252.145|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 872816 (852K) [application/octet-stream]
    Saving to: `WindowsXP-KB975337-x86-ENU.exe'

    100%[======================================>] 872,816 163K/s in 6.2s

    2010-04-25 20:29:37 (137 KB/s) - `WindowsXP-KB975337-x86-ENU.exe' saved [872816/872816]

    Executing wine /home/frank/.winetrickscache/WindowsXP-KB975337-x86-ENU.exe /extract:c:\winetrickstmp /q
    fixme:advapi:DecryptFileA "c:\\winetrickstmp\\" 00000000
    Executing cp /home/frank/.wine/dosdevices/c:/winetrickstmp/asms/10/msft/windows/gdiplus/gdiplus.dll /home/frank/.wine/dosdevices/c:/windows/system32/
    Using native override for following DLLs: gdiplus
    Executing early_wine regedit c:\winetrickstmp\override-dll.reg
    Install of gdiplus done
    Install of hosts done
    Executing wget -O InstMsiA.exe -nd -c --read-timeout=300 --retry-connrefused --header Accept-Encoding: gzip,deflate http://download.microsoft.com/downlo...S/InstMsiA.exe
    --2010-04-25 20:29:40-- http://download.microsoft.com/downlo...S/InstMsiA.exe
    Resolving download.microsoft.com... 203.109.252.138, 203.109.252.145
    Connecting to download.microsoft.com|203.109.252.138|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 1709160 (1.6M) [application/octet-stream]
    Saving to: `InstMsiA.exe'

    100%[======================================>] 1,709,160 175K/s in 10s

    2010-04-25 20:29:51 (166 KB/s) - `InstMsiA.exe' saved [1709160/1709160]

    Setting Windows version to win98
    Executing early_wine regedit c:\winetrickstmp\set-winver.reg
    Executing wine /home/frank/.winetrickscache/InstMSIA.exe
    fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
    fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
    Failed to rename /home/frank/.local/share/mime/audio/x-ogg.xml.new as /home/frank/.local/share/mime/audio/x-ogg.xml , errno: 2

    fixme:storage:create_storagefile Storage share mode not implemented.
    fixme:imagehlp:BindImageEx (0, "C:\\windows\\system32\\msisip.dll", "C:\\windows\\system32\\;C:\\windows\\system32\\;C :\\windows\\system32", (null), (nil)): stub
    fixme:imagehlp:BindImageEx (0, "C:\\windows\\system32\\msihnd.dll", "C:\\windows\\system32\\;C:\\windows\\system32\\;C :\\windows\\system32", (null), (nil)): stub
    fixme:imagehlp:BindImageEx (0, "C:\\windows\\system32\\msiexec.exe", "C:\\windows\\system32\\;C:\\windows\\system32\\;C :\\windows\\system32", (null), (nil)): stub
    fixme:imagehlp:BindImageEx (0, "C:\\windows\\system32\\msi.dll", "C:\\windows\\system32\\;C:\\windows\\system32\\;C :\\windows\\system32", (null), (nil)): stub
    fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
    fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
    fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
    Using native,builtin override for following DLLs: msi msiexec.exe
    Executing early_wine regedit c:\winetrickstmp\override-dll.reg
    Clearing Windows version back to default
    Executing early_wine regedit c:\winetrickstmp\unset-winver.reg
    Install of msi2 done
    Executing wget -O MSMASK32.CAB -nd -c --read-timeout=300 --retry-connrefused --header Accept-Encoding: gzip,deflate http://activex.microsoft.com/controls/vb6/MSMASK32.CAB
    --2010-04-25 20:29:58-- http://activex.microsoft.com/controls/vb6/MSMASK32.CAB
    Resolving activex.microsoft.com... 65.55.13.243
    Connecting to activex.microsoft.com|65.55.13.243|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 89928 (88K) [application/octet-stream]
    Saving to: `MSMASK32.CAB'

    100%[======================================>] 89,928 71.3K/s in 1.2s

    2010-04-25 20:30:00 (71.3 KB/s) - `MSMASK32.CAB' saved [89928/89928]

    Executing /usr/bin/cabextract --directory=/home/frank/.wine/dosdevices/c:/winetrickstmp /home/frank/.winetrickscache/MSMASK32.CAB
    /home/frank/.winetrickscache/MSMASK32.CAB: WARNING; possible 5952 extra bytes at end of file.
    Extracting cabinet: /home/frank/.winetrickscache/MSMASK32.CAB
    extracting /home/frank/.wine/dosdevices/c:/winetrickstmp/msmask32.ocx
    extracting /home/frank/.wine/dosdevices/c:/winetrickstmp/msmask32.inf

    All done, no errors.
    Executing cp -f /home/frank/.wine/dosdevices/c:/winetrickstmp/msmask32.ocx /home/frank/.wine/dosdevices/c:/windows/system32/msmask32.ocx
    Executing wine regsvr32 msmask32.ocx
    Successfully registered DLL msmask32.ocx
    Install of msmask done
    Executing wget -O paintnt.exe -nd -c --read-timeout=300 --retry-connrefused --header Accept-Encoding: gzip,deflate http://download.microsoft.com/downlo...us/paintnt.exe
    --2010-04-25 20:30:00-- http://download.microsoft.com/downlo...us/paintnt.exe
    Resolving download.microsoft.com... 203.109.252.138, 203.109.252.145
    Connecting to download.microsoft.com|203.109.252.138|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 1206048 (1.1M) [application/octet-stream]
    Saving to: `paintnt.exe'

    100%[======================================>] 1,206,048 160K/s in 10s

    2010-04-25 20:30:12 (116 KB/s) - `paintnt.exe' saved [1206048/1206048]

    Executing /usr/bin/unzip /home/frank/.winetrickscache/paintnt.exe -d /home/frank/.wine/dosdevices/c:/windows
    Archive: /home/frank/.winetrickscache/paintnt.exe
    inflating: /home/frank/.wine/dosdevices/c:/windows/MSPAINT.EXE
    inflating: /home/frank/.wine/dosdevices/c:/windows/MFC42.DLL
    inflating: /home/frank/.wine/dosdevices/c:/windows/MFC42U.DLL
    inflating: /home/frank/.wine/dosdevices/c:/windows/MSVCRT.DLL
    inflating: /home/frank/.wine/dosdevices/c:/windows/OLEPRO32.DLL
    inflating: /home/frank/.wine/dosdevices/c:/windows/README.TXT
    ------------------------------------------------------
    Paint is now installed to /home/frank/.wine/dosdevices/c:/windows/MSPAINT.EXE
    ------------------------------------------------------
    Install of mspaint done
    Executing wget -O sct10en.exe -nd -c --read-timeout=300 --retry-connrefused --header Accept-Encoding: gzip,deflate http://download.microsoft.com/downlo...fe/sct10en.exe
    --2010-04-25 20:30:17-- http://download.microsoft.com/downlo...fe/sct10en.exe
    Resolving download.microsoft.com... 203.109.252.138, 203.109.252.145
    Connecting to download.microsoft.com|203.109.252.138|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 201712 (197K) [application/octet-stream]
    Saving to: `sct10en.exe'

    100%[======================================>] 201,712 173K/s in 1.1s

    2010-04-25 20:30:19 (173 KB/s) - `sct10en.exe' saved [201712/201712]

    Executing /usr/bin/cabextract --directory=/home/frank/.wine/dosdevices/c:/winetrickstmp /home/frank/.winetrickscache/sct10en.exe
    Extracting cabinet: /home/frank/.winetrickscache/sct10en.exe
    extracting /home/frank/.wine/dosdevices/c:/winetrickstmp/advpack.dll
    extracting /home/frank/.wine/dosdevices/c:/winetrickstmp/msscript.cnt
    extracting /home/frank/.wine/dosdevices/c:/winetrickstmp/msscript.hlp
    extracting /home/frank/.wine/dosdevices/c:/winetrickstmp/msscript.ocx
    extracting /home/frank/.wine/dosdevices/c:/winetrickstmp/sct10en.inf
    extracting /home/frank/.wine/dosdevices/c:/winetrickstmp/w95inf16.dll
    extracting /home/frank/.wine/dosdevices/c:/winetrickstmp/w95inf32.dll

    All done, no errors.
    Executing cp -f /home/frank/.wine/dosdevices/c:/winetrickstmp/msscript.ocx /home/frank/.wine/dosdevices/c:/windows/system32
    Executing wine regsvr32 msscript.ocx
    Successfully registered DLL msscript.ocx
    Install of msscript done
    Executing wget -O msxml3.msi -nd -c --read-timeout=300 --retry-connrefused --header Accept-Encoding: gzip,deflate http://download.microsoft.com/downlo...3dd/msxml3.msi
    --2010-04-25 20:30:20-- http://download.microsoft.com/downlo...3dd/msxml3.msi
    Resolving download.microsoft.com... 203.109.252.138, 203.109.252.145
    Connecting to download.microsoft.com|203.109.252.138|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 1070592 (1.0M) [application/octet-stream]
    Saving to: `msxml3.msi'

    100%[======================================>] 1,070,592 149K/s in 7.5s

    2010-04-25 20:30:29 (139 KB/s) - `msxml3.msi' saved [1070592/1070592]

    Using native,builtin override for following DLLs: msxml3
    Executing early_wine regedit c:\winetrickstmp\override-dll.reg
    Executing wine msiexec /i /home/frank/.winetrickscache/msxml3.msi
    fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
    ------------------------------------------------------
    Note: command 'wine msiexec /i /home/frank/.winetrickscache/msxml3.msi' returned status 103. Aborting.
    ------------------------------------------------------
    frank@ubuntu:~/.wine/drive_c$
    Maybe someone else can work through the winetricks list methodically, trying each package one by one to try to identify which one is the right one.

    Alternatively, someone in a hurry could try telling winetricks to install *all* the packages and it might work.

    In the meantime, I think *I* have it working.

    Oh, and for slovanredneck's information, I'm running a pre 32-bit system. I'm pretty sure the whole ndiswrapper thing was (for me) just a total red herring.

  6. #46
    Join Date
    Dec 2009
    Location
    Whyalla, South Australia, Australia
    Posts
    858
    Post Thanks / Like

    Default Re: Linux Ubuntu 9.04 with Vixen

    version 2.5.0.8 is what i seem to have working,
    its says there's a problem with ledtricks when loading, but that wont bother me.
    i still have'nt tryed to get the usb-rs485 working with it yet, but thats my next challange,
    i dont mind if it semi works on my ubuntu machine so long as i can edit my sequances an copy them over to the vixen laptop, i'll be happy

    but i now have less errors since i installed that ndis* from the gui installer
    Over 50000ch last yr

  7. #47
    Join Date
    Jan 2010
    Location
    New Zealand
    Posts
    256
    Post Thanks / Like

    Default Re: Linux Ubuntu 9.04 with Vixen

    Quote Originally Posted by smartalec View Post
    its says there's a problem with ledtricks when loading, but that wont bother me.
    Sorry, yes, it does that for me too. And it's also no problem for me. And I've also moved to 2.5.0.8, for no particular reason other than later releases are usually better than earlier ones.

    Now, to start learning how to drive Vixen.... and assemble my Renard boards, and connect some lights to them. Dunno if I can get it all done by Xmas. lol

  8. #48
    Join Date
    Dec 2009
    Location
    Whyalla, South Australia, Australia
    Posts
    858
    Post Thanks / Like

    Default Re: Linux Ubuntu 9.04 with Vixen

    are you able to see any serial ports in vixen
    cause im unable too.

    im using a usb to rs485 converter, but that should'nt make a differance.
    i just think ubuntu cant find any serial ports full stop

    i'll keep hacking away at it. i might find something
    Over 50000ch last yr

  9. #49
    Join Date
    Dec 2009
    Location
    Whyalla, South Australia, Australia
    Posts
    858
    Post Thanks / Like

    Default Re: Linux Ubuntu 9.04 with Vixen

    i can see the serial port when i go into a terminal
    an type
    dmesg | grep tty

    Edit:- did more research

    an wine does'nt recolonise serial ports like windows normally does

    this is how i got my usb serial port id'ed in windows

    ln -s /dev/ttyUSB0 ~/.wine/dosdevices/com1

    but sadly vixen couldn't find it..

    so im thinking i might need more research again..
    tipical windows, even on linux it still causes problems..lol
    Last edited by smartalec; 04-25-2010 at 08:09 AM.
    Over 50000ch last yr

  10. #50
    Join Date
    Jan 2010
    Location
    New Zealand
    Posts
    256
    Post Thanks / Like

    Default Re: Linux Ubuntu 9.04 with Vixen

    I haven't yet started doing anything inside Vixen, so don't know about the serial issue. Will let you know when I get to that.

Page 5 of 7 FirstFirst ... 34567 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •