Results 1 to 9 of 9

Thread: Kulp K8-PB and xLights NEWBIE Lights not coming on.

  1. #1
    Join Date
    Nov 2021
    Posts
    22
    Post Thanks / Like

    Default Kulp K8-PB and xLights NEWBIE Lights not coming on.

    This is my first year with pixel lights and using a controller. I had issues initially with networking and getting the controller to see network and xLights to discover controller using a usb to beagle board for setup. That was resolved with a USB to router adapter and now K8-PB is discoverable in xLights and shows green light that its working in xLights. My problem is after setting up a string of WS2811 fifty pixel lights in layout, setting port to 1, and creating a sequence and effect for the pixel lights, and turning lightbulb icon on/yellow with up arrow i do not get any output to pixel lights. I did test lights on control board, by pushing test button on Kulp PCB board and the led's do work in test mode. I am sure its something simple but I am not just seeing what's got me. I appreciate your help or suggestions. David

  2. #2
    Join Date
    Jan 2021
    Posts
    482
    Post Thanks / Like

    Default Re: Kulp K8-PB and xLights NEWBIE Lights not coming on.

    There is also a Tool->Test menu in xLights, and it works pretty much exactly like the Self-Test on the FPP page. That is an intermediate step you can try, before trying the yellow Light Bulb icon.

  3. #3
    Join Date
    Jan 2021
    Posts
    201
    Post Thanks / Like

    Default Re: Kulp K8-PB and xLights NEWBIE Lights not coming on.

    Make sure the controller is in bridge mode, else output to lights won’t work. You can change that in FPP or on the controller itself via the oled screen.


    Sent from my iPhone using Tapatalk

  4. #4
    Join Date
    Nov 2021
    Posts
    22
    Post Thanks / Like

    Default Re: Kulp K8-PB and xLights NEWBIE Lights not coming on.

    Quote Originally Posted by 1pet2_9 View Post
    There is also a Tool->Test menu in xLights, and it works pretty much exactly like the Self-Test on the FPP page. That is an intermediate step you can try, before trying the yellow Light Bulb icon.
    Thanks for suggestion. I tried testing from xLights and lights do not come on but test does work from K8-PB controller.

  5. #5
    Join Date
    Nov 2021
    Posts
    22
    Post Thanks / Like

    Default Re: Kulp K8-PB and xLights NEWBIE Lights not coming on.

    Quote Originally Posted by rsegreto View Post
    Make sure the controller is in bridge mode, else output to lights won’t work. You can change that in FPP or on the controller itself via the oled screen.


    Sent from my iPhone using Tapatalk
    Thanks for reply. I put in bridge mode through FPP but still not outputting. Also I got a reply from kulp tech support and here is that exchange...

    ME: I have made some progress. I purchased a USB to network cable and now the controller is recognizing the network. I have pixel lights wired up and the test button works to light led's. I am setting up K8-PB in xLights software and it is now discoverable on the network with xLights discover controller button. But when I test I am not getting lights to come on. Which K8-PB protocol should I use with xLights (E131, Artnett or DDP)? Thanks.

    Daniel: I’d definitely use DDP. However, by default, the controller is not setup to “listen” for any incoming data. You need to go to the Channel Inputs page and click the “Enable” button and hit save. That will enable the listening for DDP data. You’d need to configure the String on the K8-PB page as well for the right channel ranges and such.

    I looked at what he suggested and tried using DDP. I did have the input enable selected as he asked about and still no light output in xLights.

  6. #6
    Join Date
    Nov 2021
    Posts
    22
    Post Thanks / Like

    Default Re: Kulp K8-PB and xLights NEWBIE Lights not coming on.

    I thought it was in Bridge mode but I don't think it is. I am not finding that now in the FPP and in the controller using the menu for mode it only gives the option for player or remote. I included a screen shot of what I found in user manual and of the controller screen and options... I am not sure why it's not an option. Thanks
    IMG_2183.jpg
    Screen Shot 2021-12-03 at 9.04.21 PM.jpg
    Last edited by daveblueeyes67; 12-03-2021 at 11:23 PM.

  7. #7
    Join Date
    Dec 2015
    Posts
    43
    Post Thanks / Like

    Default Re: Kulp K8-PB and xLights NEWBIE Lights not coming on.

    I just posted a very similar reply to another thread earlier today:

    I just migrated to FPPs this year (from mostly pixel sticks) so just went through a lot of the issues you're going through.

    In xLights:
    Setup your FPP controller like this:
    Auto Layout Models: Yes
    Auto Size: Yes
    Auto Upload Configuration: Yes (in the screenshot, I have it unchecked, but you need to have it checked - I have xLights on multiple computers, and not all of them have my current layout on them so i don't want the old layout being uploaded to the controllers by accident)
    Active: xLights only - this tells xLights that when you're testing from xLights, the controller will be receiving the data by DDP, but when you upload the sequence to the FPP to play when it's all done, the controller will be playing out that data directly from the sequence file on the local storage

    xlights_controller_setup.jpg

    Then, select the controller, and press "Visualise" button at the bottom - drag your model to the right controller port. Save your controllers, and save your layout at this point.

    xlights_visualize.png

    Go to the FPP controller webpage. There is no "bridge mode" anymore in the newest firmware (V 5.x) - the controller can act as a bridge in either player or remote mode. You do this by going to Input/Output Setup -> Channel Inputs. If you have the FPP setup as DDP protocol in xLights, all you need to do is check the "Enable Input" box, save, and restart FPPD. Now the player will take DDP input and bridge it to the lights if xLights is sending anything. It will do this in either mode (player or remote) if the enable box is checked. If you're using DDP, you don't need to add any actual inputs to the list - that is more for E1.31 or ArtNet (which I would encourage you to not use - DDP is a much more efficient protocol)

    fpp_input_configuration.png

    Now go to your sequencer and drag any effect to your model. Hit the enable light output button - this is when xLights actually updates the configuration on the controller to match what's in xLights. If everything is right, you will have your effect on the lights!

    Also, you're looking at a really old version of the FPP manual. It's actually really difficult to find the latest FPP manual using a google search (because there are so many links to the old one around, and almost none to the new one). In the FPP controller webpage, go to Help -> FPP manual - that will link you to the current manual, which is quite different than the V2.2 manual you showed a screenshot of above.

    You can also check your channel outputs to make sure they match what you see in xLights - the channel numbers of each port are really important - if they don't match what's in xLights, nothing will work properly:
    fpp_output_configuration.png
    xlights_controller_match.jpg
    Last edited by bobsmith; 12-04-2021 at 06:09 AM.

  8. #8
    Join Date
    Nov 2021
    Posts
    22
    Post Thanks / Like

    Default Re: Kulp K8-PB and xLights NEWBIE Lights not coming on.

    Thank you for your help! It helped me understand quite a bit more and lead me to success! I did exactly what you said multiple times and it didn't work. But that confidently lead me to look at other things to discover the problem. I went into xLights preferences and discovered the light output address was not my Kulp controller address. I am using the Mac xLights version so I don't know if that is something that is suppose to auto populate and didn't or if has to be manually entered. I guess its kinda obvious it has to be the right IP address but I had no idea to look there and just found it by accident. But seriously THANK YOU for your help. Light are now working!

    Screen Shot 2021-12-04 at 10.01.14 AM.jpg
    Last edited by daveblueeyes67; 12-04-2021 at 12:14 PM.

  9. #9
    Join Date
    Dec 2015
    Posts
    43
    Post Thanks / Like

    Default Re: Kulp K8-PB and xLights NEWBIE Lights not coming on.

    I've never even seen that dialog in xLights, and I run the linux version (which should be really similar to the Mac version) - where is that dialog?

    So your source IP was wrong? Or it was using the wrong network interface to send data on?

    Edited: oh yeah, I see it there under preferences now - it lets you chose which network interface to send light data out on if you have more than one. I only have a wired ethernet interface and the loopback interface, so it works fine for me to just leave it blank, and it does the right thing.
    Last edited by bobsmith; 12-04-2021 at 03:39 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •