Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: wierd Ws2811 pixel issues flicker Ray Wu

  1. #1
    Join Date
    Nov 2019
    Location
    Vancouver, BC, Canada
    Posts
    36
    Post Thanks / Like

    Question wierd Ws2811 pixel issues flicker Ray Wu

    Hello, and happy 2021 setup.

    I have been running my e682 and Ray wus 5v ws2811 pixels for 2 seasons now. I recently just did another larger order from him to build my spiral trees. I am having a weird flicker issue with these. I am running version 5 on the e682. all my other lights work fine.

    I have 4 trees, all built the same, power injected @ every 50 pixels. One tree is made with the original order LED from 2 years ago, then there are 3 more with the new LEDs. What is happening is that the old LED tree is working perfect, but the other trees are all having a slight flicker at certain settings. originally I thought maybe it was power related, but its not that. solid colors tend to be fine, but when you change to white it is more evident. 50% white they flash then at 25% little less. but if you unplug 3 trees and leave one on it still does this.

    any idea of why this is happening

  2. #2
    Join Date
    Dec 2012
    Location
    Newtown CT
    Posts
    5,640
    Post Thanks / Like

    Default Re: wierd Ws2811 pixel issues flicker Ray Wu

    Not sure but I took my new matrix made from Ray Wu pixels down because it was flickering. Sometimes a pixel would stop forwarding data (looked dead). Then it would start working again. Annoying. Tried a new PSU, all the tricks for better data etc but nothing worked. Now it sits in the basement.


    2021 New Tune-to sign. New 40x27 matrix at the house. Retiring the Strip based matrix. Updating some of the old window frames to the new house. Adding two new songs.
    2020 Full sized show reworked for the new location. Only adding (famous last words) 13 RBLs that I finally got converted to using pixels
    2019 - Just moved into a new home (yet another change of plans). Will be dim but not dark. Too much to do at the new place to leave time for a show. Dim show (3000 pixels) had regular visits most nights.
    https://www.youtube.com/user/MartinMueller2003

  3. #3
    Join Date
    Jan 2014
    Posts
    292
    Post Thanks / Like

    Default Re: wierd Ws2811 pixel issues flicker Ray Wu

    Quote Originally Posted by MartinMueller2003 View Post
    Not sure but I took my new matrix made from Ray Wu pixels down because it was flickering. Sometimes a pixel would stop forwarding data (looked dead). Then it would start working again. Annoying. Tried a new PSU, all the tricks for better data etc but nothing worked. Now it sits in the basement.
    This sounds like a timing protocol issue with the ws2811 chip. Have you tried adjusting the timing to see if this resolved the flickering?

  4. #4
    Join Date
    Nov 2019
    Location
    Vancouver, BC, Canada
    Posts
    36
    Post Thanks / Like

    Default Re: wierd Ws2811 pixel issues flicker Ray Wu

    Yes, currently run everything at 300 with no issues. These one are ok at solid color, but main issue, when white.

  5. #5
    Join Date
    Nov 2019
    Location
    Vancouver, BC, Canada
    Posts
    36
    Post Thanks / Like

    Default Re: wierd Ws2811 pixel issues flicker Ray Wu

    Quote Originally Posted by EE351 View Post
    This sounds like a timing protocol issue with the ws2811 chip. Have you tried adjusting the timing to see if this resolved the flickering?
    Yes, currently run everything at 300 with no issues. These one are ok at solid color, but main issue, when white.

  6. #6
    Join Date
    Dec 2012
    Location
    Newtown CT
    Posts
    5,640
    Post Thanks / Like

    Default Re: wierd Ws2811 pixel issues flicker Ray Wu

    Quote Originally Posted by EE351 View Post
    This sounds like a timing protocol issue with the ws2811 chip. Have you tried adjusting the timing to see if this resolved the flickering?
    That would be a potential issue if the first pixel were consistently the problem. In my case I use 300us interframe gap. The first pixel almost always works fine. the flickering generally starts a little way down the line. I agree it looks a lot like a timing issue and I suspect these pixels are an attempted redesign of the failed pixel design Ray Wu tried to sell last year. At this point I would say the design is not stable between pixels on a string. I am just sorry I bought two thousand of these duds. FYI: Vampire measured Voltage at various parts of the string and it is at 4.95v almost anywhere on the string at flickering white. Remember I powerinject every 25 pixels so I generally do not have power issues in my design. And turning down the intensity does not help.


    2021 New Tune-to sign. New 40x27 matrix at the house. Retiring the Strip based matrix. Updating some of the old window frames to the new house. Adding two new songs.
    2020 Full sized show reworked for the new location. Only adding (famous last words) 13 RBLs that I finally got converted to using pixels
    2019 - Just moved into a new home (yet another change of plans). Will be dim but not dark. Too much to do at the new place to leave time for a show. Dim show (3000 pixels) had regular visits most nights.
    https://www.youtube.com/user/MartinMueller2003

  7. #7
    Join Date
    Feb 2018
    Posts
    91
    Post Thanks / Like

    Default Re: wierd Ws2811 pixel issues flicker Ray Wu

    Out of curiosity, how are you running your show / testing your pixels?
    I too have the E682. Are you using the built in firmware to test your pixels?
    Are you using a Pi FPP? If so, do you have any output processors running?

    I just recently purchased Ray Wu Pixels as well. These new props push my 29A power supply to just over 27A. So, to side on safety, I added an output processor of 90% to my FPP setup and now the new Ray Wu pixels flicker. Turn off the output processor and they seem to work fine.
    Last edited by Cmndr Brain; 12-03-2021 at 09:21 AM.

  8. #8
    Join Date
    Dec 2012
    Location
    Newtown CT
    Posts
    5,640
    Post Thanks / Like

    Default Re: wierd Ws2811 pixel issues flicker Ray Wu

    In my case I use the RonP PI Hat on an FPP at 100%


    2021 New Tune-to sign. New 40x27 matrix at the house. Retiring the Strip based matrix. Updating some of the old window frames to the new house. Adding two new songs.
    2020 Full sized show reworked for the new location. Only adding (famous last words) 13 RBLs that I finally got converted to using pixels
    2019 - Just moved into a new home (yet another change of plans). Will be dim but not dark. Too much to do at the new place to leave time for a show. Dim show (3000 pixels) had regular visits most nights.
    https://www.youtube.com/user/MartinMueller2003

  9. #9
    Join Date
    Jan 2014
    Posts
    292
    Post Thanks / Like

    Default Re: wierd Ws2811 pixel issues flicker Ray Wu

    This is a little concerning. I was planning on placing an order for pixels that will be permanently mounted to my eaves using j-channel, but I may have to reconsider if his pixels are not working correctly.

    This is a shame, as I have placed several orders with him in the past and haven't had any issues with products I've purchased through Ray.

  10. #10
    Join Date
    Dec 2012
    Location
    Newtown CT
    Posts
    5,640
    Post Thanks / Like

    Default Re: wierd Ws2811 pixel issues flicker Ray Wu

    Quote Originally Posted by EE351 View Post
    This is a little concerning. I was planning on placing an order for pixels that will be permanently mounted to my eaves using j-channel, but I may have to reconsider if his pixels are not working correctly.

    This is a shame, as I have placed several orders with him in the past and haven't had any issues with products I've purchased through Ray.
    Keep in mind that until I complete debugging this, the issue could turn out to very well NOT be the pixels. That and I am expressing frustration at this point. That should not be taken as fact. It would be good to hear from others that have purchased recently and may not be having any issues.


    2021 New Tune-to sign. New 40x27 matrix at the house. Retiring the Strip based matrix. Updating some of the old window frames to the new house. Adding two new songs.
    2020 Full sized show reworked for the new location. Only adding (famous last words) 13 RBLs that I finally got converted to using pixels
    2019 - Just moved into a new home (yet another change of plans). Will be dim but not dark. Too much to do at the new place to leave time for a show. Dim show (3000 pixels) had regular visits most nights.
    https://www.youtube.com/user/MartinMueller2003

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •