Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: Error when attemtping to flash ESPixelStick V3

  1. #11
    Join Date
    Oct 2021
    Location
    midwest
    Posts
    15
    Post Thanks / Like

    Default Re: Error when attemtping to flash ESPixelStick V3

    Quote Originally Posted by angus40 View Post
    I think your post will give Shelby a clue as to where to look at the issue in the tool . I have doubt it being a cable issue .
    hope so! Thanks

  2. #12
    Join Date
    Oct 2021
    Location
    midwest
    Posts
    15
    Post Thanks / Like

    Default Re: Error when attemtping to flash ESPixelStick V3

    Well I was able to test a brand new data micro usb cable and the same error results, ruling out a cable issue.

  3. #13
    Join Date
    Aug 2012
    Location
    Charleston, SC
    Posts
    1,198
    Post Thanks / Like

    Default Re: Error when attemtping to flash ESPixelStick V3

    Heya, sorry the delayed response. Yesterday got away from me and been at soccer games all day today. I'll get that vm loaded up tomorrow.
    forkineye.com

  4. #14
    Join Date
    Oct 2021
    Location
    midwest
    Posts
    15
    Post Thanks / Like

    Default Re: Error when attemtping to flash ESPixelStick V3

    Thank you very much. I look forward to seeing what the solution might be. Please let me know if there is anything I can do to aid in the process.

  5. #15
    Join Date
    Aug 2012
    Location
    Charleston, SC
    Posts
    1,198
    Post Thanks / Like

    Default Re: Error when attemtping to flash ESPixelStick V3

    I created a Mint 19.3 Cinnamon VM in Proxmox this morning. Only odd thing I've experienced so far is having to reboot after adding myself to the dialout group. In all my years of messing with Linux, I've never seen that occur. It was like my session was still being held in the background even though I'd logged out. After rebooting though, I was able to flash without issue. I haven't updated it yet, so will do that next and test again. Can you check which version of Python you're running? The flash tool that the frontend calls is Python based. I should be in the xLights Zoom room today as well if you have a chance to jump in and troubleshoot there.
    -shelby
    mint.jpg
    forkineye.com

  6. #16
    Join Date
    Oct 2021
    Location
    midwest
    Posts
    15
    Post Thanks / Like

    Default Re: Error when attemtping to flash ESPixelStick V3

    Quote Originally Posted by sporadic View Post
    I created a Mint 19.3 Cinnamon VM in Proxmox this morning. Only odd thing I've experienced so far is having to reboot after adding myself to the dialout group. In all my years of messing with Linux, I've never seen that occur. It was like my session was still being held in the background even though I'd logged out. After rebooting though, I was able to flash without issue. I haven't updated it yet, so will do that next and test again. Can you check which version of Python you're running? The flash tool that the frontend calls is Python based. I should be in the xLights Zoom room today as well if you have a chance to jump in and troubleshoot there.
    -shelby
    mint.jpg
    Wow, I didn't need to reboot after running usermod; curios indeed.
    Output of ls /usr/bin/python*:
    /usr/bin/python /usr/bin/python2.7 /usr/bin/python3.6 /usr/bin/python3.9
    /usr/bin/python2 /usr/bin/python3 /usr/bin/python3.6m /usr/bin/python3m

    It appears I have several versions of python installed.

    Output of python -V:
    Python 2.7.17

    Screenshot from 2021-10-25 08-43-58.png

    I am very new to this so am unsure of how to access the xLights Zoom room. Please let me know and I will try to attend. I can't thank you enough for your help. It is frustrating but also a fun challenge at the same time!
    Last edited by dbsmokey; 10-25-2021 at 09:44 AM.

  7. #17
    Join Date
    Aug 2012
    Location
    Charleston, SC
    Posts
    1,198
    Post Thanks / Like

    Default Re: Error when attemtping to flash ESPixelStick V3

    Quote Originally Posted by dbsmokey View Post
    Wow, I didn't need to reboot after running usermod; curios indeed.
    Output of ls /usr/bin/python*:
    /usr/bin/python /usr/bin/python2.7 /usr/bin/python3.6 /usr/bin/python3.9
    /usr/bin/python2 /usr/bin/python3 /usr/bin/python3.6m /usr/bin/python3m

    It appears I have several versions of python installed.

    Output of python -V:
    Python 2.7.17

    Screenshot from 2021-10-25 08-43-58.png

    I am very new to this so am unsure of how to access the xLights Zoom room. Please let me know and I will try to attend. I can't thank you enough for your help. It is frustrating but also a fun challenge at the same time!
    Well, I can verify that it breaks once Mint 19 is updated. Not sure why yet, but looking into it. Neither Python 2.7.17 or Python 3.6.9 are able to reset the chip into flash mode, so it seems to be something going on with Mint or the kernel in regards to serial port access and toggling the dtr/rts lines to throw it into flash mode.
    forkineye.com

  8. #18
    Join Date
    Aug 2012
    Location
    Charleston, SC
    Posts
    1,198
    Post Thanks / Like

    Default Re: Error when attemtping to flash ESPixelStick V3

    Ok, think I found out what's going on. Seems to be an issue with the CH340 driver that made its way into the kernel. According to this post, it should have been fixed and back-ported into the stable kernel releases - https://github.com/espressif/esptool...ment-905539861 / https://bugzilla.kernel.org/show_bug.cgi?id=214131#c8
    forkineye.com

  9. #19
    Join Date
    Oct 2021
    Location
    midwest
    Posts
    15
    Post Thanks / Like

    Default Re: Error when attemtping to flash ESPixelStick V3

    Quote Originally Posted by sporadic View Post
    Well, I can verify that it breaks once Mint 19 is updated. Not sure why yet, but looking into it. Neither Python 2.7.17 or Python 3.6.9 are able to reset the chip into flash mode, so it seems to be something going on with Mint or the kernel in regards to serial port access and toggling the dtr/rts lines to throw it into flash mode.
    Hmm...I have retried this in both an Ubuntu 18 VM and just today a Centos 8 VM. With both of those I get this error:

    Screenshot from 2021-10-25 10-24-59.png

    I cannot figure out what is going on!!

  10. #20
    Join Date
    Aug 2012
    Location
    Charleston, SC
    Posts
    1,198
    Post Thanks / Like

    Default Re: Error when attemtping to flash ESPixelStick V3

    From what I can tell, Linux Mint is just customized Ubuntu? Looks like they have it slated to be fixed in the next kernel release, 5.4.0-90 - https://launchpad.net/ubuntu/+source/linux/5.4.0-90.101. Not sure how far back you would have to revert Mint, but it's definitely a kernel issue. You won't be able to use a VM on top of it either unless you pass an entire USB controller (the PCI device) through, bypassing the USB drivers of your Mint install.
    Code:
        - Revert "USB: serial: ch341: fix character loss at high transfer rates"
    forkineye.com

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •