Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Vixen 3.8 released

  1. #11
    Join Date
    Mar 2015
    Location
    Kent, WA
    Posts
    29
    Post Thanks / Like

    Default Re: Vixen 3.8 released

    Sorry accidently wrong forum
    Attached Images Attached Images
    Last edited by skykicker; 09-13-2021 at 03:28 PM. Reason: wrong forum

  2. #12
    Join Date
    Nov 2011
    Location
    Chicago - Southwest Suburbs
    Posts
    8,290
    Post Thanks / Like

    Default Re: Vixen 3.8 released

    You should start a new thread for your arduino issues. That doesn't belong in an announcement thread. Vixen team doesn't do arduino development. That's not our specialty. We do Vixen, not hardware. Your arduino sketch development and troubleshooting probably belongs in the arduino category.

    One thing that sticks out is that your 3 sketches use 3 different baud rates. You only show one of the controller configs which is set to 115200 on com5. So that would hopefully be for the second sketch you posted.
    And another thing i can confirm from your screenshots is that none of your output modules are disabled. If they were, they'd have a red ball in front of them.
    The most common problems with serial based control, especially when using multiple ports, is that the devices are either not available when vixen tries to begin using them, or if the com port numbers change on the fly. When you're using multiple of the same type of device, windows has no way of knowing which is which. They all look identical to windows. So the com port numbering can vary every time you fire them up. Windows just assigns them in order as it discovers them. I've heard of guys who use power sequencing circuits that will power up USB serial devices one at a time in a specific order to help ensure that the port numbers come up the same way every time.

  3. #13
    Join Date
    Nov 2018
    Location
    Fairfax, Virginia
    Posts
    83
    Post Thanks / Like

    Default Re: Vixen 3.8 released

    My 3.8 seems to freeze when I click on edit preview. Could this be a computing power problem or is this a program problem?

  4. #14
    Join Date
    Nov 2011
    Location
    Chicago - Southwest Suburbs
    Posts
    8,290
    Post Thanks / Like

    Default Re: Vixen 3.8 released

    Quote Originally Posted by patmitchell View Post
    My 3.8 seems to freeze when I click on edit preview. Could this be a computing power problem or is this a program problem?
    That could go either way. Did it happen after recent changes to your profile, or is your profile the same as it used to be? Does it just sit there frozen or does it eventually crash? In any case, if it's reproducable, we'd like to dig into it further. If you could upload a copy of the profile (slimmed down without sequences or audio) to a google drive or similar and start a ticket on bugs.vixenlights.com, we'll take a look at it and see if we can figure it out.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •