Results 1 to 8 of 8

Thread: Espixelstick with vixen runst extreem slow

  1. #1
    Join Date
    Nov 2020
    Posts
    3
    Post Thanks / Like

    Default Espixelstick with vixen runst extreem slow

    Hi guys.
    I have a problem.

    I receive my espixelstick last week so i try to look what it can do, so i start up vixen and grap the stroboscoop tool and set it cylce time to 100.
    I discovered it runs very slow so i try cycle time 200 where it stil looks glitchy.
    So i tried x lights and there i can strobo what i want without any problems on any speed.

    But i really like using vixen so who can help me and tel me where the problem may be ?

    Kind regards

    Kermisbrian

  2. #2
    Join Date
    Dec 2012
    Location
    Newtown CT
    Posts
    4,942
    Post Thanks / Like

    Default Re: Espixelstick with vixen runst extreem slow

    This question should get moved to a Vixen thread. There is apparently nothing wrong with the PixelStick (aka controller) or the pixels. What version of Vixen are you using? What are the computer specifications for the machine playing the effect? How are you playing the effect?


    2020 Full sized show reworked for the new location. Only adding (famous last words) 13 RBLs that I finally got converted to using pixels
    2019 - Just moved into a new home (yet another change of plans). Will be dim but not dark. Too much to do at the new place to leave time for a show. Dim show (3000 pixels) had regular visits most nights.
    https://www.youtube.com/channel/UCyX...ttrsZNARkUce0Q

  3. #3
    Join Date
    Nov 2020
    Posts
    3
    Post Thanks / Like

    Default Re: Espixelstick with vixen runst extreem slow

    Hi Martin, No there is nothing wrong with the pixelstick i am extremely happy with it. Works amazing !

    I run the newest version of Vixen 3.7u4 and currently work it on boodcamp on my i mac with the following specs 3,5 GHz Intel Core i7 - 16 GB 1600 MHz DDR3 - VIDIA GeForce GTX 780M 4 GB.

  4. #4
    Join Date
    Feb 2017
    Location
    Ohio
    Posts
    60
    Post Thanks / Like

    Default Re: Espixelstick with vixen runst extreem slow

    Do you have more controllers configured in vixen than just the Pixelstick? I believe vixen will tend to lag if you have controllers configured and not connected.

    Thanks,
    Shawn

  5. #5
    Join Date
    Nov 2020
    Posts
    3
    Post Thanks / Like

    Default Re: Espixelstick with vixen runst extreem slow

    Hee Shawn the controller is connected with vixen.
    I play real-time with the lights connected to see if it all works.
    After trying out some stuff I figure out there is an update interval option in vixen that was set on 100. After setting it on 1 everything like to work fine and the problem is solved.
    Or is changing the update interval from 100 to 1 harmful for your computer or your led?

  6. #6
    Join Date
    Dec 2012
    Location
    Newtown CT
    Posts
    4,942
    Post Thanks / Like

    Default Re: Espixelstick with vixen runst extreem slow

    I run mine at 25ms. The lower the number, The higher the CPU load and the load on the network. You cant break anything but you can impact your wife using her tablet


    2020 Full sized show reworked for the new location. Only adding (famous last words) 13 RBLs that I finally got converted to using pixels
    2019 - Just moved into a new home (yet another change of plans). Will be dim but not dark. Too much to do at the new place to leave time for a show. Dim show (3000 pixels) had regular visits most nights.
    https://www.youtube.com/channel/UCyX...ttrsZNARkUce0Q

  7. #7
    Join Date
    Oct 2014
    Location
    Sauk City, WI USA
    Posts
    1,810
    Post Thanks / Like

    Default Re: Espixelstick with vixen runst extreem slow

    And to go along with that idea...does the controller have an appropiate number of channels defined on both Vixen and in the espixelstick?

  8. #8
    Join Date
    Nov 2011
    Location
    Chicago - Southwest Suburbs
    Posts
    8,271
    Post Thanks / Like

    Default Re: Espixelstick with vixen runst extreem slow

    Quote Originally Posted by kermisbrian View Post
    Hee Shawn the controller is connected with vixen.
    I play real-time with the lights connected to see if it all works.
    After trying out some stuff I figure out there is an update interval option in vixen that was set on 100. After setting it on 1 everything like to work fine and the problem is solved.
    Or is changing the update interval from 100 to 1 harmful for your computer or your led?
    The update interval should be at 50 as a default. You can experiment with lower values. But I would not recommend anything lower than 25ms. And even at 25ms, that requires a strong computer and will not scale well to a large show. The lower the value the more frequently the software will update state for all elements and controllers. It's not harmful in the sense that it will break something, but it will cause a lot of overhead for the system and will perform poorly.

    In general, there's no need for the update interval to be any lower than the desired framerate of your show. If you're aiming for a 40fps show, then 25ms is your value. With wireless, you'll also need to consider how frequently the access point will forward packets to your controller. Most APs have a default beacon interval of 100ms, so having your source transmit frames at more than half that interval will likely cause buffering at the AP.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •