Results 1 to 4 of 4

Thread: 3.7u3 Released

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Oct 2011
    Location
    Maryville, Illinois
    Posts
    1,935
    Post Thanks / Like

    Default 3.7u3 Released

    3.7u3 has been released. This release addresses a few bugs that were found recently. There is no new functionality so if you are not affected by one of these bugs, then updating is optional.

    The most notable bugs affect those that do not use a background picture in their preview or have used the Morph effect in location mode.


    Release Notes - Vixen 3 - 3.7u3 Build

    Improvement

    [VIX-2878] - Add bounds checking for preview items to ensure they are visible.
    [VIX-3016] - No size fields for custom props

    Bug

    [VIX-3006] - Off-center effects
    [VIX-3012] - Morph polygons not saving
    [VIX-3017] - Crash while aligning effects
    [VIX-3018] - Row zoom draws effects in the wrong location.

  2. #2
    Join Date
    Nov 2013
    Location
    Osceola, IN
    Posts
    335
    Post Thanks / Like

    Default Re: 3.7u3 Released

    As always, thank you Jeff and all the other brains behind Vixen!
    -Wife-certified nerd

  3. #3
    Join Date
    Oct 2015
    Posts
    9
    Post Thanks / Like

    Default Re: 3.7u3 Released

    Think I found a bug - Single Light object in previews aren't saved/retained... when I upgraded from 3.6 - POOF all items in the preview configured as "Single Light" are gone and don't come back. I can reproduce consistently.

    Setup Previews
    Configure Preview
    Select Single Light from Basic Drawing
    It draws a tiny dot, when I click Select to Select it, The properties window remains blank
    If I click on another object and click back to the single light, then I get properties (Bug 1)
    Once I set up a single light as a DMX RGB Par Can (Change Light Size to 25, String Type to Pixel, and I set the collection type to the Par Can)
    if I hit Save, Exit, OK, - it remains in the preview, but as soon as I go back to "Configure Preview" POOF all Single Lights are gone once again. They also disappear if I restart Vixen.

    So I think whenever the preview config is read/loaded, any Single Lights are wiped out.

  4. #4
    Join Date
    Oct 2011
    Location
    Maryville, Illinois
    Posts
    1,935
    Post Thanks / Like

    Default Re: 3.7u3 Released

    That one slipped through the cracks. We fixed it in a dev build a few days ago. The latest dev build is 3.7u3 with the fix for that issue. If no one reports anything further in the next few days we will likely release another with just that extra change.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •