Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: FPP Raspberry Pi 3B+ No Audio

  1. #1
    Join Date
    Sep 2007
    Location
    Valley Center, Ks
    Posts
    527
    Post Thanks / Like

    Default FPP Raspberry Pi 3B+ No Audio

    Everything worked fine last night. Today I was doing some testing to fix a few issues with pixels and other items. Got those fixed with the display testing page so I decided to play my playlist and no audio. I use the 3.5mm jack on the Pi to a FM transmitter. I have swapped out the Pi, FM transmitter, and audio cable and nothing fixes it. I was checking the FPP settings page (FPP V4.2) and the Audio Output Device setting only has dummy for a selection. Shouldn't I have some more settings like analog? I don't even see a FPP global settings page like the manual shows on page 38. Show runs in 4 1/2 hours. Ugh!!!!
    Dave-2990Px-20KLts

  2. #2
    Join Date
    Nov 2018
    Location
    Houston, Texas
    Posts
    2,077
    Post Thanks / Like

    Default Re: FPP Raspberry Pi 3B+ No Audio

    I never tried that jack. I use a soundblaster 3 via. USB port on pi


    Sent from my iPhone using Tapatalk

  3. #3
    Join Date
    Dec 2014
    Location
    Southern California
    Posts
    1,202
    Post Thanks / Like

    Default Re: FPP Raspberry Pi 3B+ No Audio

    Did you play the playlist from the status page?
    Kevin

  4. #4
    Join Date
    Sep 2007
    Location
    Valley Center, Ks
    Posts
    527
    Post Thanks / Like

    Default FPP Raspberry Pi 3B+ No Audio

    Quote Originally Posted by kev View Post
    Did you play the playlist from the status page?
    Yes and from the display test page as well


    Sent from my iPhone using Tapatalk
    Last edited by davdue; 11-28-2020 at 04:11 PM.
    Dave-2990Px-20KLts

  5. #5
    Join Date
    Dec 2012
    Location
    Newtown CT
    Posts
    4,931
    Post Thanks / Like

    Default Re: FPP Raspberry Pi 3B+ No Audio

    The issue is in the audio tab on the FPP Settings page. As long as Dummy is the only selection, you are stuck. If you are using the on board audio, you need to select the BCM.... audio device. If the device is not present then you have not enabled sound in the base PI configuration (Usually done for you by the FPP installer). I had my master PI lose the audio configuration yesterday. Not sure why or how. I went into PI Config and enabled my sound device (again) and then went into the FPP settings page to select my sound card (I use an audio DAC PI Hat).


    2020 Full sized show reworked for the new location. Only adding (famous last words) 13 RBLs that I finally got converted to using pixels
    2019 - Just moved into a new home (yet another change of plans). Will be dim but not dark. Too much to do at the new place to leave time for a show. Dim show (3000 pixels) had regular visits most nights.
    https://www.youtube.com/channel/UCyX...ttrsZNARkUce0Q

  6. #6
    Join Date
    Sep 2007
    Location
    Valley Center, Ks
    Posts
    527
    Post Thanks / Like

    Default FPP Raspberry Pi 3B+ No Audio

    Quote Originally Posted by MartinMueller2003 View Post
    The issue is in the audio tab on the FPP Settings page. As long as Dummy is the only selection, you are stuck. If you are using the on board audio, you need to select the BCM.... audio device. If the device is not present then you have not enabled sound in the base PI configuration (Usually done for you by the FPP installer). I had my master PI lose the audio configuration yesterday. Not sure why or how. I went into PI Config and enabled my sound device (again) and then went into the FPP settings page to select my sound card (I use an audio DAC PI Hat).
    Is Pi Config from the FPP GUI or from the python prompt? Can I get to it from the SSH shell from the help menu?


    Sent from my iPhone using Tapatalk
    Last edited by davdue; 11-28-2020 at 05:04 PM.
    Dave-2990Px-20KLts

  7. #7
    Join Date
    Sep 2007
    Location
    Valley Center, Ks
    Posts
    527
    Post Thanks / Like

    Default FPP Raspberry Pi 3B+ No Audio

    Is this where I need to put it back in? I tried to replace Dumm with BCM and it didnít work.




    Sent from my iPhone using Tapatalk
    Dave-2990Px-20KLts

  8. #8
    Join Date
    Dec 2012
    Location
    Newtown CT
    Posts
    4,931
    Post Thanks / Like

    Default Re: FPP Raspberry Pi 3B+ No Audio

    Make sure you have installed the latest version of FPP. Then you should set up the audio like the picture below. The FPP installer sets up all of the support files. I suggest formatting the SD card and then installing the FPP image using an image writer. The format step is important to ensure any lingering file issues are erased.
    Attached Images Attached Images

  9. #9
    Join Date
    Sep 2007
    Location
    Valley Center, Ks
    Posts
    527
    Post Thanks / Like

    Default FPP Raspberry Pi 3B+ No Audio

    So are saying I have to start over with the FPP install. This was working fine last night. I made no changes to the FPP today and it doesnít work. Something must have gotten corrupted. Since I only have dummy as a selection. What did you mean when you said you had to go into the Pi Config and re-enable the audio?


    Sent from my iPhone using Tapatalk
    Last edited by davdue; 11-28-2020 at 07:52 PM.
    Dave-2990Px-20KLts

  10. #10
    Join Date
    Dec 2012
    Location
    Newtown CT
    Posts
    4,931
    Post Thanks / Like

    Default Re: FPP Raspberry Pi 3B+ No Audio

    I have been using Linux for twenty years. I am comfortable walking through the various config tables when they get corrupted. When I do not know the level of Linux familiarity of the person I am talking to, I will recommend the safest route to getting an issue resolved. Here is what I have: You and I both experienced an issue with the sound on the PI. I noticed that my issue showed itself after an unusual hang in my FPP. When I investigated I found that critical 'SYSTEM' config information for my configuration had been deleted (no idea why). I went through the Linux tables and manually repaired them. I would hate to try to walk someone else through that process. I know that the latest Linux/FPP build sets up those tables properly. So here is what I am suggesting to you. Save your FPP config to your PC. Rebuild the FPP using the latest files from Falcon. Restore your config from your PC to the FPP. Correct any issues that may be in the config due to the corruption on the PI.

    The low level PI config is called raspi-config and you can find information about it here "https://www.raspberrypi.org/documentation/configuration/raspi-config.md". This program is executed in the linux shell as root. It allows you to set up the hardware and other features of the PI. In my case the busses I needed had gotten turned off and the control files in /etc had gotten changed. WARNING: Modifying settings using this utility can leave your PI unusable. Use at your own risk.


    2020 Full sized show reworked for the new location. Only adding (famous last words) 13 RBLs that I finally got converted to using pixels
    2019 - Just moved into a new home (yet another change of plans). Will be dim but not dark. Too much to do at the new place to leave time for a show. Dim show (3000 pixels) had regular visits most nights.
    https://www.youtube.com/channel/UCyX...ttrsZNARkUce0Q

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •