Results 1 to 5 of 5

Thread: ESPixelStick with 3.2 firmware won't join WiFi

  1. #1
    Join Date
    Sep 2015
    Posts
    3
    Post Thanks / Like

    Default ESPixelStick with 3.2 firmware won't join WiFi

    I have 7 ESPixelSticks that I had previously flashed with the 3.1 firmware and all were working fine. I put everything away for the summer and have just taken everything back out. I have a NetGear WNR2020 router dedicated to my show net, hardwired to my show laptop and to my FPP. I can connect (via browser) from the show laptop to the admin console of the router and to FPP. I had assigned static IP address to the ESPixelSticks and also told DHCP to reserve those addresses to avoid overlap in the future.

    5 of the ESpixelSticks happily joined the show net and I'm able to access their setup pages as well as send test patterns from FPP.

    The other 2 ESPixelSticks are not joining the WiFi. I plugged each back into the programmer cable and rebooted them using the little button on the D1 module, in the serial console it shows

    connecting to shownet as ESPixelStick
    Connecting with DHCP.......
    *** Failed to connect ***

    then it tries to connect to the default SSID

    and finally issues this error

    ets Jan 8 2013, rst code:2, boot mode3,7)

    I tried to refresh this module with the latest 3.2 code, same result

    I tried to change the SSID to both my home network and my guest network instead of the show network, but still can't associate
    I tried removing the password on the show net, and that did not help either.

    I have a few more PixelSticks that I haven't used yet, so I took the D1 module from a new one, and it also fails to associate.

    I also did a factory reset on the router, upgraded its firmware to the latest version, and reset the show net
    The 5 ESPixelSticks that work have connected fine, and I can connect to the show net from another laptop using the same credentials that I put in the Flash Tool

    Any help here would be appreciated

    thanks in advance
    Jay

  2. #2
    Join Date
    Sep 2015
    Posts
    3
    Post Thanks / Like

    Default Re: ESPixelStick with 3.2 firmware won't join WiFi

    Quick additional info

    1 of the PixelSticks that won't associate has a Static IP, the other is new and trying to connect with DHCP
    the static one does say in the serial console
    Connecting with Static IP

  3. #3
    Join Date
    Sep 2015
    Posts
    3
    Post Thanks / Like

    Default Re: ESPixelStick with 3.2 firmware won't join WiFi

    I don't have a solid explanation, but...

    I decided I was going to program another PixelStick with the DMX image, and it happily joined the show net.

    I went back and refreshed the 3 modules that were previously not joining the show net with the Pixel image, and now all have happily joined and successfully run a test pattern

    I guess the mere thought of having other people think about this made it work

    Happy Thanksgiving

  4. #4
    Join Date
    Oct 2015
    Location
    Hastings, New Zealand
    Posts
    103
    Post Thanks / Like

    Default Re: ESPixelStick with 3.2 firmware won't join WiFi

    I'm working through a similar issue. So you just reloaded the 3.2 pixel image?

  5. #5
    Join Date
    Oct 2015
    Location
    Hastings, New Zealand
    Posts
    103
    Post Thanks / Like

    Default Re: ESPixelStick with 3.2 firmware won't join WiFi

    I figured out my issue. I had to turn on dhcp in my rougher so it would connect. Now it works everytime. I'll turn it off when I've programmed them all for the show.

    Sent from my YAL-L21 using Tapatalk

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •