Results 1 to 3 of 3

Thread: Am I missing something for P5 matrix building "rules"?

  1. #1
    Join Date
    Nov 2014
    Location
    Close to Hillsboro, OR
    Posts
    600
    Post Thanks / Like

    Default Am I missing something for P5 matrix building "rules"?

    This is my 2nd year with P5 panels in my matrix. I've spent the last couple of months modifying and improving the box that holds the matrix, and after doing that and then testing/displaying I noticed something that is now making me a little nuts. I don't recall if this was happening this last year because I wasn't looking for it but now I can't help but notice this problem. In one corner, I've got 2 panels connected to 1 output from the BBB/Octoscroller, tied in series/daisy-chained. They output both video and effects, but I'm noticing that on some of the videos and effects there's a slight discoloration on some of the pixels or there's some "artifacting" going on, where some of the pixels just flicker in different colors. I've changed the power connection to those panels (as in moved the power connectors to different panels and moved the ones from the other panels to these), changed out the ribbon cable twice, swapped out Octoscrollers just in case it's the output connector, and even changed out the actual panels. Nothing has helped - it's still there.

    Then I remembered a couple comments in past threads and it got me thinking: are there certain 'rules' to follow in a P5 matrix, especially concerning ribbon cable length? Right now, the panels in question are connected to the BBB/Octo with a cable that is about 4.5 feet in length. Most of the other ribbon cable lengths are 3 feet or less. My entire matrix is driven by the Pi 3B+, running in Standalone mode, with the BBB set to Bridge - changing to Master and Remote doesn't help.

    I'm including the layout of my matrix in case there's something else I've missed. The output in question is Output 7. Thanks in advance for any advice/help.

    P5 layout.JPG
    Last edited by Stormyblade; 09-07-2020 at 05:42 AM. Reason: Rotated image

  2. #2
    Join Date
    Nov 2014
    Location
    Close to Hillsboro, OR
    Posts
    600
    Post Thanks / Like

    Default Re: Am I missing something for P5 matrix building "rules"?

    Well, I do have an update on this...I decided to go out and change my configuration, at least just a little. I know I've read that Dan Kulp recommended using as many outputs as possible on the Octoscroller, while keeping the number of outputs and panels per output balanced.

    I took out my 2 longest ribbon cables - the ones that stretched from the lower left corner to the upper right corner for outputs 7 & 8. I then told FPP that I've got 4 rows of 4 and the bottom row has 2 panels for each output. I fired up FPP player and it would appear that the issues I was facing have gone - no more artifacts or flickery pixels!

    Anyway, even though I think it's 'fixed', I would still like to know if there is some data or knowledge to back this up. Just because it appears to work for me now doesn't mean it won't come back.

    New layout.jpg
    Attached Images Attached Images

  3. #3
    Join Date
    Jan 2015
    Location
    Folsom, CA, USA
    Posts
    2,272
    Post Thanks / Like

    Default Re: Am I missing something for P5 matrix building "rules"?

    Quote Originally Posted by Stormyblade View Post
    ........Dan Kulp recommended using as many outputs as possible on the Octoscroller, while keeping the number of outputs and panels per output balanced
    I think you still need a little tuning to be balanced. Combing Output 6 (p1 & p2) with Output 5, making it P1, P2, P3, P4.
    Now all used outputs have 4 panels each.

    FPP-P5.jpg

    Did you see there is an update for FFF. Release 4.2 is out.
    Last edited by mrGrumpy; 09-07-2020 at 10:12 AM.
    In Lights Therapy

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •