Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Problems with a New Prop

  1. #1
    Join Date
    Jan 2012
    Location
    Chambersburg, PA
    Posts
    954
    Post Thanks / Like

    Default Problems with a New Prop - Solved!

    I added a small front porch to my house this summer and have built an "archway" consisting of 2 Boscoyo Chroma Poles of 300 pixels each and an 8x37 matrix in between. I have all 896 pixels being controlled from a single port on an ESPixelStick. When I test using the PixelStick effects everything works as expected, but when I take control from the RPi and FPP there seems to be lag when I run bars across the matrix. It changes 4 of the 8 pixels in a column, instead of the entire column at once. Also when I try to run Text across the matrix I am only seeing gibberish. The setup for the Matrix section of the archway is wired correctly in XLights and previews perfectly. I am running the Show network as Multicast.

    Am I pushing the limits of the ESPixelStick too far, should I add another controller into the prop? I have tried my test sequence at both 20 & 40 fps.

    Suggestions?
    Last edited by TomL8345; 09-13-2020 at 06:29 PM.
    2012 - 1st year 64 Channels - 7500 LED lights - 5 sequences
    2013 - 128 Channels - 10,000 LED lights - 7 sequences (2 New)
    2014 - 201 Channels - upgrading 8 Arches to dumb RGB - 8+ sequences (1+ New)
    2015 - 240 Channels + 8 Universes - sequences TBD
    2016 - No Display
    2017 - Back in the Game - 240 Renard Channels + 12 Universes
    2018 - 256 Renard and 9 Falcon Outputs of Pixels - 16 sequences shown over 2 nights
    2019 - 256 Renard and 9 Falcon Outputs of Pixels - 16 sequences shown over 2 nights
    2020 - Emergency Conversion to Falcon F48 with limited wireless

  2. #2
    Join Date
    Oct 2014
    Location
    Sauk City, WI USA
    Posts
    1,806
    Post Thanks / Like

    Default Re: Problems with a New Prop

    Gibberish would indicate a mapping problem. I would fix that first and then see if you are having problems. I thought sporadic has indicated that 8266 based espixelstick would run 680 pixels reliably at 40 fps. You are defintely over that number but if the mapping is messed up, you might just be seeing fragments from the mapping.
    Last edited by MikeKrebs; 09-03-2020 at 11:51 AM.

  3. #3
    Join Date
    Jan 2012
    Location
    Chambersburg, PA
    Posts
    954
    Post Thanks / Like

    Default Re: Problems with a New Prop

    Quote Originally Posted by MikeKrebs View Post
    Gibberish would indicate a mapping problem. I would fix that first and then see if you are having problems. I thought sporadic has indicated that 8266 based espixelstick would ruin 680 pixels reliably at 40 fps. You are defintely over that number but if the mapping is messed up, you might just be seeing fragments from the mapping.
    I don't think the mapping is the issue, rather trying to run too many pixels. I will add another pixelstick to the prop and see how that works.
    2012 - 1st year 64 Channels - 7500 LED lights - 5 sequences
    2013 - 128 Channels - 10,000 LED lights - 7 sequences (2 New)
    2014 - 201 Channels - upgrading 8 Arches to dumb RGB - 8+ sequences (1+ New)
    2015 - 240 Channels + 8 Universes - sequences TBD
    2016 - No Display
    2017 - Back in the Game - 240 Renard Channels + 12 Universes
    2018 - 256 Renard and 9 Falcon Outputs of Pixels - 16 sequences shown over 2 nights
    2019 - 256 Renard and 9 Falcon Outputs of Pixels - 16 sequences shown over 2 nights
    2020 - Emergency Conversion to Falcon F48 with limited wireless

  4. #4
    Join Date
    Oct 2014
    Location
    Sauk City, WI USA
    Posts
    1,806
    Post Thanks / Like

    Default Re: Problems with a New Prop

    You could test that pretty quick by configuring 680 pixels on the esp. The last 2xx should be dark and everything else should work correctly.

  5. #5
    Join Date
    Dec 2012
    Location
    Newtown CT
    Posts
    4,928
    Post Thanks / Like

    Default Re: Problems with a New Prop

    The ESPixelStick can drive in excess of 1000 pixels without an issue.


    2020 Full sized show reworked for the new location. Only adding (famous last words) 13 RBLs that I finally got converted to using pixels
    2019 - Just moved into a new home (yet another change of plans). Will be dim but not dark. Too much to do at the new place to leave time for a show. Dim show (3000 pixels) had regular visits most nights.
    https://www.youtube.com/channel/UCyX...ttrsZNARkUce0Q

  6. #6
    Join Date
    Jan 2012
    Location
    Chambersburg, PA
    Posts
    954
    Post Thanks / Like

    Default Re: Problems with a New Prop

    I shortened the string down to 586 pixels and am still having the same issues. Whenever I run a test sequence on FPP for the Matix a simple Bars pattern is jerky and even simple TEXT does not display properly. I am using XLights and the actual prop matches the wiring views in XLights. I am running a horizontal 8x37 grid starting in the upper left corner of the matrix
    Porch Matrix Wiring Diagram front.png

    so I don't think it is a mapping issue. What else would you suggest?
    2012 - 1st year 64 Channels - 7500 LED lights - 5 sequences
    2013 - 128 Channels - 10,000 LED lights - 7 sequences (2 New)
    2014 - 201 Channels - upgrading 8 Arches to dumb RGB - 8+ sequences (1+ New)
    2015 - 240 Channels + 8 Universes - sequences TBD
    2016 - No Display
    2017 - Back in the Game - 240 Renard Channels + 12 Universes
    2018 - 256 Renard and 9 Falcon Outputs of Pixels - 16 sequences shown over 2 nights
    2019 - 256 Renard and 9 Falcon Outputs of Pixels - 16 sequences shown over 2 nights
    2020 - Emergency Conversion to Falcon F48 with limited wireless

  7. #7
    Join Date
    Jan 2012
    Location
    Chambersburg, PA
    Posts
    954
    Post Thanks / Like

    Default Re: Problems with a New Prop

    bump
    2012 - 1st year 64 Channels - 7500 LED lights - 5 sequences
    2013 - 128 Channels - 10,000 LED lights - 7 sequences (2 New)
    2014 - 201 Channels - upgrading 8 Arches to dumb RGB - 8+ sequences (1+ New)
    2015 - 240 Channels + 8 Universes - sequences TBD
    2016 - No Display
    2017 - Back in the Game - 240 Renard Channels + 12 Universes
    2018 - 256 Renard and 9 Falcon Outputs of Pixels - 16 sequences shown over 2 nights
    2019 - 256 Renard and 9 Falcon Outputs of Pixels - 16 sequences shown over 2 nights
    2020 - Emergency Conversion to Falcon F48 with limited wireless

  8. #8
    Join Date
    Dec 2012
    Location
    Newtown CT
    Posts
    4,928
    Post Thanks / Like

    Default Re: Problems with a New Prop

    Jerky sounds more like a network issue. Things not displaying right is usually a patching issue.

    Are you using unicast or multicast?
    Is your network quiet or noisy?
    Is the player connected to the wired interface on your AP?


    2020 Full sized show reworked for the new location. Only adding (famous last words) 13 RBLs that I finally got converted to using pixels
    2019 - Just moved into a new home (yet another change of plans). Will be dim but not dark. Too much to do at the new place to leave time for a show. Dim show (3000 pixels) had regular visits most nights.
    https://www.youtube.com/channel/UCyX...ttrsZNARkUce0Q

  9. #9
    Join Date
    Dec 2011
    Location
    UK S80 postcode
    Posts
    1,519
    Post Thanks / Like

    Default Re: Problems with a New Prop

    Hi Tom, I think you can login to the ESPixelStick and check for dropped (or lost) packets, what does that say? I think if you power down it resets the value so you can do a couple of tests with the same setup.

  10. #10
    Join Date
    Jan 2012
    Location
    Chambersburg, PA
    Posts
    954
    Post Thanks / Like

    Default Re: Problems with a New Prop

    Quote Originally Posted by Barnabybear View Post
    Hi Tom, I think you can login to the ESPixelStick and check for dropped (or lost) packets, what does that say? I think if you power down it resets the value so you can do a couple of tests with the same setup.
    Hi Barnaby,

    Here is what I have on the stick at the moment:
    E1.31 Status
    Universe Range 50 to 53
    Total Packets 3237
    Sequence Errors 378
    Packet Errors 0
    Source IP 192.168.73.115

    I will do some more testing tomorrow.
    2012 - 1st year 64 Channels - 7500 LED lights - 5 sequences
    2013 - 128 Channels - 10,000 LED lights - 7 sequences (2 New)
    2014 - 201 Channels - upgrading 8 Arches to dumb RGB - 8+ sequences (1+ New)
    2015 - 240 Channels + 8 Universes - sequences TBD
    2016 - No Display
    2017 - Back in the Game - 240 Renard Channels + 12 Universes
    2018 - 256 Renard and 9 Falcon Outputs of Pixels - 16 sequences shown over 2 nights
    2019 - 256 Renard and 9 Falcon Outputs of Pixels - 16 sequences shown over 2 nights
    2020 - Emergency Conversion to Falcon F48 with limited wireless

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •