Results 1 to 8 of 8

Thread: Falcon serial output issue

  1. #1
    Join Date
    Dec 2015
    Posts
    32
    Post Thanks / Like

    Default Falcon serial output issue

    Hello all,

    I posted this over on the green site, but I'll post it here too.

    I've got a Falcon F16V3 driving my pixel tree on streaming ACN/E1.31, and I was finally able to get the jumper correct to output serial data from the falcon to Renard.

    The falcon has all 16 ports used on it for 16 strings of 94 pixels, addresses 1-4512. (16*94*3=4512). I have the output hooked to serial 2 on the falcon, with the jumpers in the DMX position. The web server is set as such: Serial Data, Renard, start address 4513, Baud 115200 (The controllers are flashed to this baud rate), stop bits 1.

    Vixen is configured for streaming ACN/E1.31 total channel count of "5000" (which is a little more than I need, but I can reduce that later.)

    I have an actual 432 outputs hardware wise, and I am using almost every single one of them (I think 427 was the last count, with a few just simply not plugged in)

    I have 4 renzillas, then 2 TR-24's in that order in series.

    When I have it configured with Streaming ACN/E1.31 in Vixen, it will output to the first 3 controllers (288 channels after the pixel tree) then nothing.

    I suspected a hardware issue initially, but after swapping over the cable to run it with a USB-RS-485 adapter, everything came on and worked (except for the pixel tree of course)

    Right now the patching is 1-4512 = pixel tree, then 4513-"5000" are serial.

    Does anyone have any ideas of what I'm missing?falcon web server serial 11-11-19.jpgfalcon web server e131 setup 11-11-19.jpgvixen setup E131 config screen 11-1-19.jpg

  2. #2
    Join Date
    Jan 2016
    Location
    Lizella, GA
    Posts
    1,480
    Post Thanks / Like

    Default Re: Falcon serial output issue

    Are you using a crossover cable to the 1st Renard board?

    DMX_(RJ-45)_to_Renard_Connection.jpg

    From the Falcon Manual

    Falcon Manual.JPG
    Last edited by Ruppro; 11-11-2019 at 10:49 PM.
    Matt

  3. #3
    Join Date
    Nov 2007
    Location
    Houston, TX (near Katy)
    Posts
    976
    Post Thanks / Like

    Default Re: Falcon serial output issue

    Quote Originally Posted by marknbacon View Post
    Hello all,


    The falcon has all 16 ports used on it for 16 strings of 94 pixels, addresses 1-4512. (16*94*3=4512). I have the output hooked to serial 2 on the falcon, with the jumpers in the DMX position. The web server is set as such: Serial Data, Renard, start address 4513, Baud 115200 (The controllers are flashed to this baud rate), stop bits 1.
    I'm pretty sure that with your string ports set to serial and DMX, you are losing ports 13-16 of your E1-31 (output to your tree).
    That's a feature not a bug.
    There's no charge for that.

  4. #4
    Join Date
    Dec 2015
    Posts
    32
    Post Thanks / Like

    Default Re: Falcon serial output issue

    Quote Originally Posted by Ruppro View Post
    Are you using a crossover cable to the 1st Renard board?

    DMX_(RJ-45)_to_Renard_Connection.jpg

    From the Falcon Manual

    Falcon Manual.JPG


    Yes. I made that cable and hooked it up. I actually have it as a very short one that goes to a enclosure pass through and to another cable on the other side of the pass-through for additional waterproofing.

    Like I said, channels 1-288 turn on via the serial output, and I am almost certain all the pixel tree strings are lighting up.

    I also swapped to where the first universe had the serial data and the pixels didnít start until universe 2 (channel 513.) made no difference.

    Any more ideas?


    Sent from my iPhone using Tapatalk

  5. #5
    Join Date
    Jan 2016
    Location
    Lizella, GA
    Posts
    1,480
    Post Thanks / Like

    Default Re: Falcon serial output issue

    I would tone out the crossover cable to make sure it is correct, and make a longer one just to test from Falcon to Renard, maybe the waterproof pass-through is bad.

    DMX using RJ45 (CAT5) Connectors
    RJ45 connector pin 1 (Data+) to RJ45-pin 5
    RJ45 connector pin 2 (Data-) to RJ45-pin 4
    RJ45 connector pins 7 & 8 (GND) to RJ45-pins 1 & 2
    Last edited by Ruppro; 11-12-2019 at 01:00 AM.
    Matt

  6. #6
    Join Date
    Dec 2015
    Posts
    32
    Post Thanks / Like

    Default Falcon serial output issue

    Quote Originally Posted by Ruppro View Post
    I would tone out the crossover cable to make sure it is correct, and make a longer one just to test from Falcon to Renard, maybe the waterproof pass-through is bad.

    DMX using RJ45 (CAT5) Connectors
    RJ45 connector pin 1 (Data+) to RJ45-pin 5
    RJ45 connector pin 2 (Data-) to RJ45-pin 4
    RJ45 connector pins 7 & 8 (GND) to RJ45-pins 1 & 2


    Yeah I donít think thatís it, because if that was messed up, it wouldnít pass a signal to the renards at all, right?

    Channels 1-288 work fine (through the first three renzillas) and renzilla 4, and then TR24 1 and 2 arenít lighting anything up. (Channels 289-432)

    I know itís not the renards because it will work fine with the USB to RS485 adapter hooked directly to the first renard. In fact, I got everything lit up tonight and mapped my inputs.

    And it DOES work through the falcon, but NOT all the channels in the data string.

    EDIT: also, this is the diagram I used.




    Sent from my iPhone using Tapatalk

  7. #7
    Join Date
    Jan 2016
    Location
    Lizella, GA
    Posts
    1,480
    Post Thanks / Like

    Default Re: Falcon serial output issue

    OK,, I thought the Falcon did not work at all. I know that there are issues when you have "too many PICs" in a chain, but again it is working off the Serial Dongle....??
    Matt

  8. #8
    Join Date
    Dec 2015
    Posts
    32
    Post Thanks / Like

    Default Re: Falcon serial output issue

    Quote Originally Posted by Ruppro View Post
    OK,, I thought the Falcon did not work at all. I know that there are issues when you have "too many PICs" in a chain, but again it is working off the Serial Dongle....??
    Ah gotcha. Nope, it works fine, as long as I use the serial dongle directly off my laptop for the renards, and e1.31 for the pixels.

    Iím thinking maybe I try making another dmx/renard cable and run it from serial 3 to renzillas 3 & 4 plus the TR 24s?

    Idk. Iím kinda at a loss here. I really want to make the falcon work the way it is supposed to and only have the one Ethernet cable running from the computer to the systems.


    Sent from my iPhone using Tapatalk

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •