Results 1 to 6 of 6

Thread: please Help with Ron's four output controller

  1. #1
    Join Date
    Mar 2017
    Location
    Clinton Twp. Michigan
    Posts
    87
    Post Thanks / Like

    Default please Help with Ron's four output controller

    Well I got one of Ron's 4 output controllers this summer. I build it and all was going well until I tried to control my pixel tree. I blew the controller. I have a new one on order. I was hoping someone could help me make I don't blow the new one. I have a 180 deg 10 roll of pixel tree with 4 signal points coming off the controller. I am using Vixen software

    Line 1 has 135 ws2811
    Line 2 has 135 ws2811
    Line 3 has 135 ws2811
    Line 4 has 45 ws2811

    I am using a 12v 30A Power supply. The controller says it will handle 3 amp per output. I am not sure if I blew it or if the power surge that I had blew it. I did have it working great a few times before it blew. Any help would be appreciated. Trying to get it working so I can use it this year.

  2. #2
    Join Date
    Aug 2012
    Location
    Nova Scotia, Canada
    Posts
    1,675
    Post Thanks / Like

    Default Re: please Help with Ron's four output controller

    135 X 12v pixels = 97w (.72wX135)
    135/12= around 8amps
    This is at 100%...
    When you say you blew the board, did you just mean the fuses?
    You can always just run data to the pixels and power inject.
    Do you get the red light when you only have the 5v powering the board? I better ask this as well.....you did only supply 5v to the board right?
    There are 2 X 2 pin power connections on the board, one is for pixel power and the other is for the board itself. The board needs 5v only...
    rons.JPG
    Phil

  3. #3
    Join Date
    Oct 2014
    Location
    Sauk City, WI USA
    Posts
    1,155
    Post Thanks / Like

    Default Re: please Help with Ron's four output controller

    Did you have smoke?

  4. #4
    Join Date
    Mar 2017
    Location
    Clinton Twp. Michigan
    Posts
    87
    Post Thanks / Like

    Default Re: please Help with Ron's four output controller

    I did connect the 5v and I did see some smoke It was working great then I lost power to the controller after that it would not get a signal at the input. After checking it out and bench checking I saw smoke, so I thing it is dead. I did not know I could just get a signal from the controller. Now that I know l can gust get the signal from the controller when I get the new one I will power inject instead of going thought the controller. I did not blow a fuse there are no fuses on this controller that I know of.as I said I did have it working for a short time before it went.

  5. #5
    Join Date
    Oct 2014
    Location
    Sauk City, WI USA
    Posts
    1,155
    Post Thanks / Like

    Default Re: please Help with Ron's four output controller

    do you have scorch marks? If you can identify what toasted, you can probably replace. Take a good hi res pix of both sides of board. Someone will be able to guide you on getting it working. Before that step though, need to determine as best you can why it happened. If it was user error, a solder bridge, stray wire, whatever, root cause before throwing good parts at it.

  6. #6
    Join Date
    Mar 2017
    Location
    Clinton Twp. Michigan
    Posts
    87
    Post Thanks / Like

    Default Re: please Help with Ron's four output controller

    It was said that I could run the pixel tree with the signal data only and power inject. Would you know do I need to run the ground from the pixels to the controller ground also? Or do inject I set the controller as you would and power inject along the way to cut down my amps going thought the controller.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •