Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: megatree help please

  1. #1
    Join Date
    Dec 2018
    Posts
    15
    Post Thanks / Like

    Default megatree help please

    Hi guys,
    I am new first time setup megatree.

    I have two nodemcu running ESPixelStick, one string of 400 pixel, 8 strands per string.

    trying to setup xlights but it didn't come out right, can anyone tell me what i did wrong?



    megatree wiring
    http://doityourselfchristmas.com/for...1&d=1576553912

    xlights network setup
    http://doityourselfchristmas.com/for...1&d=1576553920

    xlights layout
    http://doityourselfchristmas.com/for...1&d=1576553928
    Attached Images Attached Images

  2. #2
    Join Date
    Jan 2018
    Posts
    301
    Post Thanks / Like

    Default Re: megatree help please

    First, you need to change the nodemcu's to multicast, then set up your xlights as one output for your mega tree, then set each mcu, first one set number of pixels as 400, start channel 1, second mcu as 400 pixels start channel 1201. Then set your tree in layout as 180 tree, 16 strands 50 pixels per strand

  3. #3
    Join Date
    Jan 2019
    Location
    USA - Boca Raton, FL
    Posts
    45
    Post Thanks / Like

    Default Re: megatree help please

    Quote Originally Posted by vietnight View Post
    Hi guys,
    I am new first time setup megatree.

    I have two nodemcu running ESPixelStick, one string of 400 pixel, 8 strands per string.

    trying to setup xlights but it didn't come out right, can anyone tell me what i did wrong?



    megatree wiring
    http://doityourselfchristmas.com/for...1&d=1576553912

    xlights network setup
    http://doityourselfchristmas.com/for...1&d=1576553920

    xlights layout
    http://doityourselfchristmas.com/for...1&d=1576553928
    1. Why is your xLight/Vixen/FPP Mapping says Channels 1 to 1530 for #1 and 1531 to 3060 on #2?
    It should be "Channels 1 to 1200" for #1 and "Channels 1201 to 2401" for the #2 (400 pixels times 3 channels per pixel is 1200 channels. Not 1530 )

    2. Please take a screenshot from ESPixelStick device setup.

    My wiring is the same *2 , but I also have power injections.

    Thanks,
    Last edited by EvoMoto; 12-17-2019 at 10:47 AM.

  4. #4
    Join Date
    Dec 2018
    Posts
    15
    Post Thanks / Like

    Default Re: megatree help please

    Quote Originally Posted by EvoMoto View Post
    1. Why is your xLight/Vixen/FPP Mapping says Channels 1 to 1530 for #1 and 1531 to 3060 on #2?
    It should be "Channels 1 to 1200" for #1 and "Channels 1201 to 2401" for the #2 (400 pixels times 3 channels per pixel is 1200 channels. Not 1530 )

    2. Please take a screenshot from ESPixelStick device setup.

    My wiring is the same *2 , but I also have power injections.

    Thanks,
    Quote Originally Posted by EvoMoto View Post
    1. Why is your xLight/Vixen/FPP Mapping says Channels 1 to 1530 for #1 and 1531 to 3060 on #2?
    It should be "Channels 1 to 1200" for #1 and "Channels 1201 to 2401" for the #2 (400 pixels times 3 channels per pixel is 1200 channels. Not 1530 )

    2. Please take a screenshot from ESPixelStick device setup.

    My wiring is the same *2 , but I also have power injections.

    Thanks,
    hi thank you for the help,
    1. xlights setup at start universe#1, # of universe is 3 that why is show 1-1530, and 1531 to 3060 is on #2, i left the default at 510 that why is 1530, if i change to 400 then is 1200 for #1 and 1202-2800 for #2
    xlights network e131 setup
    Attachment 42407
    ESPixelStick screenshot of 1 and 2
    Attachment 42408
    Attachment 42409

    i have power injections at 100 pixel right now but when i get it to work i will do power injection at 50 pixel.

  5. #5
    Join Date
    Dec 2018
    Posts
    15
    Post Thanks / Like

    Default Re: megatree help please

    Output of the tree is not in order and missing pixels.

    Sent from my SM-N975U using Tapatalk

  6. #6
    Join Date
    Dec 2018
    Posts
    15
    Post Thanks / Like

    Default Re: megatree help please

    Quote Originally Posted by dim bulb View Post
    First, you need to change the nodemcu's to multicast, then set up your xlights as one output for your mega tree, then set each mcu, first one set number of pixels as 400, start channel 1, second mcu as 400 pixels start channel 1201. Then set your tree in layout as 180 tree, 16 strands 50 pixels per strand
    I try change nodemcu to multicast but didn't get anything from testing

    Sent from my SM-N975U using Tapatalk

  7. #7
    Join Date
    Nov 2011
    Location
    Richmond, TX (Pecan Grove)
    Posts
    274
    Post Thanks / Like

    Default Re: megatree help please

    hmm - I think maybe your individual start channel setting in Xlights for String 2 should be 1201 (assuming string 1 is channels 1-1200, string 2 channels 1201-2400). I use 16 individual strings, 1 string per strand, so i'm not certain if you also need to specify zig zag in the xlights pixel tree config, i don't see a setting for that, so maybe it will follow appropriately. However, your start channel for string 2 looks incorrect so that can definitely cause some problem.

  8. #8
    Join Date
    Nov 2011
    Location
    Richmond, TX (Pecan Grove)
    Posts
    274
    Post Thanks / Like

    Default Re: megatree help please

    reading your post in more detail, perhaps in the Xlights tree setting you should set string 2 start channel to 1531 (i said 1201 assuming you just started at 1 and followed 3 per pixel). If second string starts at channel 1531, use that. your current setting looks like string 2 starts at channel 181, which isn't correct.

  9. #9
    Join Date
    Nov 2011
    Location
    Richmond, TX (Pecan Grove)
    Posts
    274
    Post Thanks / Like

    Default Re: megatree help please

    sorry - i may have read it wrong, i'm actually not sure what the 4:181 implies as the start channel for string 2, maybe universe 4, ch 181? at any rate, i would look at that string 2 start channel

  10. #10
    Join Date
    Dec 2018
    Posts
    15
    Post Thanks / Like

    Default Re: megatree help please

    Quote Originally Posted by EMKLLK View Post
    sorry - i may have read it wrong, i'm actually not sure what the 4:181 implies as the start channel for string 2, maybe universe 4, ch 181? at any rate, i would look at that string 2 start channel
    that is universe 4 ch 181 but is was wrong.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •