Page 1 of 4 123 ... LastLast
Results 1 to 10 of 35

Thread: FPP won't light ESP Wifi model chains

  1. #1
    Join Date
    Jun 2019
    Posts
    41
    Post Thanks / Like

    Default FPP won't light ESP Wifi model chains

    Trying to figure out where I've got things mixed up here - any help or direction appreciated. I can't find the right search terms to find my answer.
    I'm sequencing in XLights and running from FPP. I added two ESP Wifi controllers (Renard) to the setup. I can "output to lights" through both Wifi controllers but when I load the FSEQ to FPP and play it the two Wifi model groups do not light.
    If I use the display test in XLights everything lights up. Same for the test mode in FPP. I have a feeling it's got something to do with getting my outputs in FPP set up properly but cannot find any real "how to" in this regard. I THINK I need to define exactly how may channels (universe size) in each universe but am not really sure how to determine this based on my models in XLights.
    For example, one Wifi controller runs a group of five 26mm tri-led pixels (model one in the universe), three groups of three (models two, three and four), a group of two (spider eyes), a group of four (spider head), a group of eight (spider body) and then three more groups of three. (37 WS2811 chips.)
    My math says that should be 111 channels?Seems simple enough but in FPP's Channel Outputs screen it also asks for the FPP start channel and I'm not sure how to determine that. It's a simple display - probably good to learn this stuff before it gets too big.
    Thanks in advance for any wisdom.

  2. #2
    Join Date
    Jan 2018
    Posts
    226
    Post Thanks / Like

    Default Re: FPP won't light ESP Wifi model chains

    The Renard controllers need to use start address 0, then set the perimeters of how many channels the controller uses in the ESP module device settings.

  3. #3
    Join Date
    Jun 2019
    Posts
    41
    Post Thanks / Like

    Default Re: FPP won't light ESP Wifi model chains

    I'm pretty sure the universes are all set up correctly and all use the start channel in the correct manner (I've got three outputs coming off the 4 universe controller and those are working fine). It's the two wifi outputs going to the ESP Wifi sticks that are giving me trouble. Here are some screen shots of the setup in case maybe something obvious jumps out that I'm not seeing. Is it the Universe Boundaries you're referring to?

    Forgive the messy model. It's not intended to be accurately modelled as I'm sequencing each element individually. I'm a control freak perhaps..

    Screen Shot 2019-10-27 at 10.07.37 PM.pngLayout1.pngLayout2.pngScreen Shot 2019-10-27 at 10.07.37 PM.pngScreen Shot 2019-10-28 at 12.17.33 PM.pngScreen Shot 2019-10-28 at 12.17.50 PM.png

  4. #4
    Join Date
    Jan 2018
    Posts
    226
    Post Thanks / Like

    Default Re: FPP won't light ESP Wifi model chains

    Ok, you said renard when you meant renstick. Try running them in multicast as well. I have a few ESPixelMCU, they dont like unicast.

  5. #5
    Join Date
    Jun 2019
    Posts
    41
    Post Thanks / Like

    Default Re: FPP won't light ESP Wifi model chains

    Same result. I can light them all fully using the lights test panel as well as the FPP display test screen. But when I play the sequence only the house (hard wired) stuff lights.

  6. #6
    Join Date
    Jan 2018
    Posts
    226
    Post Thanks / Like

    Default Re: FPP won't light ESP Wifi model chains

    Ok, well when I get home and can see your output screen shots better I will look at them if someone hasn't solved it before then.

  7. #7
    Join Date
    Jun 2019
    Posts
    41
    Post Thanks / Like

    Default Re: FPP won't light ESP Wifi model chains

    I appreciate it. I've made some changes to the model and layout but only to simplify the organization on my end and allow me to break up the "web" model better for multiple ESPs (assuming I get this figured out and fixed).

  8. #8
    Join Date
    Jan 2018
    Posts
    226
    Post Thanks / Like

    Default Re: FPP won't light ESP Wifi model chains

    I was able to just now get your screen shots up, first off, set all your universe boundaries in FPP and you pixel sticks to 510. No need to set them at channel count.

  9. #9
    Join Date
    Jun 2019
    Posts
    41
    Post Thanks / Like

    Default Re: FPP won't light ESP Wifi model chains

    Do I need to check "on" the 'Enable Multicast" checkbox on the ESP Wifi setup pages?

  10. #10
    Join Date
    Jun 2019
    Posts
    41
    Post Thanks / Like

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •