Results 1 to 6 of 6

Thread: Vixen 2 communicating with Arduino

  1. #1
    Join Date
    Dec 2016
    Location
    Calgary, Canada
    Posts
    27
    Post Thanks / Like

    Default Vixen 2 communicating with Arduino

    Hey! I am using Zparticle's V2 code. However when I go to test it with Vixen, the RX led flashes but the arduino doesn't respond. The zc circuit is working in Random mode but the arduino just ignores all input.

    I have double checked the following.
    Baudrate (pc/vixen)
    Header (I am assuming is STRT)
    Footer (set to END)
    Everything hardware.


    Im not sure what's going on so im reaching out here.

    Any help is appreciated.

    Sent from my LG-H873 using Tapatalk

  2. #2
    Join Date
    Oct 2011
    Location
    Batesburg, SC
    Posts
    92
    Post Thanks / Like

    Default Re: Vixen 2 communicating with Arduino

    I'm not sure which code is which, but the last one I used had `~ or ~` as the start code. Nothing was needed for end.

    Sent from my XT1254 using Tapatalk

  3. #3
    Join Date
    Oct 2014
    Location
    Sauk City, WI USA
    Posts
    1,173
    Post Thanks / Like

    Default Re: Vixen 2 communicating with Arduino

    look in the code for wait for vixen or something similar. You will find the start bytes there.

    double check number of channels on both sides.

  4. #4
    Join Date
    Dec 2016
    Location
    Calgary, Canada
    Posts
    27
    Post Thanks / Like

    Default Re: Vixen 2 communicating with Arduino

    Nope, all the values are right. I checked for any other headers but all I could find was STRT and END.

    I will attach the code as the entire sketch is too big for the forum.
    Attached Files Attached Files

  5. #5
    Join Date
    Dec 2016
    Location
    Calgary, Canada
    Posts
    27
    Post Thanks / Like

    Default Re: Vixen 2 communicating with Arduino

    Ok so my issue must involve the FT232 which I don't see the need for...
    How do I get around this?

  6. #6
    Join Date
    Dec 2016
    Location
    Calgary, Canada
    Posts
    27
    Post Thanks / Like

    Default Re: Vixen 2 communicating with Arduino

    Nevermind! If anyone doesn't want to use the FT232 for zparticle's code. Just tie Pin 0 to Pin 18 and Pin 1 to Pin 19 essentially tie your TX/RX 0 and TX/RX 1 together.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •