Results 1 to 5 of 5

Thread: Dev build possible bug with multi point string/polystring in preview builder

  1. #1
    Join Date
    Nov 2016
    Location
    North Vancouver, BC, Canada
    Posts
    758
    Post Thanks / Like

    Default Dev build possible bug with multi point string/polystring in preview builder

    Not sure if this is a bug, or if it's already been reported, but I haven't really had to modify my preview layout very much other than editing the pixel linking. So the props and shapes I have on my preview were already existing, and I would just modify the properties or tweak the size and shape from the handles on it when selected. Unless something has been changed with regards to the way it's handled, when I selected multi point string from the basic items menu I would click a start point, then click another point and so on, and everytime I clicked, a line of lights would be drawn at whatever angle or length I drew until I had the finished shape I wanted and hit escape. And although each section between each point was editable after the fact by dragging one of the two points on either end of the line segment in question, ultimately, when I selected the object, everything I had drawn from first click until hitting esc when I was done would be selected as one object which I could then link or edit the properties as desired. I noticed it starting from build 902, but it could have been around for a lot longer than that, as I haven't had to re draw any props from scratch for a year. While I'm drawing, it acts and looks like it normally would, but is treating each segment between two click points as a standalone item with properties. And trying to select for example a rectangle shape I drew out that is showing as 4 separate items/strings together does not give any properties to assign or link anything. Only if I select one of the 4 individual lines will properties or linking options be available. The prior objects I had drawn with the exact same tool are still being treated as one object and allowing modification to properties. I tried the next few dev builds just in case, starting a brand new profile, new preview with no change. Am I missing something?

    Only thing that stood out in the log when i've noticed this is this:

    09/18/2019 01:26:37.441 [VixenApplication.NLogListener] Property 'Decorator' mapped on model properties 'Decorator' cannot be converted via given converter 'Catel.MVVM.DefaultViewModelToModelMappingConverte r'
    09/18/2019 01:26:37.472 [VixenApplication.NLogListener] Property 'Decorator' mapped on model properties 'Decorator' cannot be converted via given converter 'Catel.MVVM.DefaultViewModelToModelMappingConverte r'
    09/18/2019 01:26:37.472 [VixenApplication.NLogListener] Property 'Decorator' mapped on model properties 'Decorator' cannot be converted via given converter 'Catel.MVVM.DefaultViewModelToModelMappingConverte r'
    09/18/2019 01:26:37.472 [VixenApplication.NLogListener] Property 'Decorator' mapped on model properties 'Decorator' cannot be converted via given converter 'Catel.MVVM.DefaultViewModelToModelMappingConverte r'
    09/18/2019 01:26:37.472 [VixenApplication.NLogListener] Property 'Decorator' mapped on model properties 'Decorator' cannot be converted via given converter 'Catel.MVVM.DefaultViewModelToModelMappingConverte r'
    09/18/2019 01:26:37.491 [VixenApplication.NLogListener] Property 'Decorator' mapped on model properties 'Decorator' cannot be converted via given converter 'Catel.MVVM.DefaultViewModelToModelMappingConverte r'
    09/18/2019 01:26:37.491 [VixenApplication.NLogListener] Property 'Decorator' mapped on model properties 'Decorator' cannot be converted via given converter 'Catel.MVVM.DefaultViewModelToModelMappingConverte r'
    09/18/2019 01:26:37.491 [VixenApplication.NLogListener] Property 'Decorator' mapped on model properties 'Decorator' cannot be converted via given converter 'Catel.MVVM.DefaultViewModelToModelMappingConverte r'
    09/18/2019 01:26:37.491 [VixenApplication.NLogListener] Property 'Decorator' mapped on model properties 'Decorator' cannot be converted via given converter 'Catel.MVVM.DefaultViewModelToModelMappingConverte r'
    09/18/2019 01:27:50.897 [VixenApplication.NLogListener] Property 'Decorator' mapped on model properties 'Decorator' cannot be converted via given converter 'Catel.MVVM.DefaultViewModelToModelMappingConverte r'
    09/18/2019 18:16:04.592 [VixenModules.Editor.TimedSequenceEditor.FormEffect Editor] Preview context was not running!

  2. #2
    Join Date
    Nov 2016
    Location
    North Vancouver, BC, Canada
    Posts
    758
    Post Thanks / Like

    Default Re: Dev build possible bug with multi point string/polystring in preview builder

    Oh, and that is build #905, but same behavior on the builds since I first tried on 902 I believe

  3. #3
    Join Date
    Oct 2011
    Location
    Maryville, Illinois
    Posts
    1,659
    Post Thanks / Like

    Default Re: Dev build possible bug with multi point string/polystring in preview builder

    Yep, looks like there is a bug there that was recently introduced. I will get it fixed, but any multi point strings you drew with the bug with either the basic or smart object will need to be redrawn after the fix. The bug was breaking them apart into multiple individual strings instead of one multipoint string. Preexisting ones should be ok.
    Last edited by jeffu231; 09-19-2019 at 09:39 AM.

  4. #4
    Join Date
    Nov 2016
    Location
    North Vancouver, BC, Canada
    Posts
    758
    Post Thanks / Like

    Default Re: Dev build possible bug with multi point string/polystring in preview builder

    Quote Originally Posted by jeffu231 View Post
    Yep, looks like there is a bug there that was recently introduced. I will get it fixed, but any multi point strings you drew with the bug with either the basic or smart object will need to be redrawn after the fix. The bug was breaking them apart into multiple individual strings instead of one multipoint string. Preexisting ones should be ok.
    Phew lol. I thought the way it works changed since I last used it, and I would be embarassed

  5. #5
    Join Date
    Oct 2011
    Location
    Maryville, Illinois
    Posts
    1,659
    Post Thanks / Like

    Default Re: Dev build possible bug with multi point string/polystring in preview builder

    No worries. Thanks for reporting it. It should be fixed in the latest development build.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •