Results 1 to 7 of 7

Thread: Lip Sync Face Mapping - Vixen 3.5

  1. #1
    Join Date
    Jan 2017
    Location
    Jacksonville FL
    Posts
    36
    Post Thanks / Like

    Default Lip Sync Face Mapping - Vixen 3.5

    <Insert the Beatles song here - HELP!>

    So I am at round 5 or 6, (lost count in between knock downs) with the singing characters, you may have seen my earlier post "Vixen crashes when importing xModel... What am I missing?"
    Well a month later and I've made some progress, if you're generous enough to call it that. All characters are now functional in testing with effects.

    Next challenge, face mapping and lip sync....

    I "believe" the following, though after some many hours you start to unravel... I've mapped the faces in Setup Display, then selected the mapping in the sequence. I also added the verbiage, broke-down the phrase, then broke-down the words and added Lip Sync to the element I wanted to sing.
    Though, when I hit play, and it gets to the words.... the entire element lights up in the preview and the prop. No lippy movement. If I put an effect (say "Alternating colors") on a specific face feature (AI, L, O, etc...) they light up perfectly as they should, but not with the word marks.

    I've really struggled to find any videos on this for Vixen that isn't 4+ years old.

    I've attached some images that I believe are relevant, though this is a completely new area for me. So I could be and likely am overlooking something.

    Thanks,
    Krampus

    Xixen 3.5u4
    Boscoyo: Santa, Elf & Reindeer Chromacharacters

  2. #2
    Join Date
    Oct 2011
    Location
    Maryville, Illinois
    Posts
    1,491
    Post Thanks / Like

    Default Re: Lip Sync Face Mapping - Vixen 3.5

    Here are the 3 that I made last year that are relevant to the new tooling. I'll read through your docs once I get back home. My phone won't open them correctly.


    https://youtu.be/i3quOLEFHv8

    https://youtu.be/RhBecwSIAfo

    https://youtu.be/OBuj58kDHJU

  3. #3
    Join Date
    Jan 2017
    Location
    Jacksonville FL
    Posts
    36
    Post Thanks / Like

    Default Re: Lip Sync Face Mapping - Vixen 3.5

    Thanks Jeff. I appreciate it man!

    Yeh I was in a hurry working on a laptop while out in about. Battery was getting low, no charger cord. The images I uploaded were saved in Word doc.

  4. #4
    Join Date
    Oct 2011
    Location
    Maryville, Illinois
    Posts
    1,491
    Post Thanks / Like

    Default Re: Lip Sync Face Mapping - Vixen 3.5

    I looked at the images and things look to be correct there from what I can see. We might be able to save some time, if you can zip up the profile you are working with and upload it to dropbox or something of the like and PM me a link, or create a ticket with it a bugs.vixenlights.com. If I can look at it I am sure I get you headed in the right direction. The goal with how this works was to make it easier, so your struggles tell me we need more documentation/videos or we missed something that could make it easier for you. I am working to wrap up the 3.6 release which does have some bug fixes and improvements to this workflow.

  5. #5
    Join Date
    Oct 2011
    Location
    Maryville, Illinois
    Posts
    1,491
    Post Thanks / Like

    Default Re: Lip Sync Face Mapping - Vixen 3.5

    Thanks for sending me the profile. I figured it out. There is Face mapping defined on the top level Santa group that says it is all phonemes. The face definitions should only be on the specific groups that the elements to manipulate. To fix it, go to the display setup and click on the top level Santa - Boscoyo element and in the Properties box in the lower left corner you will see an item called Face. Select it and click the minus icon. That will remove the Face definition telling it the main group is everything. If you were to double click on that before you remove it, you would see the Face Mapping setup and it would have all the boxes checked and the color set to white. Since it is the main mapping and it was white, it was overriding what you really wanted on the lower level group items. You will see the property on each of the groups that define the mouths, eyes, etc and they each individually define what that group supports. When you edit them all together in the face mapping ender the covers it applies that to the elements you specified. You need to do the same for the other characters as they have the same problem.

    It does look like a few pixels are misplaced in a couple of the mouths and as I recall that is how there were in the model. You may have to tweak the pixels in the groups to fix those up in display setup.

    I'll try to make some more videos on the lip-sync and I will clarify that you only want to map the group nodes.

  6. #6
    Join Date
    Jan 2017
    Location
    Jacksonville FL
    Posts
    36
    Post Thanks / Like

    Default Re: Lip Sync Face Mapping - Vixen 3.5

    Yooooou, you're good. You are good my friend! That was it! I think I watched one video a day or two ago and that is how they set their mapping and I must have set-up those up and forgot about them. Then I saw your videos earlier today and edited them in face mapping and was going in circles over here trying find out the problem. I knew it was something simple. I really appreciate it Jeff. This is one I will not make a mistake again with, use each mistake and a lesson!

    You are also correct about the models. I spent a while getting them to import, had a few issues with them. I was only able to import them without sub-models, so I'm going to need to figure out how to make Santa's hat trim red & white and the elf's face a different color than his hat, etc... Baby steps, I got the mouths working, that's going down as a win and I will address the next challenge as they keep coming.

    Again, I truly appreciate it!
    Krampus

  7. #7
    Join Date
    Oct 2011
    Location
    Maryville, Illinois
    Posts
    1,491
    Post Thanks / Like

    Default Re: Lip Sync Face Mapping - Vixen 3.5

    Glad to hear it. Always willing to help.

    I have fixed the issues with the model imports in the latest development build and that will be in the 3.6 release coming soon. I am looking to get that release out soon. So hopefully future model imports will go smoother for you.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •