Page 1 of 4 123 ... LastLast
Results 1 to 10 of 38

Thread: Access to Com Port Denied

  1. #1
    Join Date
    Oct 2007
    Location
    Altoona, PA
    Posts
    566
    Post Thanks / Like

    Default Access to Com Port Denied

    I posted this in the bugzilla, but thought I'd post it here as well, in case someone else wants to share their experience.


    I have a program consisting of 4 sequences. About 15 minutes total. Each
    sequence uses the same profile, which has these settings:

    -Channels 1-48, Simple 595 Plugin
    -Channels 49-64, Renard Dimmer (modified), Com port 1, Hold port open

    In the Program settings, I have this:
    -Sequence 1, Sequence 2, Sequence 3, Sequence 4
    -Use each sequences plugin setup, I've also tried "Use a profile"
    -0 seconds of cross fade

    The error I'm getting is between sequences:
    "Collection was modified. Enumeration operation may not execute". and in
    another dialog box: "Access to Com Port 1 Denied"

    I've gone through each sequence and re-attached the profile, but I still get
    the same problem. It was happening randomly during playing the program.

    I've since detached the profile from each of the sequences, and I still randomly get the Com Port issues.

  2. #2
    Join Date
    Jan 2008
    Location
    North Ridgeville, Ohio
    Posts
    1,558
    Post Thanks / Like

    Default Re: Access to Com Port Denied

    What version of Vixen are you using? I had the same problem when I was using 2.09. I downgraded to 2.05 and it went away.
    Don

  3. #3
    Join Date
    Dec 2007
    Location
    Camp Hill Pa.
    Posts
    326
    Post Thanks / Like

    Default Re: Access to Com Port Denied

    I occaisionally had the same issue and i either have to delete the old program and build a new program, save it and restart or found unplugging the comp ports and shutting down then opening the program and trying to play it then pluging the com ports in it goes away.

  4. #4
    Join Date
    Dec 2007
    Location
    Melbourne , Australia
    Posts
    896
    Post Thanks / Like

    Default Re: Access to Com Port Denied

    i think this comm port issue is the work of the modified plugin. from what i can tell the modified plugin came in as of 2.0.5.1. so it was unmodified as of 2.0.5.

    i would try the unmodified plugin from the 2.0.5 beta and see if the issue goes away.

    Peter

  5. #5
    Join Date
    Jun 2008
    Location
    Noble Park, Victoria, Australia
    Posts
    156
    Post Thanks / Like

    Default Re: Access to Com Port Denied

    Hi I am having the same problem and am using the 2.0.5 beta

  6. #6
    Join Date
    Dec 2007
    Location
    Melbourne , Australia
    Posts
    896
    Post Thanks / Like

    Default Re: Access to Com Port Denied

    ah well, there goes my idea

  7. #7
    Join Date
    Oct 2007
    Location
    Altoona, PA
    Posts
    566
    Post Thanks / Like

    Default Re: Access to Com Port Denied

    Quote Originally Posted by omzig View Post
    What version of Vixen are you using? I had the same problem when I was using 2.09. I downgraded to 2.05 and it went away.
    I am using 2.09. I'll try the downgrade to see if that helps.

  8. #8
    Join Date
    May 2007
    Location
    Mooresville, NC
    Posts
    7,573
    Post Thanks / Like

    Default Re: Access to Com Port Denied

    Quote Originally Posted by scorpia
    i think this comm port issue is the work of the modified plugin. from what i can tell the modified plugin came in as of 2.0.5.1. so it was unmodified as of 2.0.5.

    i would try the unmodified plugin from the 2.0.5 beta and see if the issue goes away.

    Peter
    Quote Originally Posted by scorpia View Post
    ah well, there goes my idea
    LOL, I was hoping the same thing.

    I had the issue myself, and the old version of the plug-in did not help. (renard 2.0.3 and 2.0.4)
    James Family Christmas - 1600 channels of SS Renard channels
    Website - http://jamesfamilychristmas.com/ <<broken
    Facebook - James Family Christmas


  9. #9
    Join Date
    Jan 2008
    Location
    Bastrop, Texas
    Posts
    978
    Post Thanks / Like

    Default Re: Access to Com Port Denied

    I'm using 2.09 without any real issues.

    I have noticed similar behaviour occasionally. I exit Vixen and bring up task manager, it shows Vixen still running (as a process, not an application).

    I end the process, restart Vixen, and all is well.
    Bob
    ----
    I love the smell of solder flux in the morning....smells like Christmas magic...[URL="http://photobucket.com/setup-2008"]Set up Done!![/URL] [URL="http://www.vimeo.com/rlilly/videos"]Showtime!![/URL]
    (for the fruit of light is found in all that is good and right and true) Ephesians5:9

  10. #10
    Join Date
    Oct 2007
    Location
    Altoona, PA
    Posts
    566
    Post Thanks / Like

    Default Re: Access to Com Port Denied

    Ok- so tried it with the older 2.0 version. Same problem. Apparently this is a known issue, that has a pretty good history. I'm just wondering why there isn't a solid fix for this yet. I could sit and babysit it all night long, but that defeats the purpose of the scheduler. Especially if I have to kill the task and start over every 15 minutes.

    I think what I'm going to do is make a 15 minute sequence that has all 3 of my songs, and just cut and paste all the sequences together. Hopefully that'll avoid this technical issue. I'm gonna get tired of resetting this every 15 :-)

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •