Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 41

Thread: No Range at All.. Not Even 12 Inches...

  1. #31
    Join Date
    Dec 2016
    Location
    Anchorage, AK
    Posts
    262
    Post Thanks / Like

    Default Re: No Range at All.. Not Even 12 Inches...

    Quote Originally Posted by TomL8345 View Post
    I used those for my 2017 show flawlessly. I also had bought a second as a back up. I was running FPP 1.8 at the time. This year when I went to use the same setup the sound was terrible, on both previously used and tested transmitters. The only thing that was different for me was I was now running FPP2.5x. Did anyone have sucess using these transmitters with RasPi running FPP 2.x?
    Something changed with 2.x I was working with Dkulp, but he went on vacation and the emails stopped. I was able to use it with the usb connection with 1.x. Like you found that does'nt work with 2.x. So I purchased a soundblaster 3 usb audio adapter, and connected the audio out of that to the dsp pll transmitter, It works fine, maybe slightly worse audio than 1.x but acceptable. I kinda hate having the extra dongle hanging off the pi, but there seems to be no interest in fixing what was broken with the code. I did create a bug report #403. Several others commented about usb audio not working with any transmitter now. Maybe one day someone will fix it.

  2. Likes Stormyblade liked this post
  3. #32
    Join Date
    Dec 2016
    Location
    Anchorage, AK
    Posts
    262
    Post Thanks / Like

    Default Re: No Range at All.. Not Even 12 Inches...

    Quote Originally Posted by Bwinter View Post
    Yup—I used those last year as well. No problems
    are you using usb audio?

  4. #33
    Join Date
    Nov 2014
    Location
    Close to Hillsboro, OR
    Posts
    367
    Post Thanks / Like

    Default Re: No Range at All.. Not Even 12 Inches...

    Quote Originally Posted by aknflyer View Post
    Something changed with 2.x I was working with Dkulp, but he went on vacation and the emails stopped. I was able to use it with the usb connection with 1.x. Like you found that does'nt work with 2.x. So I purchased a soundblaster 3 usb audio adapter, and connected the audio out of that to the dsp pll transmitter, It works fine, maybe slightly worse audio than 1.x but acceptable. I kinda hate having the extra dongle hanging off the pi, but there seems to be no interest in fixing what was broken with the code. I did create a bug report #403. Several others commented about usb audio not working with any transmitter now. Maybe one day someone will fix it.
    We've got several months left in this year...maybe the FPP guys can figure this out. This past season I used the same setup as you and everything was very clear.

  5. #34
    Join Date
    Dec 2012
    Posts
    814
    Post Thanks / Like

    Default Re: No Range at All.. Not Even 12 Inches...

    This problem is in the USB subsystem or firmware and possibly not something that Dan or I can fix. The same is true for the longstanding robot sound issue with the Vast FMT-212R which I also have. A few years ago, I ran with a BBB master so I could use the USB input on the FMT-212R, but for the past two years I have just used the analog input with a Pi 3 B. Unfortunately, neither Dan or I (or Mat who was looking into this a few years ago) have the knowledge or time to look into the USB issue. We have opened a case with the Pi kernel/firmware guys but they havenít come up with a solution yet and didnít take Mat up on his offer to send one of them his FMT-212R to test with.

  6. #35
    Join Date
    Jan 2012
    Location
    Chambersburg, PA
    Posts
    632
    Post Thanks / Like

    Default Re: No Range at All.. Not Even 12 Inches...

    Quote Originally Posted by CaptainMurdoch View Post
    This problem is in the USB subsystem or firmware and possibly not something that Dan or I can fix. The same is true for the longstanding robot sound issue with the Vast FMT-212R which I also have. A few years ago, I ran with a BBB master so I could use the USB input on the FMT-212R, but for the past two years I have just used the analog input with a Pi 3 B. Unfortunately, neither Dan or I (or Mat who was looking into this a few years ago) have the knowledge or time to look into the USB issue. We have opened a case with the Pi kernel/firmware guys but they haven’t come up with a solution yet and didn’t take Mat up on his offer to send one of them his FMT-212R to test with.
    Thanks for the update.
    2012 - 1st year 64 Channels - 7500 LED lights - 5 sequences
    2013 - 128 Channels - 10,000 LED lights - 7 sequences (2 New)
    2014 - 201 Channels - upgrading 8 Arches to dumb RGB - 8+ sequences (1+ New)
    2015 - 240 Channels + 8 Universes - sequences TBD
    2016 - No Display
    2017 - Back in the Game - 240 Renard Channels + 12 Universes
    2018 - 256 Renard and 9 Falcon Outputs of Pixels - 16 sequences shown over 2 nights

  7. #36
    Join Date
    Dec 2016
    Location
    Anchorage, AK
    Posts
    262
    Post Thanks / Like

    Default Re: No Range at All.. Not Even 12 Inches...

    Quote Originally Posted by CaptainMurdoch View Post
    This problem is in the USB subsystem or firmware and possibly not something that Dan or I can fix. The same is true for the longstanding robot sound issue with the Vast FMT-212R which I also have. A few years ago, I ran with a BBB master so I could use the USB input on the FMT-212R, but for the past two years I have just used the analog input with a Pi 3 B. Unfortunately, neither Dan or I (or Mat who was looking into this a few years ago) have the knowledge or time to look into the USB issue. We have opened a case with the Pi kernel/firmware guys but they haven’t come up with a solution yet and didn’t take Mat up on his offer to send one of them his FMT-212R to test with.
    I am not sure I understand why it could be in the usb subsystem or firmware, it worked in 1.x and not in 2.x. Same pi, same hardware. Only thing that changed was the new FPP version. Could you clarify?

  8. #37
    Join Date
    Dec 2012
    Location
    Hudson MA
    Posts
    3,421
    Post Thanks / Like

    Default Re: No Range at All.. Not Even 12 Inches...

    fpp 1.x and 2.x are based on different kernels. I gave up on usb audio and went to an audio pi hat. have not had an issue since.


    2019 - Going to visit my Daughter in New Zealand (again). I will be dark for the 2nd year in a row. Sigh..

  9. #38
    Join Date
    Aug 2008
    Location
    Columbus, OH
    Posts
    4,161
    Post Thanks / Like

    Default Re: No Range at All.. Not Even 12 Inches...

    Which exact hat are you using?
    Quote Originally Posted by MartinMueller2003 View Post
    fpp 1.x and 2.x are based on different kernels. I gave up on usb audio and went to an audio pi hat. have not had an issue since.

  10. #39
    Join Date
    Dec 2012
    Posts
    814
    Post Thanks / Like

    Default Re: No Range at All.. Not Even 12 Inches...

    Quote Originally Posted by aknflyer View Post
    I am not sure I understand why it could be in the usb subsystem or firmware, it worked in 1.x and not in 2.x. Same pi, same hardware. Only thing that changed was the new FPP version. Could you clarify?
    FPP v1.x used a Raspbian/Debian Wheezy Linux install with an older kernel. FPP v2.x uses Raspbian/Debian Stretch. In between Wheezy and Stretch was Jessie, so we jumped 2 major Operating System versions for v2.x. Wheezy was ancient, it had been around since before the first FPP release in 2013, we needed a OS upgrade.

  11. #40
    Join Date
    Dec 2016
    Location
    Anchorage, AK
    Posts
    262
    Post Thanks / Like

    Default Re: No Range at All.. Not Even 12 Inches...

    Thank you for the response, it did'nt occur to me that the OS change was the main reason for the usb audio issues. Guess the audio dongle is the solution for now.

Page 4 of 5 FirstFirst ... 2345 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •