Page 4 of 4 FirstFirst ... 234
Results 31 to 39 of 39

Thread: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

  1. #31
    Join Date
    Jan 2010
    Location
    Mims, Fl
    Posts
    681
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    this is one of my controllers before change

    sandev 5v.jpg
    http://www.vixenlights.com/wp-content/uploads/2013/05/Vixen3-Logo-435x165White-300x107.png

  2. #32
    Join Date
    Jan 2010
    Location
    Mims, Fl
    Posts
    681
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    If i am understanding you with the kitchen WAP, i need to uncheck enable for the DHCP and change start IP to 192.168.0.115?

    If i uncheck the DHCP, that side all grays out. If i pick edit next to router details, i can change the IP address there - that sounds more correct to me, but waiting for confirmation!

    This means i have to change the RPi again from "1" to "0" in the third location - definately waiting for response first.

    Kitchen_router.JPG
    Last edited by ben&bobbi; 01-16-2019 at 09:38 PM.
    http://www.vixenlights.com/wp-content/uploads/2013/05/Vixen3-Logo-435x165White-300x107.png

  3. #33
    Join Date
    Dec 2018
    Location
    Navarre, FL
    Posts
    11
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    Quote Originally Posted by ben&bobbi View Post
    If i am understanding you with the kitchen WAP, i need to uncheck enable for the DHCP and change start IP to 192.168.0.115?

    If i uncheck the DHCP, that side all grays out. If i pick edit next to router details, i can change the IP address there - that sounds more correct to me, but waiting for confirmation!

    This means i have to change the RPi again from "1" to "0" in the third location - definately waiting for response first.

    Kitchen_router.JPG
    Once you uncheck the "Enable DHCP Server" the whole right side should go grey - all those setting are for how the server leases addresses things connected to your network. However, when we put your Kitchen Router in Bridge Mode and make it a true Wireless Access Point it will disable all that for you.
    You don't want to "EDIT" the IP address on the connectivity page yet - you may doing this all on the "Basic Page" if your router supports Bridge Mode.

    1. Before you modify your Kitchen router, since you still have wireless access to the RPi, go into the RPi and change the eth0 setting back to 192.168.0.37 for now ( you can change it back to 192.168.5.250 after we get Wifi back up) - the setting originally given by your ISP Router so that we can access the RPi after the Kitchen Router is configured for Bridge Mode.

    2. I'm not sure of the model of your Kitchen Router, but it looks like a Linksys using the Smart-Wifi software. You can go to this page and follow the steps to put it in Bridge Mode: https://www.linksys.com/us/support-a...icleNum=143751

    a. Before starting the process, get on your bedroom computer and log into your ISP router. Get the current IP address of the Kitchen Router that the ISP router assigned. Should be in one of the "status windows". You will use this address in Step 7 of the procedure above. The gateway will be 192.168.0.1 - your ISP provided gateway and the mask 255.255.255.0.

    If for some reason your router doesn't support Bridge Mode as described in the link provided. You can simply turn off the DHCP (uncheck enable) and then you will edit the IP address of your router so an available address on the 192.168.0.X Subnet (If you were able to find the Kitchen Router address in the ISP router status page - that is the IP address you want to manually give the Kitchen Router)

    3. Once your Kitchen Router is back up again, connect to your RPi via ethernet cable and configure the wlan0 as we did earlier. It will get another 192.168.0.X IP Address from the Wireless connection.

    4. At this point you can change your eth0 setting back to 192.168.5.250.

    In Response to your post about losing connection to your Christmas devices:
    I noticed that the Christmas Router was still set for DHCP, don't forget to disable that as well. That may have caused issue after you reconfigured your controllers.
    Robert USN EM1/SS

  4. #34
    Join Date
    Jan 2010
    Location
    Mims, Fl
    Posts
    681
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    Mine is a little different, its an EA6100. This is where i am at. I need to call service provider and see if i get access to that modem.

    I did reset RPi eth0 value, and can see it fine ... so far

    chenging to bridge.JPG
    http://www.vixenlights.com/wp-content/uploads/2013/05/Vixen3-Logo-435x165White-300x107.png

  5. #35
    Join Date
    Jan 2010
    Location
    Mims, Fl
    Posts
    681
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    almost there, some more success. I have the kitchen router setup in bridge mode. I can see the RPi from the desktop and wireless laptop.

    Now i am lost again. The router for the show, you mentioned to disable DHCP. I tried to setup with static IP address, entered 192.168.5.101, then 255.255.255.0, then 192.168.5.1 and for DNS i think i entered 192.168.5.1 again. Well, this did not work, i can not access the router with any of those addresses, even directly plugged in with laptop. So i have reset the router and looking for instructions to access it again.

    Controllers still a no show. I even tried to direct connect to them and no luck. So i will reset them too.
    Last edited by ben&bobbi; 01-18-2019 at 10:12 PM.
    http://www.vixenlights.com/wp-content/uploads/2013/05/Vixen3-Logo-435x165White-300x107.png

  6. #36
    Join Date
    Jan 2010
    Location
    Mims, Fl
    Posts
    681
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    Router back, this is the setup page. I will wait for help this time. I thought i understood it!

    resetting router.JPG
    http://www.vixenlights.com/wp-content/uploads/2013/05/Vixen3-Logo-435x165White-300x107.png

  7. #37
    Join Date
    Dec 2018
    Location
    Navarre, FL
    Posts
    11
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    Quote Originally Posted by ben&bobbi View Post
    Router back, this is the setup page. I will wait for help this time. I thought i understood it!

    resetting router.JPG
    Always remember that devices cannot talk to other devices on a different SUBNET. Once you configure your Show Router and Show devices to the 192.168.5.X Domain, you won't be able to see them with your laptop (since it has an IP on the 192.168.0.X SUBNET) unless you give your laptop a 192.168.5.X static address as well and connect directly to the show router.

    So no need to reset your Christmas Controllers, they are still there, just on a different SUBNET. You can also set your router back up as you did before.

    First Option
    The quickest way to "talk" to your Christmas Network again, would be to connect the laptop via ethernet cable to your show router, go into your network settings, and give your laptop a 192.168.5.X Address (pick a number other than the PI or your controllers)
    - You can search "How to change your IP Address in Youtube for <your version of Windows>"
    - I found this video to be short and simple for Windows 10 - https://www.youtube.com/watch?v=1p7Xt070RJw

    When your done with looking at your Show Network, remember to go back into those Network Settings and choose "Obtain IP Address Automatically" when you want to connect back to your home network.

    Second Option

    If your RPi is in range of your Kitchen network when it is connected via a ethernet cable to your show network you can configure FPP as a Network Bridge. This means that the FPP will act like your router to "route" network traffic to the appropriate devices in the Christmas Network. Therefore, once set up you could see and configure your show devices from any computer on your home network.

    It's a longer process to set up. Below is a link to a video by Keith Westly showing you how to bridge your FPP. The link starts at the point he discusses bridging, however it is a good seminar on show networking in general:

    Robert USN EM1/SS

  8. #38
    Join Date
    Jan 2010
    Location
    Mims, Fl
    Posts
    681
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    thanks again! I have watched that video before i even started trying, and that is where i want to get to. I will go through the video again. I have everything in the house now, so i will get it reconnected again. So no reset on the controller right now. I kept scratching my head wondering how i could have messed them up, thanks again for clarify. it will sink in eventually.

    I can see the RPi from the desktop and wireless laptop while it is out in show position.
    http://www.vixenlights.com/wp-content/uploads/2013/05/Vixen3-Logo-435x165White-300x107.png

  9. #39
    Join Date
    Jan 2010
    Location
    Mims, Fl
    Posts
    681
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    Go me Go me! Ok, the real thanks goes to these guys - thank you thaistalyn for all your detailed help, and Stormyblade for your helpful comments too - i read them all! I hope others are reading this and getting theirs to work also.

    I can now access my RPi and E682 from my desktop computer following the command prompts from the video. My E682 does not have a way to enter a gateway. So as he mentioned in the video, i may not be done, and i can't get the "dater" back from the controller. This may not be an issue for me, because it seems to be working. I have a light set plugged in and can change the test pattern and see blinking light. I hope this means my communication path is open for light business.

    connected controller.jpg
    http://www.vixenlights.com/wp-content/uploads/2013/05/Vixen3-Logo-435x165White-300x107.png

  10. Thanks thaistalyn thanked for this post
    Likes Stormyblade, thaistalyn liked this post
Page 4 of 4 FirstFirst ... 234

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •