Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 39

Thread: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

  1. #11
    Join Date
    Jan 2010
    Location
    Mims, Fl
    Posts
    681
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    Quote Originally Posted by FishKing View Post
    Hi ben&bobbi,

    Didn't mean to hijack your thread. Just sounded like we're having basically the same problems. So I figured with both of us asking questions we could both somehow sort out this networking nightmare. I will post any info I come across that might help you too.

    Thanks, Dale
    Yah, no problem at all!
    http://www.vixenlights.com/wp-content/uploads/2013/05/Vixen3-Logo-435x165White-300x107.png

  2. #12
    Join Date
    Dec 2018
    Location
    Navarre, FL
    Posts
    11
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    @ben&bobbi

    Can you post your network settings as Fishking did? If possible it would be good to see your home/kitchen settings. You can do this by going to a computer hooked up to the home network, right click the windows start button in the bottom left, click "Run", type CMD in the box and hit enter. On the CMD Prompt type ipconfig.

    You can also follow the instructions below, but be sure to update the IP Address information in the ETH0 for static IP Address to be a IP Address on your show network.

    @Fishking

    Looking at your attachments a few posts up it looks like you may have done things backwards from the recommendations in the Canispater XMAS video. I think you should start from the beginning and work through the settings. Start with the Wlan so you can at least get communicating with the PI player again. To make the changes below your going to have to bring the PI/FPP to your Kitchen and hook it up with a Cat5/6 ethernet cable to get these setting changed first. You may have to re-install the FPP software on the SD card, since we don't know the IP address of the PI player

    I'm going to give you some extra information, hopefully it is not too technical:

    Background Info:
    • wlan is the wireless setting selection
    • We will be using the wlan to connect to your home router
    • Unless you know how to configure your router to keep your Rasperry Pi running FPP with a Static IP Address then you need to set the "interface mode" to DHCP for the wlan
    • The reason you may have lost connection to your PI is because you set a static address in the FPP, but may not have told your router to keep the FPP address static (see#3 above - unless you know how to tell your router to give a device a static address)
    • Every once in a while your router expires the "lease" on an IP address for devices using DHCP instead of Static - Static forces your router to reserve the address forever.
    • In Summary - set your WLAN "Interface Mode" to DHCP it will result in less headache if you don't know how to configure your router for a static address.



    FPP WLAN SETTINGS
    1. Goto the FPP Network setting page
    2. Make sure you select the WLAN0 "Interface Name"
    3. Select DHCP for the Interface Mode
    4. Leave IP address, Netmask, and gateway blank
    5. Looks like you already entered your Wireless network details, just double check they are correct.
    6. Click on the update interface button - you should see a little diaglog box in the upper right that says "wlan0 network interface configuration saved"
    7. Finally, click restart network. Give it a few seconds to restart.
    8. Go to the Status Control Page - Status Page - you should see 2 IP addresses in the top bar right under the words "FALCON PLAYER - FPP". The first one is your ethernet connect IP address (eth0). The second one is the new Wireless IP.
    9. At this point we are done getting you set up on WIFI with a DHCP address for WLAN0
    10. You can always access your PI player by typing "FPP/" in your favorite browser and not have to type in the IP address (the magic of DNS - we won't get into it)


    Now, lets configure your eth0 connection to be connected to your "SHOW" network. Before we begin a little information:
    • Usually on your show network, device IP addresses are static and configured by you when you set up the controller.
    • Your "SHOW" network has a Wireless Router that could be setting addresses by DHCP. I would suggest you turn off DHCP on the "SHOW" network. You can google how or tell the router model and I may able to provide instruction.
    • We will be using the ETH0 connection to connect to your "SHOW" network.
    • From the E682 Setting picture it looks like your "SHOW" network is on the 169.254.74.XX Domain. I would suggest you give the PI/FPP a static address in this DOMAIN that you know is not being used by any of your "CHRISTMAS" network devices. Something like 169.254.74.199


    FPP ETH0 SETTINGS
    Now lets set-up your ETH0 connection to be static and on your "Christmas" network
    1. Select the ETH0 Interface Name for set up
    2. Choose the "Static" Interface Mode
    3. In the IP Address field enter "169.254.74.199" (as long as this IP address isn't used by something else in your SHOW network)
    4. In the Netmask field enter "255.255.0.0" - same as your E682
    5. In the Gateway field enter "168.254.1.1" - I'm just guessing this is your gateway. Usually the XXX.XXX.XXX.1 address is the network gateway. Or you may be able to leave this blank.
    6. Click on Update Interface, then Click on Restart Network
    7. Give the FPP some time to restart then type in "FPP/" into your browser.
    8. Now look at the IP address in the Top Area (under FALCON PLAYER - FPP) and next to where it says Host: FPP. You should see in parenthesis (169.254.74.199) and next to that the IP address from WLAN set up above.
    9. You are now ready to disconnect the ethernet cable from your PI in the Kitchen/House and take it our to the shop and connect the ethernet to your show network!!
    Last edited by thaistalyn; 01-13-2019 at 01:44 AM.
    Robert USN EM1/SS

  3. Likes Stormyblade liked this post
  4. #13
    Join Date
    Dec 2018
    Location
    Navarre, FL
    Posts
    11
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    @ben&bobbi

    1. The SSID and Password should be the same network name/password you use to connect wirelessly to your home network - the same one you give to friends when they come over and want to connect to your WIFI.
    2. Maybe try to have the RPi connect wirelessly to your Router from the Internet Provider? (It should be a wireless router), with the one in the kitchen being a dumb wireless access point.
    Robert USN EM1/SS

  5. #14
    Join Date
    Jan 2016
    Location
    West Bloomfield, MI
    Posts
    642
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    Quote Originally Posted by FishKing View Post
    Hi Ed,

    I followed everything you suggested and when I updated and was going to the status page, I lost my connection to the Pi. On the router it only shows as offline. I'm back to where I can't get FPP on my computer browser or phone. Any thoughts.

    Thanks, Dale
    FishKing - Since you didn't change the wlan0 info, you should have maintained your wireless connection. Do you have the RPi connected by cable to the router (it should not be)? Did you try powering the RPi off and on?
    Ed
    Happily retired

  6. #15
    Join Date
    Jan 2010
    Location
    Mims, Fl
    Posts
    681
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    i think i messed mine up too, i can't get to it anymore. I brought it in the house to make this a little easier (i thought). The video output from the RPi (HDMI connected to TV and hard wired to network) says "my IP address is 192.168.1.102. In the show network, it was 192.168.1.100

    Connected by lan to my home network, on the FPP page it had two addresses (192.168.1.102 192.168.0.37) I am not certain on the original order. I tried entering those into wan and lan and thats when it stopped working. I can't get to it using either of those numbers.

    this is what i have that i can get to. the FPP screen was stuck like that when i tried to set it before.

    desktop computer.JPG


    Home kitchen router.JPG
    christmas dumb router.JPG
    Last edited by ben&bobbi; 02-06-2019 at 04:39 PM.
    http://www.vixenlights.com/wp-content/uploads/2013/05/Vixen3-Logo-435x165White-300x107.png

  7. #16
    Join Date
    Jan 2010
    Location
    Mims, Fl
    Posts
    681
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    from reading above, i am reflashing my sd card, and calling it a night.
    http://www.vixenlights.com/wp-content/uploads/2013/05/Vixen3-Logo-435x165White-300x107.png

  8. #17
    Join Date
    Jan 2010
    Location
    Mims, Fl
    Posts
    681
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    ok, i couldn't until tomorrow night. here is the reloaded FPP connected to my home network with cable. now i am calling it a night.

    FPP Reloaded.JPG
    http://www.vixenlights.com/wp-content/uploads/2013/05/Vixen3-Logo-435x165White-300x107.png

  9. #18
    Join Date
    Jan 2016
    Location
    West Bloomfield, MI
    Posts
    642
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    Quote Originally Posted by ben&bobbi View Post
    ok, i couldn't until tomorrow night. here is the reloaded FPP connected to my home network with cable. now i am calling it a night.

    FPP Reloaded.JPG
    ben&bobbi - A couple of things I noticed from your screen shots. First, I would set your FPP eth0 to be a static IP address otherwise your router will potentially change it each time you connect it via cable. Once you get your wifi connection to work, then this IP address needs to change to your show network. Secondly, on your wlan0 setup, you have the gateway and the address of the RPi the same. That cannot be. The gateway is the IP address of the router. The IP address for wlan0 is the static IP address of the RPi. The first three numbers will be the same as the gateway but the last number will be unique to the RPi.
    Ed
    Happily retired

  10. Likes Stormyblade liked this post
  11. #19
    Join Date
    Jan 2010
    Location
    Mims, Fl
    Posts
    681
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    Quote Originally Posted by ezellner View Post
    ben&bobbi - A couple of things I noticed from your screen shots. First, I would set your FPP eth0 to be a static IP address otherwise your router will potentially change it each time you connect it via cable. Once you get your wifi connection to work, then this IP address needs to change to your show network. Secondly, on your wlan0 setup, you have the gateway and the address of the RPi the same. That cannot be. The gateway is the IP address of the router. The IP address for wlan0 is the static IP address of the RPi. The first three numbers will be the same as the gateway but the last number will be unique to the RPi.
    Warning, dumb question coming - is my home IP address 192.168.1.X or 192.168.0.x? The ipconfig window looks like it is 0, but the router screen shots look like its 1.

    The two being the same might be what caused it to hang up when i was trying to reset it the first round. i will go through this evening i hope.
    http://www.vixenlights.com/wp-content/uploads/2013/05/Vixen3-Logo-435x165White-300x107.png

  12. #20
    Join Date
    Dec 2018
    Location
    Navarre, FL
    Posts
    11
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    @ben&bobbi

    Now were cooking with fire in the Kitchen!!

    Alright, first a little analysis of your network:
    1. Your internet provider, provided router is using the 192.168.0.X subnet to provide IP addresses for your home devices. This is evident from your first screenshot of the "Bedroom Computer"
    2. Your Kitchen router (I call it a Wireless access point-WAP) is using the 192.168.1.X subnet, that is why it originally assigned the RPi a wireless address of 192.168.1.102 and if you look at your image 4 (Home Kitchen Router) - you can see on the top left the Start IP address of 192.168.1.100 for the DHCP server (basically this DHCP server will dish out addresses in the ranges of 192.168.1.100 to 192.168.1.149)
    3. In addition, when you hook up with the ethernet cable in the house you can see that the Internet Provider Router is assigning the RPi with an address in the 192.168.0.X subnet. The first time around it assigned the RPi 192.168.0.37 and after you flashed the SD again it remembered and gave the RPi back the address 192.168.0.37.
    4. Finally, your "Christmas Router" - It is also set up for the 192.168.1.X subnet AND it is set up to dish out addresses in the range of 192.168.1.100 - 192.168.1.149. Another item I noticed on the "Christmas Router" network was that the DHCP Server is enabled, meaning it has the ability to put "leases" on IP addresses and can change them at will.
    5. Right now there are 2 problems with the "Christmas Router" network
      1. It has the same IP address range for hosts as your Kitchen Router, this could wreak havoc if devices are in range of both wireless networks as it is possible to duplicate an addresses. If they were sooo far apart that this would never happen it would be alright. Like more than a football field (100 yards) away for any device that would be on either network.
      2. The Christmas Router has DHCP enabled. If you were to set up an Xmas controller with an IP address (configure it in Falcon) it is entirely possible that the DHCP server would disagree and give it a new IP Address - unless you know how to use that "DHCP reservation button" and statically assign your Christmas show devices. In addition, you would need to add your RPi to that static list. At the end of the day, if you are statically setting all your show device IP addresses, you might as well turn of the DHCP server. There is no need for it to be "setting" device IP Addresses.


    Summary of your Network

    Internet Provider Router
    Subnet: 192.168.0.X

    Kitchen WAP
    Subnet: 192.168.1.X

    Christmas Router
    Subnet 192.168.1.X

    Current Status of Rpi
    Connected to Home Network with physical cable and reserving the 192.168.0.37 address on RPi Interface eth0
    You should also be able to connect to the RPi from any of your house computers by typing "FPP/" into any browser window.

    Next Steps - Getting the RPi set up on the Kitchen Network

    FPP WLAN SETTINGS
    1. Goto the FPP Network setting page
    2. Make sure you select the WLAN0 "Interface Name"
    3. Select DHCP for the Interface Mode
    4. Leave IP address, Netmask, and gateway blank
    5. Looks like you already entered your Wireless network details (kitchen / mustang9), just double check they are correct.
    6. Click on the update interface button - you should see a little diaglog box in the upper right that says "wlan0 network interface configuration saved"
    7. Finally, click restart network. Give it a few seconds to restart.
    8. Go to the Status Control Page - Status Page - you should see 2 IP addresses in the top bar right under the words "FALCON PLAYER - FPP". The first one is your ethernet connect IP address (eth0) and should be 192.168.0.37. The second one is the new Wireless IP, which should have the format of 192.168.1.x
    9. At this point we are done getting you set up on WIFI with a DHCP address for WLAN0
    10. You can always access your PI player by typing "FPP/" in your favorite browser and not have to type in the IP address (the magic of DNS - we won't get into it)


    Next Steps - Dealing with the Christmas Network

    You now have some decisions to make on the Christmas network. I also need a little more information to help at this point.

    Do you have controllers already on the Christmas Network?
    If so, what are their IP addresses. You should be able to see this from the Christmas Router "status" page.

    Bottom Line is that we need to put the Christmas Network on a new SUBNET. Below is an example. You would have to make some changes in your "Christmas Router" and show controllers. However, it will clean up the issue of having 2 identical subnets around your home.

    Notice in the example below we are using the 192.168.2 - SUBNET so we don't collide with your 192.168.0.x Home and 192.168.1.x Kitchen networks.

    Show Network 192.168.2.X
    Raspberry PI 192.168.2.200
    Controller #1 192.168.2.2
    Controller #2 192.168.2.3

    Once you decide how you want to handle the "Christmas" network, we can continue configuring the RPi for the eth0 connection. The example I provided gives the RPi an address of 192.168.2.200 - but the Christmas network needs to be changed first!
    Robert USN EM1/SS

  13. Likes Stormyblade liked this post
Page 2 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •