Page 1 of 4 123 ... LastLast
Results 1 to 10 of 39

Thread: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

  1. #1
    Join Date
    Jan 2010
    Location
    Mims, Fl
    Posts
    629
    Post Thanks / Like

    Default Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    How do i get to the IP address on the Pi? Do i set it up on the FPP Network page? I don't see it telling me the Pi IP address. Forgive me if this sounds backwards, i am not really sure where to start, but trying to work through this!

    I believe i want to setup like this video at 6:50 mark - https://www.youtube.com/watch?v=g0fOZs6UgXw&t=10s

    I want to try getting my show network setup so i can access it from the house network without switching a laptop between two wifi networks and sitting in the kitchen.

    My setup has a wireless router with the Pi and the E682 controllers connected, Renard output from the Pi. I think right now i am accessing everything with the laptop switched to my "Christmas" wifi thru the router outside. The closest access from the home network to the show network is a wireless router in the kitchen. Right now, i am not sure the wireless router inside is strong enough to see the Pi or router outside.
    http://www.vixenlights.com/wp-content/uploads/2013/05/Vixen3-Logo-435x165White-300x107.png

  2. #2
    Join Date
    Dec 2018
    Location
    Navarre, FL
    Posts
    11
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    Hopefully one of your 2 wireless networks (preferably the Home Network) can reach the Pi in the "office" which is connected to your Show Network.

    Check out the video from Canispater Christmas. He walks you through setting up this network bridge.


  3. #3
    Join Date
    Jan 2015
    Location
    New Berlin, WI
    Posts
    183
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    I've watched this video over and over but I can't get my FPP to handle the wireless part. I have a Pi3 B v1.2 and FPP 1.10...
    I've followed the steps in the video religiously and can't get it to go wireless. When looking at my router connections it only shows the Pi as an ethernet connection. I can see the FPP ina browser but lose it as soon as the ethernet cable is disconnected. Any help would be greatly appreciated.

  4. #4
    Join Date
    Nov 2010
    Location
    Manhattan Kansas
    Posts
    223
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    Post screen shots of your network settings here.

  5. #5
    Join Date
    Jan 2015
    Location
    New Berlin, WI
    Posts
    183
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    Quote Originally Posted by K-State Fan View Post
    Post screen shots of your network settings here.
    Now I can't connect with the Pi at all. Is there any way I can check or change settings when this happens?

    Thanks, Dale

  6. #6
    Join Date
    Jan 2015
    Location
    New Berlin, WI
    Posts
    183
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    Quote Originally Posted by K-State Fan View Post
    Post screen shots of your network settings here.
    Finally connected to the Pi again! Here are the screen shots of the settings. Thanks, Dale

    wlan0 Settings.png
    eth0 Settings.png
    Router Connections.png
    E682 Settings.jpg

  7. #7
    Join Date
    Jan 2016
    Location
    West Bloomfield, MI
    Posts
    616
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    Quote Originally Posted by FishKing View Post
    Finally connected to the Pi again! Here are the screen shots of the settings. Thanks, Dale

    wlan0 Settings.png
    eth0 Settings.png
    Router Connections.png
    E682 Settings.jpg
    Based on your E682 setting, for eth0, set IP address as static 169.254.74.01, mask 255.255.255.0, leave gateway blank, check the box at the bottom that says "Enable routing between network interfaces." Also plug in your DNS settings. If using a PC, go to the command prompt. Type "ipconfig /all" and it will list your primary and secondary DNS IP addresses. Copy those onto the RPi in the appropriate places. To connect to the E682 through the RPi wirelessly, you will have to do a route command. Again, you'll need the command prompt but make sure you launch it as administrator. Type "route /p add 169.254.74.0 mask 255.255.255.0 192.168.0.24" This tells your computer not to look on the internet for that IP address but rather go through your RPi to find it. The /p makes the route "persistent" so that it stays after you restart your computer. Otherwise it will clear on restart. Note I am assuming all your devices connected to the RPi through the Ethernet cable have ip addresses that only change the last number. If you are changing the last two numbers, the route command needs to change. Also, you should update your E682 firmware to version 5.030. This will allow you to specify your mask. Right now it is set to give you over 65,000 devices on the network.
    Ed
    Happily retired

  8. #8
    Join Date
    Jan 2010
    Location
    Mims, Fl
    Posts
    629
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    coincidence, i took a little time to check into this again myself. I do not mind at all both of us getting help here. If you respond to help us, just put the username of the person you are talking to first. - Appreciate the help!


    I am still having an issue, maybe i am not using the correct wording. The password for the wlan0 is for my home network "router" - correct? The wireless "router" (called kitchen) i have closest to the show i have been told is setup more like a switch. I have a wire running from my Internet router from provider into one of the 4 ports (not internet in - yellow port) on the "wireless router". Right now, we log into kitchen wirelessly for internet on cell phones, etc..

    On the RPi, I put SSID in as "kitchen" and shared key i put the password. I hit Update Interface and is says its updated, Restart Network shows up and i select that. It doesn't look like anything happens, no second address pops up at the top of the RPi screen.

    Maybe i have issues before this issue. Looking on my desktop computer, under devices i see the "kitchen" router, but it is a grayed out icon listed with my keyboard, mouse, etc.. Should i be able to log into this router from my desktop just like i can wirelessly from laptop? When i enter the IP address, it says can't be found.

    Any ideas!?
    Last edited by ben&bobbi; 01-12-2019 at 09:29 PM.
    http://www.vixenlights.com/wp-content/uploads/2013/05/Vixen3-Logo-435x165White-300x107.png

  9. #9
    Join Date
    Jan 2015
    Location
    New Berlin, WI
    Posts
    183
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    Quote Originally Posted by ezellner View Post
    Based on your E682 setting, for eth0, set IP address as static 169.254.74.01, mask 255.255.255.0, leave gateway blank, check the box at the bottom that says "Enable routing between network interfaces." Also plug in your DNS settings. If using a PC, go to the command prompt. Type "ipconfig /all" and it will list your primary and secondary DNS IP addresses. Copy those onto the RPi in the appropriate places. To connect to the E682 through the RPi wirelessly, you will have to do a route command. Again, you'll need the command prompt but make sure you launch it as administrator. Type "route /p add 169.254.74.0 mask 255.255.255.0 192.168.0.24" This tells your computer not to look on the internet for that IP address but rather go through your RPi to find it. The /p makes the route "persistent" so that it stays after you restart your computer. Otherwise it will clear on restart. Note I am assuming all your devices connected to the RPi through the Ethernet cable have ip addresses that only change the last number. If you are changing the last two numbers, the route command needs to change. Also, you should update your E682 firmware to version 5.030. This will allow you to specify your mask. Right now it is set to give you over 65,000 devices on the network.
    Hi Ed,

    I followed everything you suggested and when I updated and was going to the status page, I lost my connection to the Pi. On the router it only shows as offline. I'm back to where I can't get FPP on my computer browser or phone. Any thoughts.

    Thanks, Dale

  10. #10
    Join Date
    Jan 2015
    Location
    New Berlin, WI
    Posts
    183
    Post Thanks / Like

    Default Re: Networking Q1 - FPP on Rasberry Pi, how do i get back to wireless setup on Pi

    Quote Originally Posted by ben&bobbi View Post
    coincidence, i took a little time to check into this again myself. I do not mind at all both of us getting help here. If you respond to help us, just put the username of the person you are talking to first. - Appreciate the help!


    I am still having an issue, maybe i am not using the correct wording. The password for the wlan0 is for my home network "router" - correct? The wireless "router" (called kitchen) i have closest to the show i have been told is setup more like a switch. I have a wire running from my Internet router from provider into one of the 4 ports (not internet in - yellow port) on the "wireless router". Right now, we log into kitchen wirelessly for internet on cell phones, etc..

    On the RPi, I put SSID in as "kitchen" and shared key i put the password. I hit Update Interface and is says its updated, Restart Network shows up and i select that. It doesn't look like anything happens, no second address pops up at the top of the RPi screen.

    Maybe i have issues before this issue. Looking on my desktop computer, under devices i see the "kitchen" router, but it is a grayed out icon listed with my keyboard, mouse, etc.. Should i be able to log into this router from my desktop just like i can wirelessly from laptop? When i enter the IP address, it says can't be found.

    Any ideas!?
    Hi ben&bobbi,

    Didn't mean to hijack your thread. Just sounded like we're having basically the same problems. So I figured with both of us asking questions we could both somehow sort out this networking nightmare. I will post any info I come across that might help you too.

    Thanks, Dale

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •