Results 1 to 6 of 6

Thread: Bug in image mapping in lypsync effect

  1. #1
    Join Date
    Feb 2017
    Posts
    55
    Post Thanks / Like

    Default Bug in image mapping in lypsync effect

    The seems to be a bug in the Image Maps editor. An example. I have a Image mapping that is 12 * 12 pixels (144 pixels all in all). The bottom row seems to be moved one row up. So the bottom row of the image is shown on row 2 (looking from bottom and up) and so on (first line in y axsis). This means that the top row of the image itselves is not shown. In the preview I can see that it only show 11 of the 12 rows. So I tested my mapping both with text effect and level effect and here it works fine. So my mapping of the element I believe is correct.

    I tried to experiement with the y offset in the effect editor on the lipsync configuration. Trying to go both up and down it just seems as not possible to fill out the 1 row on the y axsis. Could there not be a bug here. I have the same issues with other images just in larger scale.

  2. #2
    Join Date
    Oct 2011
    Location
    Maryville, Illinois
    Posts
    1,603
    Post Thanks / Like

    Default Re: Bug in image mapping in lypsync effect

    I did some debugging this morning and it looks like there is an index offset bug in the lip-sync and the regular picture effect. I have made a fix and asked one of the other developers that uses more of those effects to give it some testing to make sure it works correctly. You can follow the ticket here:

    https://bugs.vixenlights.com/browse/VIX-2674

  3. #3
    Join Date
    Nov 2011
    Location
    Chicago - Southwest Suburbs
    Posts
    7,741
    Post Thanks / Like

    Default Re: Bug in image mapping in lypsync effect

    Looks like Jeff found the bug and is testing the fix now.

  4. #4
    Join Date
    Feb 2017
    Posts
    55
    Post Thanks / Like

    Default Re: Bug in image mapping in lypsync effect

    Sound great you allready found the bug. Looking forward to the correction.

  5. #5
    Join Date
    Feb 2017
    Posts
    55
    Post Thanks / Like

    Default Re: Bug in image mapping in lypsync effect

    I can see that the bug is fixed. So how does it work then, do I need to wait for the next release in order to help you "test" the fix?

  6. #6
    Join Date
    Oct 2011
    Location
    Maryville, Illinois
    Posts
    1,603
    Post Thanks / Like

    Default Re: Bug in image mapping in lypsync effect

    You can go and download the latest development build and give it a try yourself. Make sure you have backups of your profile, but the current development builds are stable.

    http://www.vixenlights.com/downloads/devbuild/

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •