Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Power supplies failing

  1. #11
    Join Date
    Jan 2016
    Location
    West Bloomfield, MI
    Posts
    561
    Post Thanks / Like

    Default Re: Power supplies failing

    Quote Originally Posted by Macrosill View Post
    Steve,
    I feel your pain. I had the display up and tested 100 percent a week before show time. I powered everything down for the week. On Friday I powered up the show and everything was fine, or so I thought. I watched the show that night and noticed my arches were not working. Turns out the power supply for that controller took a poop and was only putting out 2.5v. A quick swap and I was back in business. How does that happen? Things like that make me shake my head.
    Me too!
    Ed
    Happily retired

  2. #12
    Join Date
    Jan 2017
    Location
    Southern California
    Posts
    21
    Post Thanks / Like

    Default Re: Power supplies failing

    Agreed. Don't cheap out on power supplies. Meanwells are quality and built very nice. I don't trust generic power supplies.

  3. #13
    Join Date
    Nov 2012
    Location
    Toronto, ON.
    Posts
    245
    Post Thanks / Like

    Default Re: Power supplies failing

    Steve,

    Where are you located in Ontario? I've got 2 Brand new, never used Mean Well LRS-350-12 units in reserve. They are yours if you need them.

    Just PM me with your details.



    Shane

    Sent from my SM-G955W using Tapatalk

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •