Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Need help with my Raspberry Pi and FPP

  1. #1
    Join Date
    Dec 2017
    Location
    Jacksonville, FL
    Posts
    17
    Post Thanks / Like

    Default Need help with my Raspberry Pi and FPP

    Trying to get my Raspberry Pi 3B+ to talk to my E682 controller. I have researched and read everything I can find on this forum as well as the Falcon Christmas forum, watched numerous Youtube videos and I still can't seem to get this system working. I put together a short 30 second sequence in Vixen and xLights for a 7 string matrix with 50 nodes on each string. Either sequence will run fine off of my laptop. I have been working with this project for a month now, When I got out of bed this morning I said to myself "today I will get the Pi working as it should". I watched the Canispater Christmas videos on the set up. I had been working with version 2.3 on the FPP but I started from scratch with Jeff, formatted my sd card and loaded 2.1 so everything I was looking at would be the same as the video. I loaded my sequence, set the schedule and every time I open FPP on the web it shows it playing the sequence. Now here is the kicker, my pi and the controller are both plugged into the back of my router so I could take some screen shots that I'm sure will be needed for you guys to help me get things worked out, the sequence is running to my lights. I hooked the pi back up to the controller just to see if it would run, no joy. I am pretty computer savvy when it comes to software and such but I have no experience with networks and the like. Truthfully guys I don't know where to start, I'm sure it is a setting somewhere that I have missed. Reading the user manuals for FPP and the E682 there is a lot of that info that I'm not real clear on. Sorry for the long post but I thought I would give you some history. Thanks in advance for your help.

  2. #2
    Join Date
    Dec 2012
    Location
    Hudson MA
    Posts
    3,069
    Post Thanks / Like

    Default Re: Need help with my Raspberry Pi and FPP

    Please post the FPP output channel configuration. Most likely you are either not sending the data to the correct destination or you have not set up the destination properly to receive the data.

    Did you try to send the data to the controller using the xlights player?


    2018 - Moving and going to visit my Daughter in New Zealand. Most likely I will be dark or nearly dark, Some static stuff that is simple to put up.

  3. #3
    Join Date
    Nov 2014
    Location
    Close to Hillsboro, OR
    Posts
    293
    Post Thanks / Like

    Default Re: Need help with my Raspberry Pi and FPP

    Would probably also need to see a screenshot of your E682 configuration. I've got a Pi 3B (running as Master) running to a network switch (not a router), and also plugged into that switch is 3 E682 controllers and 2 BBBs (running in Remote). I have zero problems with the E682s displaying, and I went Unicast vs Multicast, so each E682 has it's own specific IP address assigned (top of the E682 web UI, type in specific IP).

    Not trying to say you didn't check, but also make sure you have the # of pixels set for each output on the E682 (ex. 1-1 is set to 35, 2-1 is set to 40, etc) and that matches the # of pixels you have assigned in xLights (for instance, I have 8 mini trees, all with 70 pixels, assigned as Mini Tree 1 thru 8 in xLights and am using 8 outputs, 3-1 thru 4-4 on the E682, that all have string size set to 70).

  4. #4
    Join Date
    Jan 2016
    Location
    West Bloomfield, MI
    Posts
    506
    Post Thanks / Like

    Default Re: Need help with my Raspberry Pi and FPP

    When your Pi is plugged into your controller, do the yellow and green lights at the network connection blink or are they on solid? If solid, it means no data is being transmitted. This also means something in your setup is incorrect. As others before me have said, post screen shots of your two Pi Network pages (one for eth0 and one for wlan0) plus your main page of the E682 which shows its IP address.
    Ed
    Happily retired

  5. #5
    Join Date
    Dec 2017
    Location
    Jacksonville, FL
    Posts
    17
    Post Thanks / Like

    Default Re: Need help with my Raspberry Pi and FPP

    ScreenshotE682A.jpg ScreenshotFPP.jpg ScreenshotFPP.etho1.jpg
    Hopefully these screen shots are OK.
    MartinMueller2003 it did run the xLights sequence from my laptop OK.
    Stormyblade will double check this in my xLights settings.
    ezellner the green light is blinking, the yellow light is on steady at the ethernet connection.

  6. #6
    Join Date
    Nov 2011
    Location
    Richmond, TX (Pecan Grove)
    Posts
    241
    Post Thanks / Like

    Default Re: Need help with my Raspberry Pi and FPP

    You should probably fill in the subnet mask and gateway on the FPP. From the e682 config page subnet is 255.0.0.0, I guess gateway should be 10.0.0.1. Not sure if it will matter, but you might also want to set DNS to manual, and set them same as the gateway 10.0.0.1

  7. #7
    Join Date
    Nov 2011
    Location
    Richmond, TX (Pecan Grove)
    Posts
    241
    Post Thanks / Like

    Default Re: Need help with my Raspberry Pi and FPP

    nothing else sticks out to me - I'll be connecting some e682s to FPP this weekend for first time (as I've been using PC for years), will chime in if I see anything. I'll note that I've already tested my Renard outputs and they're working well, just haven't gotten to the e682s yet.

  8. #8
    Join Date
    Dec 2017
    Location
    Jacksonville, FL
    Posts
    17
    Post Thanks / Like

    Default Re: Need help with my Raspberry Pi and FPP

    Thanks EMKLLK, changes have been made. Will test it again.
    Last edited by oldcaptainrusty; 11-09-2018 at 01:28 PM.

  9. #9
    Join Date
    Nov 2011
    Location
    Richmond, TX (Pecan Grove)
    Posts
    241
    Post Thanks / Like

    Default Re: Need help with my Raspberry Pi and FPP

    good luck!

  10. #10
    Join Date
    Dec 2017
    Location
    Jacksonville, FL
    Posts
    17
    Post Thanks / Like

    Default Re: Need help with my Raspberry Pi and FPP

    Made the changes recommended by EMKLLK and the sequence is running from my pi now. I was sure it was some setting that this old dumb country boy had missed, I just didn't know where to start. Thanks gentleman for your time, I'm sure I'll have more questions as this project progresses.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •