Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Cheap ESP-01 Modules that don't work for an ESPixelStick

  1. #1
    Join Date
    Jan 2014
    Posts
    23
    Post Thanks / Like

    Default Cheap ESP-01 Modules that don't work for an ESPixelStick

    So I purchased 10 ESP-01's from Aliexpress, and they don't work. At least they don't work with the ESPixelStick code. Seems to be a common problem. Guessing not all ESP-01's are the same.

    I could flash the ESP by 'hard-coding' the spiffs file. The ESP would work the first time, but never reconnect.

    The ESP-01 I had with 'AI-Cloud Inside' works fine, no issues.

    Anyone found a use for these 'bad' ESP-01's? Or a fix to get around the connection issue?

    Are there known good ESP-01's we should be buying? I ordered more from Aliexpress with the 'AI-Cloud Inside' in the picture.

    Thanks
    Attached Images Attached Images

  2. #2
    Join Date
    Jan 2015
    Location
    Folsom, CA, USA
    Posts
    1,550
    Post Thanks / Like

    Default Re: Cheap ESP-01 Modules that don't work for an ESPixelStick

    Known issue. No fix for ESP Sticks yet...may never be a fix. No know way to guarantee you won’t get them again. Try domestic source- pay more, but pre tested.
    In Lights Therapy

  3. #3
    Join Date
    Dec 2012
    Location
    Hudson MA
    Posts
    2,952
    Post Thanks / Like

    Default Re: Cheap ESP-01 Modules that don't work for an ESPixelStick

    Interesting. Look at the chip next to the CPU. On the working version, the chip is physically larger. If I remember the discussions, it is that chip that has the timing issue that causes the ESP-01s to fail. So if you see a picture of what you are getting, make sure it has the larger chip installed. FYI: That is not a guarantee, just something I noticed in your picture.


    2018 - Moving and going to visit my Daughter in New Zealand. Most likely I will be dark or nearly dark, Some static stuff that is simple to put up.

  4. #4
    Join Date
    Jan 2015
    Location
    Folsom, CA, USA
    Posts
    1,550
    Post Thanks / Like

    Default Re: Cheap ESP-01 Modules that don't work for an ESPixelStick

    How good are you at soldering smd devices. I fixed 5 of them by floating solder with an iron.
    Chip = W25Q32FVSIG

    https://www.aliexpress.com/item/10pc...ceBeautifyAB=0

    https://diychristmas.org/vb1/showthr...ll=1#post99568
    In Lights Therapy

  5. Likes Keith R liked this post
  6. #5
    Join Date
    Oct 2011
    Location
    Chesapeake, VA
    Posts
    735
    Post Thanks / Like

    Default Re: Cheap ESP-01 Modules that don't work for an ESPixelStick

    I think the bad chips are puma? I found you can flash the chips and they will work as long as you dont make or save changes in the web gui. Could be wrong though.
    [SIZE=3][B]8000 + E1.31 Channels (5x E68x controllers)
    128 Renard Channels[/SIZE][/B]
    sequencing with LightShow Pro 2.8 and/or Vixen 3 (using xLights scheduler)
    2 x Pixel Mega Trees, RGB Pixel Roofline, 2 x RGB Pixel Spinners, 11 x Pixel Bushes, 6 x GECE Icicle Arches, 16 x RGB Mini Trees, 2 x Vertical Pixel Poles,
    12 x 10w RGB Floods, 160 Strobes controlled by Arduino
    [URL="http://www.controlthelights.net"]http://www.controlthelights.net[/URL]

  7. #6
    Join Date
    Jan 2016
    Location
    Lizella, GA
    Posts
    1,167
    Post Thanks / Like

    Default Re: Cheap ESP-01 Modules that don't work for an ESPixelStick

    Matt

  8. Likes mikel3332 liked this post
  9. #7
    Join Date
    Dec 2011
    Posts
    70
    Post Thanks / Like

    Default Re: Cheap ESP-01 Modules that don't work for an ESPixelStick

    Quote Originally Posted by jaywalk101 View Post
    I think the bad chips are puma? I found you can flash the chips and they will work as long as you dont make or save changes in the web gui. Could be wrong though.
    Manufacturer of memory chip with the problem is Puya. I was able to fix mine by replacing the memory chip.

  10. #8
    Join Date
    Feb 2009
    Location
    Plymouth, MN
    Posts
    8,991
    Post Thanks / Like

    Default Re: Cheap ESP-01 Modules that don't work for an ESPixelStick

    Yes, either replace the Puya chip or hang onto them -- once the Arduino core is universally updated to use the Puya chip and current ESP firmware gets recompiled with the new core, they may work -- so don't toss them out!

    http://digwdf.com/store/
    The DIGWDF Store will be closing at the end of this year.
    While it's still open, please check us out for blinky-flashy gizmos that nobody else on the planet makes!

  11. Thanks Airwolf16 thanked for this post
  12. #9
    Join Date
    Jan 2014
    Posts
    23
    Post Thanks / Like

    Default Re: Cheap ESP-01 Modules that don't work for an ESPixelStick

    Thank you all for the info.

    Dirknerkle, as I'm digging out crap from last year, I found a couple of RenardESP kits I bought from you. I dorked with them for way too long. I could get them to work and then nothing, re-flash, repeat, same result. What I noticed a few minutes ago, I have some ESP01's with the Puya chip. Well CRAP! At least I understand the issue now. And hopefully this thread will help others.

  13. #10
    Join Date
    Dec 2011
    Posts
    5,564
    Post Thanks / Like

    Default Re: Cheap ESP-01 Modules that don't work for an ESPixelStick

    Quote Originally Posted by ucfknight98 View Post
    Thank you all for the info.

    Dirknerkle, as I'm digging out crap from last year, I found a couple of RenardESP kits I bought from you. I dorked with them for way too long. I could get them to work and then nothing, re-flash, repeat, same result. What I noticed a few minutes ago, I have some ESP01's with the Puya chip. Well CRAP! At least I understand the issue now. And hopefully this thread will help others.
    The Puya do work with ver 1.4 of the firmware

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •