Results 1 to 1 of 1

Thread: PX1 doing some interesting things

  1. #1
    Join Date
    Dec 2014
    Post Thanks / Like

    Default PX1 doing some interesting things

    I have a PX1 connected to the DO of a renzilla (using jumpers for DO to pin 2 and ground to ground of the SN65LBC179PE4 chip that is removed), the PIC16F1825 is flashed with start channel 1 and 115200 baud with 50 pixels. The first 26 pixels function correctly, but then it gets interesting, there seems to be a gap in the channel map of the 1825 chip as there is a gap then the next 16 function (correctly for that group) then another gap and the rest of the pixels operate as 1 group. I have reflashed the pic, tried another pic along with the ESP that is connected to the input side of the renzilla. I am attaching a link to a video of the test chase from the ESP and also with the same pixels connected to a ESPixel stick functioning correctly. On one more note, when using the test function of xlights the last 24 pixels flicker when the output to lights is checked. Also the pixels are ws2811 in 12 volt.

    Anybody have any idea what I might have done wrong or why the PX1 is behaving like this?

    Problem found
    The data was being corrupted somewhere on board the renzilla, after changing the start address of the PX1 and using the same data stream that is feeding the renzilla it is working correctly.
    Last edited by cmyers; 06-17-2018 at 05:54 PM. Reason: problem solved


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts