Results 1 to 8 of 8

Thread: Serial port closing after first sequence.

  1. #1
    Join Date
    Dec 2016
    Location
    Calgary, Canada
    Posts
    15
    Post Thanks / Like

    Default Serial port closing after first sequence.

    Am i doing something wrong? Anyways i set up the schedule and the program. But when the timers start at 5pm the first sequence plays without issue but as soon as the second sequence comes it brings up an error stating "COM1 is unavailable. Access is denied" or something. Any help would be appreciated.

    Sent from my LG-H873 using Tapatalk

  2. #2
    Join Date
    Dec 2014
    Location
    Southern California
    Posts
    807
    Post Thanks / Like

    Default Re: Serial port closing after first sequence.

    Are you using Arduino? Arduino IDE is closed?
    Kevin

    2017 - Pi3 w/FPP controlling 8 ESPixelsticks driving 1250pixels and 3 Arduino MEGAS communicating with ESP-01s driving 96 channels
    2016 - 184 channels of Blinking/Flashing using 4 Arduino MEGAs and cheap home-made props.

  3. #3
    Join Date
    Dec 2007
    Location
    Colorado Springs
    Posts
    3,696
    Post Thanks / Like

    Default Re: Serial port closing after first sequence.

    You might check that the last column of your sequence has every cell 'Off'. If any of them are filled in it an cause Vixen to hold a Com Port open and not allow the next sequence to play.

  4. #4
    Join Date
    Dec 2016
    Location
    Calgary, Canada
    Posts
    15
    Post Thanks / Like

    Default Re: Serial port closing after first sequence.

    Just checked all of my sequences and none of them have the last column off.

  5. #5
    Join Date
    Dec 2016
    Location
    Calgary, Canada
    Posts
    15
    Post Thanks / Like

    Default Re: Serial port closing after first sequence.

    Quote Originally Posted by rstehle View Post
    You might check that the last column of your sequence has every cell 'Off'. If any of them are filled in it an cause Vixen to hold a Com Port open and not allow the next sequence to play.
    Just Checked all my sequences and the end appears empty.

  6. #6
    Join Date
    Feb 2008
    Location
    Warminster, PA
    Posts
    1,707
    Post Thanks / Like

    Default Re: Serial port closing after first sequence.

    Make sure in your program you have the crossfade set to 0 seconds. Anything else will cause an issue.
    Chris
    [URL="http://www.maloneylights.com"]http://www.maloneylights.com[/URL]
    [URL="http://halloween.maloneylights.com"]http://halloween.maloneylights.com[/URL]
    [URL="http://ctm.maloneylights.com"]http://ctm.maloneylights.com[/URL]

  7. #7
    Join Date
    Dec 2016
    Location
    Calgary, Canada
    Posts
    15
    Post Thanks / Like

    Default Re: Serial port closing after first sequence.

    Quote Originally Posted by ctmal View Post
    Make sure in your program you have the crossfade set to 0 seconds. Anything else will cause an issue.
    Ah, thats it i thought the crossfade would be interesting at one point i thought that might be it. I will change it to 0 seconds.

    Sent from my LG-H873 using Tapatalk

  8. #8
    Join Date
    Dec 2016
    Location
    Calgary, Canada
    Posts
    15
    Post Thanks / Like

    Default Re: Serial port closing after first sequence.

    Fixed! Thanks everyone for your help!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •