Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 44

Thread: Pickit 3 - Target Device Issue

  1. #31
    Join Date
    Dec 2011
    Location
    Gaithersburg, MD
    Posts
    241
    Post Thanks / Like

    Default Re: Pickit 3 - Target Device Issue

    Ok - so I now have created my own Pickit 3 to PIC16F688 connection, I have set all of the correct setting (PIC selection/Family/voltage which is 4.87)) and I can read the PIC. When I select and load the hex and click program, I get the error:
    The following areas will be programmed:
    Program memory start address = 0x0, end address = 0xf3
    Configure memory
    Address 1 expected Value: 2846 Received: 0
    Failed to program device
    2017-04-30 12:04:53 - Programming Failed
    Pass Count: 0

    Attached is the HEX file.

    Thanks all - I feel I am one step away!
    Attached Files Attached Files
    2016 Migrating to Vixen 3.2
    Vixen 2.5x
    120 Channels
    2015 5 RenardSS24 @ 20,600 lights
    2014 5 RenardSS24 @ 18,600 lights
    2013 3 RenardSS24 @ 9,900 lights
    2012 2 RenardSS24 @ 6,000 lights
    2011 began researching
    [url]www.KentlandsChristmas.com[/url]

  2. #32
    Join Date
    Dec 2012
    Location
    Newtown CT
    Posts
    4,847
    Post Thanks / Like

    Default Re: Pickit 3 - Target Device Issue

    Try a slightly lower voltage. As I said, I had to go down to 4.5v before mine would program.
    Last edited by MartinMueller2003; 05-01-2017 at 05:21 AM.


    2020 Full sized show reworked for the new location. Only adding (famous last words) 13 RBLs that I finally got converted to using pixels
    2019 - Just moved into a new home (yet another change of plans). Will be dim but not dark. Too much to do at the new place to leave time for a show. Dim show (3000 pixels) had regular visits most nights.
    https://www.youtube.com/channel/UCyX...ttrsZNARkUce0Q

  3. #33
    Join Date
    Nov 2013
    Posts
    89
    Post Thanks / Like

    Default Re: Pickit 3 - Target Device Issue

    You also said you managed to "heat" the chip IIRC. You may want to try a new one.

  4. #34
    Join Date
    Dec 2011
    Location
    Gaithersburg, MD
    Posts
    241
    Post Thanks / Like

    Default Re: Pickit 3 - Target Device Issue

    Quote Originally Posted by davros View Post
    You also said you managed to "heat" the chip IIRC. You may want to try a new one.
    I tried a diff PIC and dropped the V to 4.5. Same error.
    2016 Migrating to Vixen 3.2
    Vixen 2.5x
    120 Channels
    2015 5 RenardSS24 @ 20,600 lights
    2014 5 RenardSS24 @ 18,600 lights
    2013 3 RenardSS24 @ 9,900 lights
    2012 2 RenardSS24 @ 6,000 lights
    2011 began researching
    [url]www.KentlandsChristmas.com[/url]

  5. #35
    Join Date
    Dec 2011
    Location
    Gaithersburg, MD
    Posts
    241
    Post Thanks / Like

    Default Re: Pickit 3 - Target Device Issue

    In addition, I can read the PIC, Verify and erase the PIC. could the hex be incorrect?
    2016 Migrating to Vixen 3.2
    Vixen 2.5x
    120 Channels
    2015 5 RenardSS24 @ 20,600 lights
    2014 5 RenardSS24 @ 18,600 lights
    2013 3 RenardSS24 @ 9,900 lights
    2012 2 RenardSS24 @ 6,000 lights
    2011 began researching
    [url]www.KentlandsChristmas.com[/url]

  6. #36
    Join Date
    Dec 2012
    Location
    Newtown CT
    Posts
    4,847
    Post Thanks / Like

    Default Re: Pickit 3 - Target Device Issue

    If you can read the PIC then the connections are good. I would suspect the hex file.


    2020 Full sized show reworked for the new location. Only adding (famous last words) 13 RBLs that I finally got converted to using pixels
    2019 - Just moved into a new home (yet another change of plans). Will be dim but not dark. Too much to do at the new place to leave time for a show. Dim show (3000 pixels) had regular visits most nights.
    https://www.youtube.com/channel/UCyX...ttrsZNARkUce0Q

  7. #37
    Join Date
    Dec 2011
    Location
    Gaithersburg, MD
    Posts
    241
    Post Thanks / Like

    Default Re: Pickit 3 - Target Device Issue

    Quote Originally Posted by MartinMueller2003 View Post
    If you can read the PIC then the connections are good. I would suspect the hex file.
    D/l another and same results. I have the SAM file and I created a HEx and I d/l a hex from the site and still same error.

    In the MPLAB IPE app, aside from voltage 4.5 and the family and device settings. Are there any other settings that I must change from the default?

    Funny thing: I perform an erase and it states erase device complete, the I to a blank check and it states device is NOT blank!
    2016 Migrating to Vixen 3.2
    Vixen 2.5x
    120 Channels
    2015 5 RenardSS24 @ 20,600 lights
    2014 5 RenardSS24 @ 18,600 lights
    2013 3 RenardSS24 @ 9,900 lights
    2012 2 RenardSS24 @ 6,000 lights
    2011 began researching
    [url]www.KentlandsChristmas.com[/url]

  8. #38
    Join Date
    Jan 2015
    Location
    Folsom, CA, USA
    Posts
    2,256
    Post Thanks / Like

    Default Re: Pickit 3 - Target Device Issue

    Are you still using AUTO Import Hex & Write....For me, I do a File/Import Hex.....
    If I get a full import then I can generally write it.
    In Lights Therapy

  9. #39
    Join Date
    Nov 2013
    Posts
    89
    Post Thanks / Like

    Default Re: Pickit 3 - Target Device Issue

    When I program I use the IPE- there is a setting to slow down the programming and (this one is likely a red herring) another to choose what gets programmed -memory eeprom etc.
    Have you tried to slow down the processes if possible? A reasonably short USB cable?

  10. #40
    Join Date
    Dec 2011
    Location
    Gaithersburg, MD
    Posts
    241
    Post Thanks / Like

    Default Re: Pickit 3 - Target Device Issue

    Quote Originally Posted by davros View Post
    When I program I use the IPE- there is a setting to slow down the programming and (this one is likely a red herring) another to choose what gets programmed -memory eeprom etc.
    Have you tried to slow down the processes if possible? A reasonably short USB cable?
    So, I have slowed down the programming, along w/ all other items. I thought I would share this. I performed a blank check on this PIC (which claimed it was not blank) then I exported the data. Below is a snippet of what was in the file.
    :020000040000FA
    :1000000000000000000000000000000000000000F0
    :1000100000000000000000000000000000000000E0
    :1000200000000000000000000000000000000000D0
    (continued until)
    :1043E00000000000000000000000000000000000CD
    :1043F00000000000000000000000000000000000BD
    :084000000000000000000000B8
    :00000001FF


    I then went to File, Import and selected the HEX file, this is what the log provided:

    ************************************************** ***

    Connecting to MPLAB PICkit 3...

    Currently loaded firmware on PICkit 3
    Firmware Suite Version.....01.48.17
    Firmware type..............Midrange

    Programmer to target power is enabled - VDD = 4.500000 volts.
    Target Device ID (0x0) is an Invalid Device ID. Please check your connections to the Target Device.
    2017-05-02 09:48:31 -0400 - Reading...

    Reading...

    The following memory area(s) will be read:
    program memory: start address = 0x0, end address = 0xfff
    configuration memory
    EEData memory
    User Id Memory
    Read complete
    2017-05-02 09:48:37 -0400 - Read complete

    2017-05-02 09:52:40 -0400 - Blank checking...

    Blank Checking...
    program memory
    Address: 0 Expected Value: 3fff Received Value: 0
    Blank check complete, device is not blank.
    2017-05-02 09:52:43 -0400 - Blank check failed

    Exporting hex file...
    2017-05-02 09:52:57 -0400 - Hex File successfully created at C:/Users/Mikel/Desktop/PIC16F688.hex
    2017-05-02 09:58:11 -0400 - Loading hex file. Please wait...
    Loading code from C:\Users\Mikel\Downloads\Renard_SS_Operational_Fir mware (1).HEX...
    2017-05-02 09:58:11 -0400 - Hex file loaded successfully.

    2017-05-02 09:58:54 -0400 - Programming...

    Device Erased...

    Programming...

    The following memory area(s) will be programmed:
    program memory: start address = 0x0, end address = 0xf3
    configuration memory
    program memory
    Address: 1 Expected Value: 2846 Received Value: 0
    Failed to program device
    2017-05-02 09:58:57 -0400 - Programming failed
    Pass Count: 2
    2016 Migrating to Vixen 3.2
    Vixen 2.5x
    120 Channels
    2015 5 RenardSS24 @ 20,600 lights
    2014 5 RenardSS24 @ 18,600 lights
    2013 3 RenardSS24 @ 9,900 lights
    2012 2 RenardSS24 @ 6,000 lights
    2011 began researching
    [url]www.KentlandsChristmas.com[/url]

Page 4 of 5 FirstFirst ... 2345 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •