Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 44

Thread: Pickit 3 - Target Device Issue

  1. #11
    Join Date
    Jan 2015
    Location
    Folsom, CA, USA
    Posts
    1,956
    Post Thanks / Like

    Default Re: Pickit 3 - Target Device Issue

    Quote Originally Posted by MartinMueller2003 View Post
    hmm. To me it looked like three empty pins on the non-3m end and then the chip starting in the fourth pin on the non-3m end. The notch on the chip should be on the 3m end of the socket.
    Confirms my previous post.

    Quote Originally Posted by MartinMueller2003 View Post


    After that you need to set the jumpers for a 14 pin chip. Then you need a total of 7 jumpers.

    J1 position 2
    J2 and J3 and J4 and J5 and J6 and J7 all need jumpers between positions 2&3
    Jumpers could be interpreted both ways. Get the DIP14 placed properly, then try....if it doesn't work, try again with Martin view of jumpers.
    Last edited by mrGrumpy; 04-26-2017 at 01:09 PM.
    In Lights Therapy

  2. #12
    Join Date
    Dec 2011
    Location
    Gaithersburg, MD
    Posts
    219
    Post Thanks / Like

    Default Re: Pickit 3 - Target Device Issue

    Thank you all - still hunting this down.

    So now, I have installed Pickit 3 programmer and flashed the OS. Now the application dives me an ID for the clone Pickit. I followed Martin's suggestion (J1 position 2 and J2 and J3 and J4 and J5 and J6 and J7 all need jumpers between positions 2&3) I then ran down all of the available slots on the adapter and asking the application to read the PIC. On two slots (see pictures) I was able to get a device found: Unsupported Part (ID=3FE0). inserted at 7th or the 9th slot down from 3M. Now I am not certain what to make of this intel.
    Attached Images Attached Images
    2016 Migrating to Vixen 3.2
    Vixen 2.5x
    120 Channels
    2015 5 RenardSS24 @ 20,600 lights
    2014 5 RenardSS24 @ 18,600 lights
    2013 3 RenardSS24 @ 9,900 lights
    2012 2 RenardSS24 @ 6,000 lights
    2011 began researching
    [url]www.KentlandsChristmas.com[/url]

  3. #13
    Join Date
    Jan 2015
    Location
    Folsom, CA, USA
    Posts
    1,956
    Post Thanks / Like

    Default Re: Pickit 3 - Target Device Issue

    Quote Originally Posted by MikelMD View Post
    Thank you all - still hunting this down.

    So now, I have installed Pickit 3 programmer and flashed the OS. Now the application dives me an ID for the clone Pickit. I followed Martin's suggestion (J1 position 2 and J2 and J3 and J4 and J5 and J6 and J7 all need jumpers between positions 2&3) I then ran down all of the available slots on the adapter and asking the application to read the PIC. On two slots (see pictures) I was able to get a device found: Unsupported Part (ID=3FE0). inserted at 7th or the 9th slot down from 3M. Now I am not certain what to make of this intel.
    Getting a better view/aligning the front marker to the pin....maybe you need 4 pins from the bottom. This is also what mine would say.
    IC "Pin 1" is placed "on the row" with the "arrow." Not above nor below.

    From the picture view, the arrow is on the 10th hole from the 3M side. IC goes into slots 10, 11, 12, 13, 14, 15 & 16. 9 holes nearest to 3M are open and the 4 holes opposite end are open.
    Last edited by mrGrumpy; 04-26-2017 at 01:46 PM.
    In Lights Therapy

  4. #14
    Join Date
    Nov 2013
    Posts
    88
    Post Thanks / Like

    Default Re: Pickit 3 - Target Device Issue

    You should be able to confirm continuity with a voltmeter from the KIT3 pins ( VPP 5v, GND PGC/clk, PGD/dat) to the socket's pins via the PIC's pinout diagram.

  5. #15
    Join Date
    Dec 2011
    Location
    Gaithersburg, MD
    Posts
    219
    Post Thanks / Like

    Default Re: Pickit 3 - Target Device Issue

    Quote Originally Posted by mrGrumpy View Post
    Getting a better view/aligning the front marker to the pin....maybe you need 4 pins from the bottom. This is also what mine would say.
    IC "Pin 1" is placed "on the row" with the "arrow." Not above nor below.

    From the picture view, the arrow is on the 10th hole from the 3M side. IC goes into slots 10, 11, 12, 13, 14, 15 & 16. 9 holes nearest to 3M are open and the 4 holes opposite end are open.

    OK, so now I am in the correct slots I am on the 10th slot w/ Pin 1 On the Pickit3 Programmer app, when I click Read = No device detected. But the Device stated: Unsupported Part (ID=3FE0). Previous pix.
    2016 Migrating to Vixen 3.2
    Vixen 2.5x
    120 Channels
    2015 5 RenardSS24 @ 20,600 lights
    2014 5 RenardSS24 @ 18,600 lights
    2013 3 RenardSS24 @ 9,900 lights
    2012 2 RenardSS24 @ 6,000 lights
    2011 began researching
    [url]www.KentlandsChristmas.com[/url]

  6. #16
    Join Date
    Jan 2015
    Location
    Folsom, CA, USA
    Posts
    1,956
    Post Thanks / Like

    Default Re: Pickit 3 - Target Device Issue

    Quote Originally Posted by MikelMD View Post
    OK, so now I am in the correct slots I am on the 10th slot w/ Pin 1 On the Pickit3 Programmer app, when I click Read = No device detected. But the Device stated: Unsupported Part (ID=3FE0). Previous pix.

    OK now tell me the PIC number. ie; if it is a PIC18F you need to set the DEVICE FAMILY to PIC18F
    Keeping IC pin 1 on row 10. That is right according to your arrow markings.

    Also, disconnect your PICkit3 from USB and close PICkit3 - now reconnect and restart PICkit3

    Before selecting DEVICE FAMILY
    Capture111.JPG Capture111.JPG

    After reset and selecting DEVICE FAMILY and clicking READ

    Capture11112.JPG Capture11112.JPG
    Last edited by mrGrumpy; 04-26-2017 at 09:06 PM.
    In Lights Therapy

  7. #17
    Join Date
    Dec 2011
    Location
    Gaithersburg, MD
    Posts
    219
    Post Thanks / Like

    Default Re: Pickit 3 - Target Device Issue

    Quote Originally Posted by mrGrumpy View Post
    Confirms my previous post.



    Jumpers could be interpreted both ways. Get the DIP14 placed properly, then try....if it doesn't work, try again with Martin view of jumpers.

    So, I went back to the MPLAB IDE and when I attach the controller in either direction for the jumpers (to interpret 1-2-3 or 3-2-1) the error is the same: The overcurrent has detected a fault on either VPP or VDD....
    2016 Migrating to Vixen 3.2
    Vixen 2.5x
    120 Channels
    2015 5 RenardSS24 @ 20,600 lights
    2014 5 RenardSS24 @ 18,600 lights
    2013 3 RenardSS24 @ 9,900 lights
    2012 2 RenardSS24 @ 6,000 lights
    2011 began researching
    [url]www.KentlandsChristmas.com[/url]

  8. #18
    Join Date
    Jan 2015
    Location
    Folsom, CA, USA
    Posts
    1,956
    Post Thanks / Like

    Default Re: Pickit 3 - Target Device Issue

    Quote Originally Posted by MikelMD View Post
    So, I went back to the MPLAB IDE and when I attach the controller in either direction for the jumpers (to interpret 1-2-3 or 3-2-1) the error is the same: The overcurrent has detected a fault on either VPP or VDD....
    Martin's pins meant whether J2-J6 had jumpers on points 2-3. Pin placement in your picture of Post #12 look correct. Redo those and let's stare there.

    OK let's back-up.

    Looking at your socket....What hole does this IMG_0555m.jpg point. Is it hole 10, 11 0r ??? This must be correct or nothing works. In hand, your view/angle is best.
    What is your PIC Series PIC18F would be a type.
    In Lights Therapy

  9. #19
    Join Date
    Dec 2011
    Location
    Gaithersburg, MD
    Posts
    219
    Post Thanks / Like

    Default Re: Pickit 3 - Target Device Issue

    So, here is where I am:
    The app is Pickit 3 Programmer v3.10
    The Pickit 3 is a clone.
    The PICs are the PIC16F688.

    On the PIC adapter bought off of ebay.
    Jumpern Settings:
    J1 on 2
    J2-J7 are all on 2-3 (I have tried then in the reverse (1-2) and I did not get any connectivity)).
    The PIC is inserted in slot 10 that leaves 4 slots open in the back.

    In the App, when I check Communication I do connect to my Pickit.
    I select the Device Family, PIC18F, the error is Unsupported Part (ID-FFF0)
    IF I use the Device Family, Midrange 1.8v, the error is Unsupported Part (ID-3FE0)
    Attached Images Attached Images
    2016 Migrating to Vixen 3.2
    Vixen 2.5x
    120 Channels
    2015 5 RenardSS24 @ 20,600 lights
    2014 5 RenardSS24 @ 18,600 lights
    2013 3 RenardSS24 @ 9,900 lights
    2012 2 RenardSS24 @ 6,000 lights
    2011 began researching
    [url]www.KentlandsChristmas.com[/url]

  10. #20
    Join Date
    Dec 2011
    Location
    Gaithersburg, MD
    Posts
    219
    Post Thanks / Like

    Default Re: Pickit 3 - Target Device Issue

    So, I decided to play with the Device Family and selected Base Configuration and selected the PIC16F59 and it read the PIC.
    So, I launch MPASMWIN, locate the asm file and generate a hex file.
    I go back to the PICKit2 App and click on auto import.
    Its starts to read and write and then I get an error: Programming failed at Program Memory address 0x000000.
    And under Configuration: 0000, it read in red: Code Protect
    Last edited by MikelMD; 04-27-2017 at 08:36 AM.
    2016 Migrating to Vixen 3.2
    Vixen 2.5x
    120 Channels
    2015 5 RenardSS24 @ 20,600 lights
    2014 5 RenardSS24 @ 18,600 lights
    2013 3 RenardSS24 @ 9,900 lights
    2012 2 RenardSS24 @ 6,000 lights
    2011 began researching
    [url]www.KentlandsChristmas.com[/url]

Page 2 of 5 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •