Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: mega 2560 & solid state relay

  1. #1
    Join Date
    Nov 2016
    Location
    South Carolina
    Posts
    91
    Post Thanks / Like

    Default mega 2560 & solid state relay

    looking for a little advice I used the videos here https://www.youtube.com/channel/UCWu...I2n5eCg/videos to put together my controller the problem that I'm having Is If I use the 5 volt 2 amp dc transformer on the relay boards I get nothing But if I hook the solid state relay boards to a ground pin and the 5 volt on the mega It works PERFECT.. thanks in advance

  2. #2
    Join Date
    Nov 2009
    Location
    Morrisburg, On, Canada
    Posts
    2,540
    Post Thanks / Like

    Default Re: mega 2560 & solid state relay

    When you use the 5V @2A power supply on the relay board you still need a ground wire from the Arduino board to the ground of the 5V dc transformer circuit. Voltages are "potential differences". you can't have a monopole 5V supply.

  3. #3
    Join Date
    Nov 2016
    Location
    South Carolina
    Posts
    91
    Post Thanks / Like

    Default Re: mega 2560 & solid state relay

    so where the ground and the vcc is I need to run a ground from the Arduino to that ground ? and one more question the ground on the channel side of the relay board does it need a ground from the Arduino as well

  4. #4
    Join Date
    Nov 2009
    Location
    Morrisburg, On, Canada
    Posts
    2,540
    Post Thanks / Like

    Default Re: mega 2560 & solid state relay

    Yes.
    I'm assuming that your Arduino DC power comes from the USB port. Your relay board has a separate 5V DC transformer or power adapter. The ground from the power adapter needs to go to an Arduino ground.
    Last edited by LightUp; 12-30-2016 at 08:04 PM. Reason: incomplete diagram

  5. Thanks perfection322008 thanked for this post
  6. #5
    Join Date
    Nov 2016
    Location
    South Carolina
    Posts
    91
    Post Thanks / Like

    Default Re: mega 2560 & solid state relay

    Yes I'm using USB port to power the Arduino

  7. #6
    Join Date
    Nov 2016
    Location
    South Carolina
    Posts
    91
    Post Thanks / Like

    Default Re: mega 2560 & solid state relay

    Attachment 35340 this is the adapter that i'm try to power the relay board with
    Last edited by perfection322008; 12-30-2016 at 08:53 PM.

  8. #7
    Join Date
    Nov 2009
    Location
    Morrisburg, On, Canada
    Posts
    2,540
    Post Thanks / Like

    Default Re: mega 2560 & solid state relay

    Don't know why but I can't open your attachment.

  9. #8
    Join Date
    Nov 2016
    Location
    South Carolina
    Posts
    91
    Post Thanks / Like

    Default Re: mega 2560 & solid state relay

    Thanks for taking time to try and help me I am very grateful for It. The bright side of It Is I got 11 months to try and get it figured out . jpg.jpg

  10. #9
    Join Date
    Nov 2009
    Location
    Morrisburg, On, Canada
    Posts
    2,540
    Post Thanks / Like

    Default Re: mega 2560 & solid state relay

    There are so many success stories here that we want others to succeed as well.
    We also know that most problems can be resolved. We just need to look at it piece by piece.

  11. #10
    Join Date
    Nov 2016
    Location
    South Carolina
    Posts
    91
    Post Thanks / Like

    Default Re: mega 2560 & solid state relay

    one last question could you recommend me a power adapter that I could get to try for me relay board

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •