Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Olsen 595 Output Problems

  1. #1
    Join Date
    Sep 2007
    Location
    Valley Center, Ks
    Posts
    418
    Post Thanks / Like

    Default Olsen 595 Output Problems

    Another problem cropped up today. I had a bad cat5 connector so I fixed that. Now I can't get 2 of the channels on that output to work. Here is my setup:
    2 Olsen 595's running from parallel port
    Powered by a AT computer power supply
    Using Brian's SSR's

    The LED for the channels turns on but nothing out the "O" port for output 2 & 3. 1 & 4 work fine. I tested this using Dirknerkle's SSR/CAT-X tester. The LED's turn on the 595 board but not on the tester board. I swapped the 2803 & 595 one at a time from another working board and that didn't fix it. I looked for a schematic to see what actually drives the outputs. I am guessing it is the 2803 chip does that. Actually I swapped the 2803 first then I swapped the 595 with the 2803 still swapped.

    Are there any troubleshooting steps that help with this online someplace?

    Thanks
    Dave-1200Px-20KLts

  2. #2
    Join Date
    Dec 2007
    Location
    Long Neck, Delaware
    Posts
    360
    Post Thanks / Like

    Default Re: Olsen 595 Output Problems

    Dave, check back at you're other post, I left you a PDF file with schematic for the Grinch board, same as the 595 but without the led's.

    http://doityourselfchristmas.com/for...en-595-Problem
    Gary
    Last edited by JP90; 11-27-2016 at 09:38 AM.

  3. #3
    Join Date
    Jan 2013
    Location
    Northern Illinois
    Posts
    296
    Post Thanks / Like

    Default Re: Olsen 595 Output Problems

    If you are using that schematic to help troubleshoot keep in mind that the Grinch board doesn't have the ULN2803 chips.

  4. #4
    Join Date
    Sep 2007
    Location
    Valley Center, Ks
    Posts
    418
    Post Thanks / Like

    Default Re: Olsen 595 Output Problems

    I looked at the grinch schematic and realized it is different so can't really use it.


    Sent from my iPhone using Tapatalk
    Dave-1200Px-20KLts

  5. #5
    Join Date
    Jan 2013
    Location
    Northern Illinois
    Posts
    296
    Post Thanks / Like

    Default Re: Olsen 595 Output Problems

    Here's a link to the thread that has the schematic in case you need it. Keep in mind there's more than one version. Not all versions had the channel LEDs on them.

    Maybe this will help you out.


    http://doityourselfchristmas.com/for...=595+schematic

  6. #6
    Join Date
    Sep 2007
    Location
    Valley Center, Ks
    Posts
    418
    Post Thanks / Like

    Default Olsen 595 Output Problems

    Haven't tried anything yet but looking at that schematic I don't understand how the LED's come on but the output doesn't according to the tester. The 2803 provides a ground right with the resistor pack pulling up to 5 volts.


    Sent from my iPhone using Tapatalk
    Dave-1200Px-20KLts

  7. #7
    Join Date
    Sep 2007
    Location
    Iowa
    Posts
    457
    Post Thanks / Like

    Default Re: Olsen 595 Output Problems

    Yeah, there's not much left..

    I couldn't find a picture that shows the traces on the bottom side of the board.. but I would do a continuity check on the 4 traces that go from the LEDs to the jack.

    possibly a bad trace, pad, jack or cat 5 cable.

    -Craig

  8. #8
    Join Date
    Jan 2013
    Location
    Northern Illinois
    Posts
    296
    Post Thanks / Like

    Default Re: Olsen 595 Output Problems

    Here's a picture of the traces for a 595 board. Maybe it will help with your trouble shooting.

    595 Traces.pdf

  9. #9
    Join Date
    May 2007
    Location
    Waterboro Maine
    Posts
    1,020
    Post Thanks / Like

    Default Re: Olsen 595 Output Problems

    You are correct the 2803 drives the ssrs

    think your problem may still be in the cat5 conector but i dont know much lol

    if my old memory is working the leds onboard run off the 595"s
    Last edited by Ronp; 12-01-2016 at 08:10 PM.

  10. #10
    Join Date
    May 2007
    Location
    Waterboro Maine
    Posts
    1,020
    Post Thanks / Like

    Default Re: Olsen 595 Output Problems

    Nope 595 feeds 2803 then leds then rj45 so if leds work whats next lol

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •