Results 1 to 7 of 7

Thread: Ghosting on Background/Foreground Channels

  1. #1
    Join Date
    Nov 2011
    Location
    Austin, TX
    Posts
    47
    Post Thanks / Like

    Question Ghosting on Background/Foreground Channels

    I'm working on some background channels at the moment and there's an odd "ghosting" effect happening when I preview. (I do have "Always Build" checked, but this happens anyway.)

    The problem is intermittent, but when it does occur, I'll run the preview, but the changes I've made to the background channels revert to the pre-change settings. The cells even show the old settings when I'm in preview mode. When I uncheck the Display Preview box, the cells revert to their current settings.

    Here's an example that just exhibited the problem. All these entries and changes were in "view background alone".

    I had three channels on WHITE for one second, off for one second, and then back on for one second:
    BugScreen1.jpg

    I deleted the second set of WHITE cells and put GREEN cells in their place, but about a half second earlier than the WHITES had been. So now they were ON for one second, off for a half second, and then on (but green) for one second:
    BugScreen2.jpg

    When I went into preview I noticed the white cells that I'd deleted were back, but with the green cells still in place. So in effect it was WHITE on for 1 second, off for a half second, GREEN on for a half second, and then WHITE on for a half second:
    BugScreen3.jpg

    When I pressed play, the preview screen showed WHITE/OFF/GREEN/WHITE on the screen.

    When I left preview, the screen reverted to the correct (2nd image above) version. A subsequent preview acted the way it was supposed to (WHITE/OFF/GREEN).

    I've found that rotating the views through Foreground Only/Both Foreground AND Background Merged/Background Only prevents the problem and causes the preview to display correctly.

    Hopefully this makes sense, but if not, come back at me with questions and I'll try to be more clear.

  2. #2
    Join Date
    Dec 2011
    Location
    Key West, FL
    Posts
    3,630
    Post Thanks / Like

    Default Re: Ghosting on Background/Foreground Channels

    HLS needs to rebuild the lighting to show properly.

    Sounds like you "Always build" set but have added effects since the last play.

    Uncheck your "Always Play" -- it should ask to rebuild -- do so and you should be fine.

    Also -- uncheck Preview and then recheck.

    Your process is doing something that is having HLS not rebuild the lighting.

    Joe
    Link to my DownLoad Site: [B][COLOR=#ff0000][URL]http://www.joehinkle.com/HLS[/URL]

    [/COLOR][/B][IMG]http://joehinkle.com/HLS/HLS%20Logo%20Small.jpg[/IMG]

  3. #3
    Join Date
    Nov 2011
    Location
    Austin, TX
    Posts
    47
    Post Thanks / Like

    Default Re: Ghosting on Background/Foreground Channels

    Apparently I'm not following you properly.

    - I did have "Always" build set.
    - I'm not finding "Always Play" so I assume you mean uncheck "Always Build".

    So here's my normal process and here's what I did to follow your solution:
    What I usually do.
    1) Edit cells
    2) "Always Build" and "Apply Lighting Controls" is checked
    3) To preview, I check the "Display Preview" box.
    4) After the image comes up, I click "Play/Pause" or "Play From Mark" depending on my need.
    5) To go back to editing the cells, I uncheck "Display Preview" and then go back to step 1

    What I did to follow your solution
    1) Edit cells
    2) "Always Build" is NOT checked. "Apply Lighting Controls" is checked
    3) To preview, I check the "Display Preview" box.
    4) The Rebuild warning popup comes up. I check yes.
    5) After the image comes up, I click "Play/Pause" or "Play From Mark" depending on my need.
    6) To go back to editing the cells, I uncheck "Display Preview" and then go back to step 1

    I experienced the ghosting effect either way. When I ran up against it following your solution, I unchecked preview and the cell editing screen looked norm. When I checked the "Display Preview" box to go back into that mode, the ghosting came back. The only way I'm able to get rid of it is by rotating through the Background/Foreground/Both views.

    What am I missing?

  4. #4
    Join Date
    Dec 2011
    Location
    Key West, FL
    Posts
    3,630
    Post Thanks / Like

    Default Re: Ghosting on Background/Foreground Channels

    You are doing something with Background cells that I did not anticipate anyone doing.

    I know that without adding Background cells all is well so it has to do with you background editing.

    Monitor your Background work and identify when it occurs.

    Joe
    Link to my DownLoad Site: [B][COLOR=#ff0000][URL]http://www.joehinkle.com/HLS[/URL]

    [/COLOR][/B][IMG]http://joehinkle.com/HLS/HLS%20Logo%20Small.jpg[/IMG]

  5. #5
    Join Date
    Nov 2011
    Location
    Austin, TX
    Posts
    47
    Post Thanks / Like

    Default Re: Ghosting on Background/Foreground Channels

    I seem to have knack for doing things no one anticipates.

    It's very likely user error then due to laziness, ignorance, or both. I'd started working on background cells, but decided this section of the song wouldn't need any foreground/background effects. Rather than switching to the foreground view, I kept working in the background thinking it wouldn't make any difference. As it turns out, it does. Not sure exactly why, but when I moved everything from background to foreground, the problem disappeared.

    Thanks for the help.

  6. #6
    Join Date
    Dec 2011
    Location
    Key West, FL
    Posts
    3,630
    Post Thanks / Like

    Default Re: Ghosting on Background/Foreground Channels

    Solved it yourself!

    Congrats.

    Joe
    Link to my DownLoad Site: [B][COLOR=#ff0000][URL]http://www.joehinkle.com/HLS[/URL]

    [/COLOR][/B][IMG]http://joehinkle.com/HLS/HLS%20Logo%20Small.jpg[/IMG]

  7. #7
    Join Date
    Sep 2012
    Location
    Seattle, WA
    Posts
    622
    Post Thanks / Like

    Default Re: Ghosting on Background/Foreground Channels

    I was just coming here to submit this as a bug. I still consider it a not fixed bug because the problem still exists, Jeff just stopped using the background layer and moved his effects to the foreground layer.

    Because I'm working on a complex new song, I need a background layer...and whenever I move things around on the background layer and then go to preview the sequence the preview gets messed up. When HLS goes through it's calculations to "rebuild the lighting" the sequence to be previewed shows "ghosts"...it will show where the effect used to be and where it is now. Usually after a few edits and previews HLS will correct itself, but I'd prefer that it just work each time I preview. Like Jeff I have "Always Build" selected and I've been in the "View Background Alone" mode.

    -=Steve

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •