Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Renard SS24 - Flashed chips not working

  1. #1
    Join Date
    Jan 2015
    Location
    Burlington, NC
    Posts
    49
    Post Thanks / Like

    Default Renard SS24 - Flashed chips not working

    Hi! I think I may need a little help with my 2 Renard SS24 controllers I bought back in the first group buy. This is my first year doing Christmas lights, so I'm still learning all this stuff.

    After I assembled my SS24s, I read that most of the chips arrived un-programmed, so I went ahead & bought an ICP03 pic programmer & followed Wayne's videos to flash the chips. I had never done any chip programming before, but it "seemed" to be pretty straightforward as long as I followed the videos.

    I just recently got around to testing the Renards with an E1.31 bridge (DIYLED) & found that the 2 controllers "mostly" don't work. I say "mostly" because the first 8 channels work on the first controller, but the last 16 don't. However, there are 2 channels that stay ON: 9 and 17.

    None of the channels on the 2nd controller work, but it's really weird because the same exact 2 channels (9 & 17) also stay ON! In addition, channel #1 stays on.

    I flashed the chips a 2nd time but got the same results.

    I have a 3rd WORKING SS24 controller that I bought from a DIYC member. I put one of my chips in that controller (U7; the middle slot) to see if my chip was bad. I expected the middle 8 channels not to work but the last 16 didn't work. Weird! I thought each chip controlled 8 channels, so why would swapping the U7 chip cause the last 16 channels to stop working? Do the chips work together?

    So I'm wondering what I did wrong. I'm fairly sure that the 2 SS24 boards are OK, and I even reflowed many solder joints just to be sure, and checked for solder bridges, etc. Everything looks good. ...and the fact that a known good controller would NOT work with my chip indicates to me that my chips are bad.

    I'm going to attach a picture of the pic programmer that I used with the chip in the programmer. Could someone please tell me if I have the chip in the correct slots, and do I have the polarity correct (notched end facing the lever). Would I get an error if I had the chip flipped the wrong way, or in the wrong slots?

    Also, does anyone know the significance of channels 9 and 17 staying powered on, on both controllers? That's got to mean something.

    Any help would be greatly appreciated!
    20150725_210034.jpg
    [URL="http://www.facebook.com/MapleRidgeLights"]http://www.facebook.com/MapleRidgeLights[/URL]

    2014: 4 static incandescent strings & 2 inflatables
    2015: Over 9000 pixel channels & 72 Renard channels. 3 E682 controllers, 3 Renard SS24s and E1.31 bridge. House & windows covered in pixels! 4 HDPE arches, 11ft pixel tree & star, 12 LED mini-trees, 8 LED snowflakes, 2 4' LED Candy Canes, Chroma-cane and various LED strings in trees & yard. Xlights / FPP run the show!
    2016: My CLAP is telling me to go BIGGER!

  2. #2
    Join Date
    Aug 2011
    Location
    Zephyrhills, FL
    Posts
    129
    Post Thanks / Like

    Default Re: Renard SS24 - Flashed chips not working


  3. #3
    Join Date
    Oct 2008
    Location
    San Jose, CA
    Posts
    10,283
    Post Thanks / Like

    Default Re: Renard SS24 - Flashed chips not working

    Channels 9 and 17 (or really PIC#2 channel 1 and PIC#3 channel 1) is indicative of a blank PIC - you did program all 3 PICs correct? They should all have the same code on them.
    [COLOR=#000080][B][I]Brian[/I][/B][/COLOR]

    [COLOR=#ff0000]Christmas in San Jose! - [URL="http://www.christmasinsj.com"]WEB[/URL] - [URL="https://www.facebook.com/ChristmasInSanJose"]FB[/URL] - [URL="https://www.youtube.com/playlist?list=PL1W78s7liEQEE0ed7WSyLF7B6j3lBX43w"]VIDEOS[/URL]
    [/COLOR][COLOR=#800080]Halloween in San Jose! - [URL="https://www.facebook.com/pages/Halloween-in-San-Jose/356280784428581?ref=tn_tnmn"]FB[/URL]
    [SIZE=1]2015 Halloween Show - Planning now - hopefully some house projection...
    2015 Christmas Show - 5x E681-12, 1x 6804, Ren48LSD, 3x RenSS16, 1x Falcon16v2 (w/expander), 24x90 WS2811 pixel MT (James MT Strips), 12x DIYC Floods, SuperPixelStar, 3x Pixel Arches, PixaBulb House outline
    [/SIZE]
    [/COLOR][SIZE=3][COLOR=#008000][I]Ignorance is Temporary [/I][/COLOR][COLOR=#800080][I]- [/I][/COLOR][COLOR=#ff0000][I]Stupidity is Forever[/I][/COLOR][COLOR=#800080][I]...[/I][/COLOR][/SIZE][I][COLOR=#ff0000]
    [/COLOR][/I]

  4. Likes jklingert liked this post
  5. #4
    Join Date
    Jan 2015
    Location
    Burlington, NC
    Posts
    49
    Post Thanks / Like

    Default Re: Renard SS24 - Flashed chips not working

    Quote Originally Posted by budude View Post
    Channels 9 and 17 (or really PIC#2 channel 1 and PIC#3 channel 1) is indicative of a blank PIC - you did program all 3 PICs correct? They should all have the same code on them.
    Hmmm... that makes sense. 1, 9 and 17 are the first channels of each "group" of 8. So now I'm wondering what I did wrong when I flashed the chips.

    BTW, I just removed the 3 chips from the "good" Renard & tested the 2 "bad" controllers with the chips... and they worked! So that means it's DEFINITELY the chips causing the issue!

    Can anyone tell me if I have the chip in the correct slot in the pic I posted above. Also, do I have the notch pointing in the correct direction? I'm preparing to re-flash the chips again, but I'm afraid I'm doing something wrong and don't want to repeat the mistake again.

    Also, I'm going to attach the ASM and HEX files that I used. Maybe someone can take a quick look & see if they look correct. I would really appreciate it. Perhaps I'm using the wrong files. ?

    I found an older link that referenced firmware on the Renard wiki page here:
    http://www.doityourselfchristmas.com...e#DMX_firmware

    Can I use this firmware from that wiki page: (Standard firmware for the PIC16F688: renard-20071229.asm)?

    Thanks in advance for any help or info.
    Attached Files Attached Files
    [URL="http://www.facebook.com/MapleRidgeLights"]http://www.facebook.com/MapleRidgeLights[/URL]

    2014: 4 static incandescent strings & 2 inflatables
    2015: Over 9000 pixel channels & 72 Renard channels. 3 E682 controllers, 3 Renard SS24s and E1.31 bridge. House & windows covered in pixels! 4 HDPE arches, 11ft pixel tree & star, 12 LED mini-trees, 8 LED snowflakes, 2 4' LED Candy Canes, Chroma-cane and various LED strings in trees & yard. Xlights / FPP run the show!
    2016: My CLAP is telling me to go BIGGER!

  6. #5
    Join Date
    Jan 2015
    Location
    Burlington, NC
    Posts
    49
    Post Thanks / Like

    Default Re: Renard SS24 - Flashed chips not working

    Anybody? Bueller?

    I started over with flashing the chips & followed every step EXACTLY, and even re-downloaded the firmware in case something got corrupted the first time. I don't think I missed anything the first time, but wanted to be sure.

    I think I have bad chips. 1 out of 6 works... and I think the other 5 are BAD.

    When I flashed the chips with the pickit 2 software the write was successful, and the verify was successful. But when I did a "blank check" afterwards, it said the chip was BLANK! So how did it pass verification?

    Has anyone encountered this before?

    I guess I need to get new chips. Who do I need to get them from? Waynej?
    [URL="http://www.facebook.com/MapleRidgeLights"]http://www.facebook.com/MapleRidgeLights[/URL]

    2014: 4 static incandescent strings & 2 inflatables
    2015: Over 9000 pixel channels & 72 Renard channels. 3 E682 controllers, 3 Renard SS24s and E1.31 bridge. House & windows covered in pixels! 4 HDPE arches, 11ft pixel tree & star, 12 LED mini-trees, 8 LED snowflakes, 2 4' LED Candy Canes, Chroma-cane and various LED strings in trees & yard. Xlights / FPP run the show!
    2016: My CLAP is telling me to go BIGGER!

  7. #6
    Join Date
    May 2007
    Location
    Mooresville, NC
    Posts
    7,567
    Post Thanks / Like

    Default Re: Renard SS24 - Flashed chips not working

    You did a "blank check"? That erases them. You only write the firmware and then use them.
    James Family Christmas - 1600 channels of SS Renard channels
    Website - http://jamesfamilychristmas.com/ <<broken
    Facebook - James Family Christmas


  8. #7
    Join Date
    Dec 2013
    Location
    Winter Haven Florida
    Posts
    3,039
    Post Thanks / Like

    Default Re: Renard SS24 - Flashed chips not working

    I have the same programmer you have chip in right spot and notch does face the lever
    James WinterHaven Fl

  9. #8
    Join Date
    Jan 2015
    Location
    Burlington, NC
    Posts
    49
    Post Thanks / Like

    Default Re: Renard SS24 - Flashed chips not working

    Quote Originally Posted by Wayne J View Post
    You did a "blank check"? That erases them. You only write the firmware and then use them.
    OK... now I'm really confused.

    I did a "blank check" on the 1 chip that's working, and the program said it was NOT blank. So I did NOT re-flash it, and it's still working. I just tested them all a few minutes ago.

    I re-flashed the other 5, did a verify... and all was successful. I did NOT do a blank check. They're still not working. I assume they're blank (the first channel in that group of 8 stays on).

    I'm out of ideas because I'm pretty sure I'm doing everything correctly.

    The only thing I can come up with is bad chips. Why would 1 work, and 5 not... when I performed the exact same steps for all of them?

    Gremlins!?

    I have the same programmer you have chip in right spot and notch does face the lever
    Thanks for that info... Glad to know it wasn't "user error"!
    [URL="http://www.facebook.com/MapleRidgeLights"]http://www.facebook.com/MapleRidgeLights[/URL]

    2014: 4 static incandescent strings & 2 inflatables
    2015: Over 9000 pixel channels & 72 Renard channels. 3 E682 controllers, 3 Renard SS24s and E1.31 bridge. House & windows covered in pixels! 4 HDPE arches, 11ft pixel tree & star, 12 LED mini-trees, 8 LED snowflakes, 2 4' LED Candy Canes, Chroma-cane and various LED strings in trees & yard. Xlights / FPP run the show!
    2016: My CLAP is telling me to go BIGGER!

  10. #9
    Join Date
    May 2007
    Location
    Mooresville, NC
    Posts
    7,567
    Post Thanks / Like

    Default Re: Renard SS24 - Flashed chips not working

    Try this.. take the one that is working, and re-flash it and try.
    James Family Christmas - 1600 channels of SS Renard channels
    Website - http://jamesfamilychristmas.com/ <<broken
    Facebook - James Family Christmas


  11. #10
    Join Date
    Jan 2015
    Location
    Burlington, NC
    Posts
    49
    Post Thanks / Like

    Default Re: Renard SS24 - Flashed chips not working

    Quote Originally Posted by Wayne J View Post
    Try this.. take the one that is working, and re-flash it and try.
    Ok... tried that. Here are the steps I performed on the "good chip:

    * Downloaded the Renard operational firmware again from here: http://doityourselfchristmas.com/wik...Board#Firmware
    * Used MPASMWIN to generate the hex file
    * Plugged in the pickit2 programmer with the chip installed. The blue button on the pickit was in the UP position (UP is for 8-20 pin chips; DOWN is for 28-40 pin chips)
    * Opened the pickit2 software; the pickit was detected
    * Performed BLANK CHECK - Was NOT blank
    * Performed ERASE
    * Performed WRITE - Successful
    * Performed VERIFY - Successful
    * Performed BLANK CHECK - Chip is BLANK
    * Tested chip - Now this chip does NOT work (Channel 1 stays on; the other 7 channels don't work)

    Hopefully someone has an idea of what may be happening, because I don't.

    Do I have a bad pickit?

    I've attached 5 screenshots of the steps I mentioned above (limit of 5 per post; will post more after this post). Maybe there's something on the screens that may give a clue as to what's happening.

    Thanks again for any help or ideas anyone may have.
    MPASM Assembling Hex for Renard SS24.JPGMPASM Assembling Hex for Renard SS24-Success.JPGPickit With Good Chip before doing anything.JPGPickit With Good Chip -Blank Check.JPGPickit With Good Chip - Erased.JPG
    [URL="http://www.facebook.com/MapleRidgeLights"]http://www.facebook.com/MapleRidgeLights[/URL]

    2014: 4 static incandescent strings & 2 inflatables
    2015: Over 9000 pixel channels & 72 Renard channels. 3 E682 controllers, 3 Renard SS24s and E1.31 bridge. House & windows covered in pixels! 4 HDPE arches, 11ft pixel tree & star, 12 LED mini-trees, 8 LED snowflakes, 2 4' LED Candy Canes, Chroma-cane and various LED strings in trees & yard. Xlights / FPP run the show!
    2016: My CLAP is telling me to go BIGGER!

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •