Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Need help understanding error

  1. #11
    Join Date
    Jan 2010
    Location
    South Centeral Oklahoma, USA
    Posts
    246
    Post Thanks / Like

    Default Re: Need help understanding error

    And the error log:

    Warning 1 The field 'Vixen.Sys.Output.IntervalUpdateSignaler._lastUpda teTime' is assigned but its value is never used C:\My Projects\vixen3\Vixen.System\Sys\Output\IntervalUp dateSignaler.cs 9 16 Vixen
    Warning 2 The field 'Vixen.Module.Effect.EffectModuleInstanceBase.prer endCnt' is assigned but its value is never used C:\My Projects\vixen3\Vixen.System\Module\Effect\EffectM oduleInstanceBase.cs 24 23 Vixen
    Warning 3 Unreachable expression code detected C:\My Projects\vixen3\Vixen.System\Sys\Managers\Hardware UpdateThread.cs 161 33 Vixen
    Warning 4 Unreachable code detected C:\My Projects\vixen3\Vixen.System\Sys\Output\OutputCont roller.cs 167 8 Vixen
    Warning 5 The using directive for 'System.Linq' appeared previously in this namespace C:\My Projects\vixen3\Common\ScriptSequence\Script\Scrip tProjectGenerator.cs 7 7 ScriptSequence
    Warning 6 Missing XML comment for publicly visible type or member 'Dataweb.NShape.WinFormsUI.Display.ScrollBy(int, int)' C:\My Projects\vixen3\Common\NShape\WinFormsUI\Display.c s 4680 15 NShapeWinFormsUI
    Warning 7 Missing XML comment for publicly visible type or member 'Dataweb.NShape.WinFormsUI.Display.ScrollTo(int, int)' C:\My Projects\vixen3\Common\NShape\WinFormsUI\Display.c s 4686 15 NShapeWinFormsUI
    Warning 8 The field 'VixenModules.Preview.VixenPreview.VixenPreviewMod uleInstance.UseOldPreview' is assigned but its value is never used C:\My Projects\vixen3\Modules\Preview\VixenPreview\Vixen PreviewModuleInstance.cs 17 16 VixenPreview
    Warning 9 The field 'VixenModules.Preview.VixenPreview.VixenPreviewMod uleInstance.UseOldPreview' is assigned but its value is never used C:\My Projects\vixen3\Modules\Preview\VixenPreview\Vixen PreviewModuleInstance.cs 17 16 VixenPreview
    Warning 10 Unreachable code detected C:\My Projects\vixen3\Modules\Preview\VixenPreview\Vixen PreviewSetupElementsDocument.cs 62 4 VixenPreview
    Warning 11 Unreachable code detected C:\My Projects\vixen3\Modules\Preview\VixenPreview\Vixen PreviewSetupElementsDocument.cs 62 4 VixenPreview
    Warning 12 The event 'VixenModules.Preview.VixenPreview.VixenPreviewCon trol.OnElementsChanged' is never used C:\My Projects\vixen3\Modules\Preview\VixenPreview\Vixen PreviewControl.cs 84 50 VixenPreview
    Warning 13 The event 'VixenModules.Preview.VixenPreview.VixenPreviewCon trol.OnElementsChanged' is never used C:\My Projects\vixen3\Modules\Preview\VixenPreview\Vixen PreviewControl.cs 84 50 VixenPreview
    Warning 14 The field 'VixenModules.Preview.VixenPreview.VixenPreviewMod uleInstance.isGdiVersion' is assigned but its value is never used C:\My Projects\vixen3\Modules\Preview\VixenPreview\Vixen PreviewModuleInstance.cs 201 8 VixenPreview
    Warning 15 The field 'VixenModules.Preview.VixenPreview.VixenPreviewMod uleInstance.isGdiVersion' is assigned but its value is never used C:\My Projects\vixen3\Modules\Preview\VixenPreview\Vixen PreviewModuleInstance.cs 201 8 VixenPreview
    Warning 16 The field 'VixenModules.App.Shows.PauseAction.process' is assigned but its value is never used C:\My Projects\vixen3\Modules\App\Shows\Actions\PauseAct ion.cs 12 19 Shows
    Warning 17 The variable 'lastUpdate' is declared but never used C:\My Projects\vixen3\Modules\Output\E1.31\E131OutputPlu gin.cs 536 22 E131
    Warning 18 Field 'VixenModules.Output.K8055_Controller.K8055Module. _Offset' is never assigned to, and will always have its default value 0 C:\My Projects\vixen3\Modules\Output\K8055 Controller\K8055Module.cs 18 15 K8055 Controller

  2. #12
    Join Date
    Mar 2010
    Location
    Delaware, OH
    Posts
    670
    Post Thanks / Like

    Default Re: Need help understanding error

    Actually, I was speaking of the Vixen Error Log accessed from the Vixen Administration Dialog.

  3. #13
    Join Date
    Jan 2010
    Location
    South Centeral Oklahoma, USA
    Posts
    246
    Post Thanks / Like

    Default Re: Need help understanding error

    Ah.. Those, yeah, I still get those

    Ill look over it a bit, and if I come up with anything Ill reply

  4. #14
    Join Date
    Mar 2010
    Location
    Delaware, OH
    Posts
    670
    Post Thanks / Like

    Default Re: Need help understanding error

    OK, thanks. I have a suspicion that this might be some kind of intermodule dependency issue specific to how I structured the Papagayo import code. But can't tell for sure.

  5. #15
    Join Date
    Jan 2010
    Location
    South Centeral Oklahoma, USA
    Posts
    246
    Post Thanks / Like

    Default Re: Need help understanding error

    You might want to post to the dev group, your errors, and a link to this thread, or just repost the relative stuff.

    Ill keep looking, but one of the others may know right away what the issue is, as most of them have done more work in this area than I have.

  6. #16
    Join Date
    Mar 2010
    Location
    Delaware, OH
    Posts
    670
    Post Thanks / Like

    Default Re: Need help understanding error

    Thanks for the help, I have posted to Jira and am also watching the Dev Group. Hopefully, I can get this figure out....

  7. #17
    Join Date
    Oct 2011
    Location
    Maryville, Illinois
    Posts
    1,657
    Post Thanks / Like

    Default Re: Need help understanding error

    I took a look at your branch and I have found the problem. You are not the first to get bit by it. When you aded the references to vixen.dll and your new modules to other projects they default to copy local = true in the properties of the reference. The way it is setup, your included references to other parts of the solution should never be copied local. So when adding a reference to another module you need to go in and update the properties on those references to copy local = false. I think I found 3 references to vixen in your new projects I changed. The 3 new modules you made (editor, effect, and app) are all cross referenced in many places with the same problem. Once I got all those cleaned up, it loads cleanly.

    What happens is that it ends up with multiple copies of the dll in the app path and the module loader discovers it multiple times and tries to load it from each version of the dll. Of course they all have the same type id and then it thinks they are duplicates.

    Jeff
    Last edited by jeffu231; 05-13-2014 at 08:22 PM.

  8. #18
    Join Date
    Jan 2010
    Location
    South Centeral Oklahoma, USA
    Posts
    246
    Post Thanks / Like

    Default Re: Need help understanding error

    Knew that was what was happening, but all of the copy local properties I looked at were already false, I guess I wasn't looking in the right place and therefore didn't mention it!

    Can you point out where you found these, for my own future reference please. (Nevermind, found it)

    Thank you,
    James
    Last edited by bolwire; 05-13-2014 at 09:12 PM.

  9. #19
    Join Date
    Mar 2010
    Location
    Delaware, OH
    Posts
    670
    Post Thanks / Like

    Default Re: Need help understanding error

    Yes!

    That worked, me and my aching head thank you both for the help.

    Ed

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •