Page 1 of 5 123 ... LastLast
Results 1 to 10 of 42

Thread: Preview problems

  1. #1
    Join Date
    Dec 2010
    Location
    Tustin, CA
    Posts
    2,143
    Post Thanks / Like

    Default Preview problems

    Well, this may be two problems that's not easily fixed.

    First, every time I try to draw something I don't get a nice clean narrow line but a huge fat line. I'm guessing something is just not quite right someplace and that place may be Wine. Is direct X used while creating props on the preview or only during run time?

    Second, even with the fat lines once I start the playing the sequence it goes for a few seconds and we get a full crash. I can access the crash report. I'm guessing the second problem may be related to the first one.

    I really don't know where to go from here. The Direct X that's being use is MSs. I could try running one from the Wine load but I figured its best right now to use the basic DirectX.

    Anyone, especially Mac users, have any ideas

  2. #2
    Join Date
    Dec 2010
    Location
    Tustin, CA
    Posts
    2,143
    Post Thanks / Like

    Default Re: Preview problems

    Update:

    Good news, as of 16S preview no longer crashes when running.

    Bad news, the existing elements are still really fat instead of the smaller lines they should be.

    To be tested, I need to create some additional elements to see if they will be created correctly or if the lines are still fat.


    I'm including a screen capture show what they currently look like.


  3. #3
    Join Date
    Dec 2011
    Location
    Key West, FL
    Posts
    3,620
    Post Thanks / Like

    Default Re: Preview problems

    That is NOT HLS --- It's your MAC.

    Please don't state a problem exists if it is NOT an issue on a PC.

    I do not design for the MAC. If I can help -- I will -- but this is clearly a MAC issue.

    I ask because users coming to the HLS Threads and see "Problem" or "Issue" ... and don't realize you are speaking about MAC behavior can think THEY will have an issue.

    Thanks in advance for your MAC posts in considering MOST users are PC based.

    Joe
    Link to my DownLoad Site: [B][COLOR=#ff0000][URL]http://www.joehinkle.com/HLS[/URL]

    [/COLOR][/B][IMG]http://joehinkle.com/HLS/HLS%20Logo%20Small.jpg[/IMG]

  4. #4
    Join Date
    Dec 2011
    Location
    Key West, FL
    Posts
    3,620
    Post Thanks / Like

    Default Re: Preview problems

    That is NOT HLS --- It's your MAC.

    Please don't state a problem exists if it is NOT an issue on a PC.

    I do not design for the MAC. If I can help -- I will -- but this is clearly a MAC issue.

    I ask because users coming to the HLS Threads and see "Problem" or "Issue" ... and don't realize you are speaking about MAC behavior can think THEY will have an issue.

    Thanks in advance for your MAC posts in considering MOST users are PC based.

    I will see if Brian will create a separate Thread for HLS running on MACs.

    Thanks again for your consideration.

    Joe
    Link to my DownLoad Site: [B][COLOR=#ff0000][URL]http://www.joehinkle.com/HLS[/URL]

    [/COLOR][/B][IMG]http://joehinkle.com/HLS/HLS%20Logo%20Small.jpg[/IMG]

  5. #5
    Join Date
    Dec 2010
    Location
    Tustin, CA
    Posts
    2,143
    Post Thanks / Like

    Default Re: Preview problems

    Sorry, I'm not trying to cause issues. I did state all along that this could be related to Wine. Anytime I report any issues I always consider if Wine could play a role. If I think its a possibly I add that to my post.

    I bring it up just incase maybe a parameter in a structure may possible be uninitialized or out of range, heck I've done that on more than one occasion, but Windows worked around it.

    I would not have made the last post except that the crash I always got went away. The first point I stated was that the crashes went away. I thought you may have working on that section of the code. Since I've not installed any updates to Wine I figured something changed in HLS.

    From now on when ever I post a but that has any reasonable chance it may be related to Wine I'll make it clear. Something like "Possible Preview Problem when running under Wine" so it totally clear.

  6. #6
    Join Date
    Dec 2011
    Location
    Key West, FL
    Posts
    3,620
    Post Thanks / Like

    Default Re: Preview problems

    I moved moved this thread to the HLS MAC forum.

    I have done nothing in the area of code you are speaking of.

    The behavior is directly related to DirectX -- which you have been asking about that recently.

    I suspect it has to do with how DirectX is used with Wine.

    Joe
    Link to my DownLoad Site: [B][COLOR=#ff0000][URL]http://www.joehinkle.com/HLS[/URL]

    [/COLOR][/B][IMG]http://joehinkle.com/HLS/HLS%20Logo%20Small.jpg[/IMG]

  7. #7
    Join Date
    Dec 2010
    Location
    Tustin, CA
    Posts
    2,143
    Post Thanks / Like

    Default Re: Preview problems

    Quote Originally Posted by JHinkle View Post
    I will see if Brian will create a separate Thread for HLS running on MACs.

    Thanks again for your consideration.

    Joe
    I'd title it not for just the Mac but for any alternate platforms since Wine is also use on Linux systems even more tha on Macs. Maybe something like "Issues when Running HLS under Wine or Virtualization" which covers any cross platform operation plus someone running under Xen on a PC.

  8. #8
    Join Date
    Dec 2010
    Location
    Tustin, CA
    Posts
    2,143
    Post Thanks / Like

    Default Re: Preview problems

    I agree this is most likely an issue with DirectX.

    Let me go through my posts dealing with Wine and send you a list so you can move those here as well.

  9. #9
    Join Date
    Dec 2010
    Location
    Tustin, CA
    Posts
    2,143
    Post Thanks / Like

    Default Re: Preview problems

    I think I have even a better title would be, "Running HLS under Wine (Mac or Linux) or Virtualization". I think is makes it clearer and covers the two main way to run HLS on other than pure windows.

  10. #10
    Join Date
    Jan 2009
    Location
    Yuma, AZ
    Posts
    1,599
    Post Thanks / Like

    Default Re: Preview problems

    Hi:
    I am running a 27" iMac, but I am using Boot Camp and Window 7 and am having no issues (so far).

    I have never run Wine but I did try Parallels and did not like it. Windows is better run under Boot Camp.

    What I did find was that HLS does not like Windows XP and at least on my show computer, locks up. I have not solved that problem yet, even though I would prefer to run HLS, I can't. I have to stick with V2 or V3.

    Sorry, Joe!
    [B][I][U]Idun[/U][/I][/B]

    [IMG]http://www.vixenlights.com/sig/sig_h.php/152/136.gif[/IMG]

    [B]Lotsa' Patience![/B] (Some days you can't win, the others you lose, and forget about the rest)

    [B]Some mornings I wake up GRUMPY and other days I let her sleep![/B]

Page 1 of 5 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •