Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Lack of communication to the E681

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Jul 2010
    Posts
    77
    Post Thanks / Like

    Default Lack of communication to the E681

    Hello all,

    I've completed the assembly of the E681 board. However, I cannot not communicate with it at all. I've followed the instructions in the manual but still cannot connect. The board is behaving as it should, all the appropriate leds respond as they should. I've attached a set of pixels and they go through the boards "test sequence". I have connected to the board directly with 2 different lap tops and now a desk top. The LAN led lights up when I plug an ethernet cable into it. I open a web browser and tried the 192.168.1.206 and the 169.254.74.73 addresses but no connection. Any suggestions would be greatly appreciated.

    Thanks,
    Kevin

  2. #2
    Join Date
    Nov 2008
    Location
    Springdale, Arkansas
    Posts
    126
    Post Thanks / Like

    Default Re: Lack of communication to the E681

    Is your computer in the same IP range as the board?
    16 channels all Grinch (2008)
    48 channels, 32 Grinch + 16 Renard (2009)
    104 channels of Renard (2010)
    168 channels of Renard (2011)

    somewhere about 22,000 LED's

  3. #3
    Join Date
    Oct 2011
    Location
    Chesapeake, VA
    Posts
    761
    Post Thanks / Like

    Default Re: Lack of communication to the E681

    Hey kayjay,

    what you could do is connect a cat5 cable from your laptop/desktop NIC to the NIC of the E681. Configure your network adapter on your computer with IP address of 192.168.1.XXX subnet mask 255.255.255.0 and you don't need to specify a gateway. This should allow you to connect without a physical router or anything.. good luck!
    [SIZE=3][B]8000 + E1.31 Channels (5x E68x controllers)
    128 Renard Channels[/SIZE][/B]
    sequencing with LightShow Pro 2.8 and/or Vixen 3 (using xLights scheduler)
    2 x Pixel Mega Trees, RGB Pixel Roofline, 2 x RGB Pixel Spinners, 11 x Pixel Bushes, 6 x GECE Icicle Arches, 16 x RGB Mini Trees, 2 x Vertical Pixel Poles,
    12 x 10w RGB Floods, 160 Strobes controlled by Arduino
    [URL="http://www.controlthelights.net"]http://www.controlthelights.net[/URL]

  4. #4
    Join Date
    Dec 2010
    Location
    Oceanside, CA
    Posts
    2,363
    Post Thanks / Like

    Default Re: Lack of communication to the E681

    Are you using a crossover cable? I'm not sure about the WizNet, but most 100baseT network interfaces either need a crossover cable, or a switch/hub between two devices. If your laptop's have Gigabit, it should auto-sense and work without it, so it would be something in the software configuration, but you can likely eliminate one more possibility.
    [url]http://christmasonquiethills.com/[/url]
    [url]http://diychristmas.org/vb1/index.php[/url]

  5. #5
    Join Date
    Nov 2008
    Location
    Lexington, NC
    Posts
    2,165
    Post Thanks / Like

    Default Re: Lack of communication to the E681

    Quote Originally Posted by Materdaddy View Post
    Are you using a crossover cable? I'm not sure about the WizNet, but most 100baseT network interfaces either need a crossover cable, or a switch/hub between two devices. If your laptop's have Gigabit, it should auto-sense and work without it, so it would be something in the software configuration, but you can likely eliminate one more possibility.
    Every time I have connected to the E681, I've used a "regular" straight cable. The Wiznet figures out if it's directly connected or via a switch.
    Mark

  6. #6
    Join Date
    Dec 2010
    Location
    Oceanside, CA
    Posts
    2,363
    Post Thanks / Like

    Default Re: Lack of communication to the E681

    Quote Originally Posted by mschell View Post
    Every time I have connected to the E681, I've used a "regular" straight cable. The Wiznet figures out if it's directly connected or via a switch.
    Good to know. Thanks for the correction!
    [url]http://christmasonquiethills.com/[/url]
    [url]http://diychristmas.org/vb1/index.php[/url]

  7. #7
    Join Date
    Jul 2010
    Posts
    77
    Post Thanks / Like

    Default Re: Lack of communication to the E681

    Thanks for the quick response. I thought I tried that but I guess I missed something. Working now. Thanks again
    Kevin

  8. #8
    Join Date
    Nov 2009
    Location
    Plymouth, MN
    Posts
    414
    Post Thanks / Like

    Default Re: Lack of communication to the E681

    The Wiznet doesn't need a crossover cable.

    I did have to disable my Wifi network on the laptop (and either reboot it or run the ipconfig command to tell it to 'forget' its DHCP address) in order to talk directly to the E681. Eventually I'll assign it an ip address in my normal network space and hook it up to my router.

  9. #9
    Join Date
    Jul 2010
    Posts
    77
    Post Thanks / Like

    Default Re: Lack of communication to the E681

    Yea, I had to disable the wireless card in order for the laptop to connect.

  10. #10
    Join Date
    Nov 2008
    Location
    Lexington, NC
    Posts
    2,165
    Post Thanks / Like

    Default Re: Lack of communication to the E681

    Quote Originally Posted by kayjay View Post
    Yea, I had to disable the wireless card in order for the laptop to connect.
    And the reason for this is that most wireless network routers use the 192.168.1.x network for the IP addresses they give out, along with a subnet mask of 255.255.255.0. What that means is that all traffic for any address in the 192.168.1.1-255 range will go out on that connection. Your local Ethernet connection would have to be assigned a different subnet to have it work, and then couldn't talk to the default address of the E681.

    All that to say that you need to know a little about IP networking to be able to use more than one network connection at a time. That network connection could be two NIC cards with wired connections, or one wired connection and a wireless one.

    Disabling the wireless allows your wired connection to handle all the traffic, and so you can "talk" to the E681.

    Setting your E681 to a different subnet, such as 192.168.2.x, and setting your wired connection to the same subnet will allow both to work at the same time.
    Mark

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •