Results 1 to 6 of 6

Thread: Newbie trying to program pic chips.

  1. #1
    Join Date
    Dec 2010
    Location
    New Albany, Pa
    Posts
    3
    Post Thanks / Like

    Default Newbie trying to program pic chips.

    Hello.. I am new to the PIC programming.. I was trying to follow the videos here on DIYC on how to convert the ASM to HEX file. However every time i do it i get errors. I am following the videos but still no go. Any help would be awsome. Thank you.

  2. #2
    Join Date
    Dec 2011
    Posts
    3,092
    Post Thanks / Like

    Default Re: Newbie trying to program pic chips.

    fixed!

  3. #3
    Join Date
    Dec 2008
    Location
    Ft. Mitchell, KY (Cincinnati Area)
    Posts
    3,723
    Post Thanks / Like

    Default Re: Newbie trying to program pic chips.

    Quote Originally Posted by angus40 View Post
    fixed!
    While it looks likely it was something simple, other new users might benefit from this thread if you describe what the problem was and what was done to "fix" it.


    Heading into my 5th season in 2013

    www.ChristmasInKentucky.com

  4. #4
    Join Date
    Dec 2011
    Posts
    3,092
    Post Thanks / Like

    Default Re: Newbie trying to program pic chips.

    Updating Mplab to the latest version seems to solved tithonia1's issues. Also it could have been the chosen location when installing the program .

    Note to first time .asm to .hex conversions ,when selecting the pic make sure you select the right part # .

    IF you select one that looks close you will most likely get errors .

  5. #5
    Join Date
    Dec 2010
    Location
    New Albany, Pa
    Posts
    3
    Post Thanks / Like

    Default Re: Newbie trying to program pic chips.

    Yes everything is good now. For those new also. My first mistake i believe is i saved MPLAB and MPASMwin to my desk top. So i deleted them and downloaded a newer version of both programs and put each in a seperate folder on my C: drive. I think between the saving and i may have downloaded a bad MPASMWIN file. Both sites i have downloaded the new files from are below And also wanted to thank ANGUS40 for taking the time so early in the morning to help out. Maybe there are other sites but both of these worked for me.

    For MPLAB IDE

    http://www.microchip.com/stellent/id...cName=en023073

    For MPASMWIN

    http://melabs.com/support/mpasm.htm

  6. #6
    Join Date
    May 2007
    Location
    Mooresville, NC
    Posts
    6,728
    Post Thanks / Like

    Default Re: Newbie trying to program pic chips.

    Quote Originally Posted by tithonia1 View Post
    Yes everything is good now. For those new also. My first mistake i believe is i saved MPLAB and MPASMwin to my desk top. So i deleted them and downloaded a newer version of both programs and put each in a seperate folder on my C: drive. I think between the saving and i may have downloaded a bad MPASMWIN file. Both sites i have downloaded the new files from are below And also wanted to thank ANGUS40 for taking the time so early in the morning to help out. Maybe there are other sites but both of these worked for me.

    For MPLAB IDE

    http://www.microchip.com/stellent/id...cName=en023073

    For MPASMWIN

    http://melabs.com/support/mpasm.htm
    ahhh, so you missed that part of the video that said to make the folder directly in the C drive. ;)
    James Family Christmas - 1144 channels of SS Renard channels
    Website - http://jamesfamilychristmas.com/
    Facebook - James Family Christmas


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •