Results 1 to 5 of 5

Thread: Question about E1.31 for Vixen 2.5

  1. #1
    Join Date
    Dec 2011
    Location
    houston, TX
    Posts
    114
    Post Thanks / Like

    Default Question about E1.31 for Vixen 2.5

    I have sucessfully added the J1sysE131 dll for vixen 2.5 to my system. And the particulars of what I'm trying to do are thus:

    I have an existing technology already set up. (Youtube: http://youtu.be/Rfu_x8sSPUo if you are curious.) Basically I already have LED controllers and drivers of my own design. What I want to do is teach it to understand DMX when it arrives over the ethernet, and just run a GIGO mode in that case, but my existing algorithms when Vixen isn't displaying anything. This gives me both scripted shows and algoritmic shows both.

    But when I try to tell the J1sysE131 dll to use a unicast address instead of multicast, it gives me a possible runtime error. And when the test show runs, it says no packets went out and nothing happens. It doesn't happen quite fast in fact. I suspect I'm doing something incorrectly, but I rt clicked the destination and it took the IP of the target board. It just doesn't run with it.

    1.0.0.1 version if that matters.

  2. #2
    Join Date
    Nov 2008
    Location
    Ottoville ohio
    Posts
    1,360
    Post Thanks / Like

    Default Re: Question about E1.31 for Vixen 2.5

    i dont think it was ever pushed thru as 2.5 was such unstable version.
    2012 - The year of the pixels
    21ft tall 12x38ct WS2811 Pixel Megatree - DONE
    5 36ct GECE Pixel Archs - Maybe
    Pixelated roofline with windows - DONE
    Bigger matrix and pixel star - DONE
    Added 1200 pixels, a few strobes, and fast tubes
    Now it just all has to play nicely lol.

    [url]http://www.facebook.com/FiedlerFamilyChristmas[/url]
    [URL="http://www.facebook.com/OhioChristmasDisplays"]http://www.facebook.com/OhioChristmasDisplays[/URL]

  3. #3
    Join Date
    Feb 2010
    Location
    Knoxville TN USA
    Posts
    136
    Post Thanks / Like

    Default Re: Question about E1.31 for Vixen 2.5

    I believe that I have conditionals in the source code for v2.1 vs v2.5. I don't recall doing much/any testing with v2.5. I don't recall releasing a v2.5 binary. I will investigate and let you know further.

    -Ed

  4. #4
    Join Date
    Dec 2007
    Location
    Canberra, ACT, Australia
    Posts
    600
    Post Thanks / Like

    Default Re: Question about E1.31 for Vixen 2.5

    I can assure you that the E131 plugin for vixen 2.x works perfectly fine in 2.5.0.8 using unicast. For 2010 i ran 20 universes of DMX out the E131 plugin with no issues at 25ms timings. For 2011 I sent 24 Universes out via E131.

    Cheers
    Phil
    2012:
    Software: LightFactory Personal
    Hardware: J1Sys Pixel controllers . [url]Http://www.j1sys.com[/url]
    Lights: 6000+ Pixels and 20k+ LEDs
    Channels: around 20,000 channels

    You know where to find me....

  5. #5
    Join Date
    Dec 2011
    Location
    houston, TX
    Posts
    114
    Post Thanks / Like

    Default Re: Question about E1.31 for Vixen 2.5

    solved the problem. Entering the data was fine, but I didn't realize that only added it to the pulldown - I still needed to pulldown and select the newly added unicast.

    Vixen2.5 is now pumping data to my custom rig just fine. Thanks for the help!

    Now to move to Vixen3.0

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •