Page 4 of 4 FirstFirst ... 234
Results 31 to 40 of 40

Thread: Vixen 2.1 on Linux

  1. #31
    Join Date
    Jul 2009
    Location
    Kansas City, KS
    Posts
    197
    Post Thanks / Like

    Default Re: Vixen 2.1 on Linux

    Nice, just got Vixen 2.1 working in 64bit Xubuntu 12.04 + Wine1.5.

    Running a 64bit distro seemed to be the source of some problems, but it works now after some hacks.
    Specificaly, I was getting this error about fmodex64 when trying to start Vixen:
    wine-fmodex64-error.png

    It appears that Vixen loads either fmodex.dll (for 32bit systems), or fmodex64.dll (for 64bit systems).
    So I tricked it into loading fmodex.dll (32bit) instead, by renaming it to fmodex64.dll.
    And oddly enough, Vixen now runs fine without any problems.

  2. #32
    Join Date
    Jan 2008
    Location
    Fountain Valley, CA (Orange County, So. Cal)
    Posts
    2,147
    Post Thanks / Like

    Default Re: How to: Vixen 2.1 on Linux

    I finally got around to trying this out. I just ran a couple of test sequences using Vixen 2.1.x on Ubuntu 12.4 inside VMWare Player on a Windows 7 box and it worked quite well. There were some errors that flashed by during the install which I didn't catch, and I skipped over the USB parts just to see if some basic plug-ins would run (Adjustable Preview and Grid Editor) and they did. One of the sequences was using the equivalent of over 12K channels. I didn't do any tuning, so it was a little jumpy/laggy due to display updates, but it ran quite well.

    Thank you Jonpro03 and everyone else who worked on this - awesome job!

    don
    Last edited by djulien; 10-11-2012 at 01:38 AM.
    Click for display details >>
    web site: http://www.eShepherdsOfLight.com or http://www.facebook.com/eShepherdsOfLight
    technical articles: http://downloads.eshepherdsoflight.com

  3. #33
    Join Date
    Aug 2007
    Location
    Hermitage TN
    Posts
    50
    Post Thanks / Like

    Default Re: Vixen 2.1 on Linux

    Anyone have any luck with the 'Network' trigger part ??

  4. #34
    Join Date
    Jan 2012
    Location
    Monroe, GA
    Posts
    200
    Post Thanks / Like

    Default Re: Vixen 2.1 on Linux

    Quick question as I don't seem to be quite as happy as that tornado in the trailer park! I am not able to see any comm ports in the Profile Manager for my Entec Pro Plugin. I have followed all of the instructions including adding my user to the dialout group but the drop down continues to be blank. Where have I gone wrong? Ubuntu 12.04 with Wine 1.4.

    Thanks in advance,

    Mark

  5. #35
    Join Date
    Aug 2007
    Location
    Hermitage TN
    Posts
    50
    Post Thanks / Like

    Default Re: Vixen 2.1 on Linux

    Is it plugged in (before you start Vixen)?

  6. #36
    Join Date
    Jan 2012
    Location
    Monroe, GA
    Posts
    200
    Post Thanks / Like

    Default Re: Vixen 2.1 on Linux

    Quote Originally Posted by lalder View Post
    Is it plugged in (before you start Vixen)?
    I have tried it several ways. I have restarted the machine with it connected, restarted the app with it connected, unplugged, launched the app and plugged it in but to no avail...

  7. #37
    Join Date
    Aug 2007
    Location
    Hermitage TN
    Posts
    50
    Post Thanks / Like

    Default Re: Vixen 2.1 on Linux

    Is it a USB port or an onboard serial? I had missed the USB serial part the first time

  8. #38
    Join Date
    Jan 2012
    Location
    Monroe, GA
    Posts
    200
    Post Thanks / Like

    Default Re: Vixen 2.1 on Linux

    Quote Originally Posted by lalder View Post
    Is it a USB port or an onboard serial? I had missed the USB serial part the first time
    Would be USB : ttyUSB0

  9. #39
    Join Date
    Aug 2007
    Location
    Hermitage TN
    Posts
    50
    Post Thanks / Like

    Default Re: Vixen 2.1 on Linux

    Well you got me then. I had to reload Ubuntu a couple of times trying to get everything right.
    one time I had ttyUSBO (the letter not the number)

  10. #40
    Join Date
    Jan 2012
    Location
    Monroe, GA
    Posts
    200
    Post Thanks / Like

    Default Re: Vixen 2.1 on Linux

    Quote Originally Posted by lalder View Post
    Well you got me then. I had to reload Ubuntu a couple of times trying to get everything right.
    one time I had ttyUSBO (the letter not the number)
    I appreciate you giving it a shot!! I have tried two different forums now and am not having much luck with this thing!

    Take care

Page 4 of 4 FirstFirst ... 234

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •