Page 1 of 4 123 ... LastLast
Results 1 to 10 of 37

Thread: DC SSR only working at half

  1. #1
    Join Date
    Feb 2009
    Location
    Scotland, UK
    Posts
    389
    Post Thanks / Like

    Thumbs down DC SSR only working at half

    Ive built some DC SSR's and connected them to my grinch controlled by a ren-c, i have both cables running between the ren-c and the grinch and both have a power supply. The lights are 12v led's and dim up and down fine however when I measured the voltage of the leds it was only 6v. Ive checked everything and cant seem to find any problem anywhere. Can anyone help?

    Thanks in advance Stephen

  2. #2
    Join Date
    Jun 2009
    Location
    Ottawa, Ontario, Canada
    Posts
    2,816
    Post Thanks / Like

    Default Re: DC SSR only working at half

    Quote Originally Posted by soakes94 View Post
    Ive built some DC SSR's and connected them to my grinch controlled by a ren-c, i have both cables running between the ren-c and the grinch and both have a power supply. The lights are 12v led's and dim up and down fine however when I measured the voltage of the leds it was only 6v. Ive checked everything and cant seem to find any problem anywhere. Can anyone help?

    Thanks in advance Stephen
    Where were you measuring?
    Did you try between +V and GND at the DCSSR itself?
    Standard Disclaimers apply:
    "Product may not appear as shown, your mileage may vary, I'm not a doctor nor do I play one on television, these are not the droids you seek"

  3. #3
    Join Date
    Feb 2009
    Location
    Scotland, UK
    Posts
    389
    Post Thanks / Like

    Default Re: DC SSR only working at half

    I measureed the voltage at the output, the input voltage for t led meausres 12v but the output is only 6v

  4. #4
    Join Date
    Oct 2008
    Location
    San Jose, CA
    Posts
    9,556
    Post Thanks / Like

    Default Re: DC SSR only working at half

    Remove the LED from the output and measure from the +DC to the output pin and verify if you are seeing 12v there or not with the channel on. Remember these are switched grounds. If that's OK then you know the SSR is working OK.

    Can you describe exactly how you have things wired up? Where is the current limiting resistor installed in the path and what do you see across that?

    I'm a little confused because you indicated it dimmed up and down fine?
    Brian

    Christmas in San Jose! - WEB - FB - VIDEOS
    Halloween in San Jose! - FB
    2014 Halloween Show - Homemade tombstones, Video Projection - not much new this year...
    2014 Christmas Show - 5x E681-12, 1x6804, 4x Ren48LSD, 30x42 TLS3001 pixel MT/Star, 4x Rainbow Floods, 12x DIYC Floods, SuperPixelStar, 3x Pixel Arches, PixaBulb House outline

    Ignorance is Temporary - Stupidity is Forever...

  5. #5
    Join Date
    Feb 2009
    Location
    Scotland, UK
    Posts
    389
    Post Thanks / Like

    Default Re: DC SSR only working at half

    Ive attached a picture of my DC SSR, the resistors between the opto and input are 680 ohm, the resistor on the 12v is a 10k ohm and the resistor between the opto and the mosfet is a 470 ohm. The 2 screw terminals read 12v, when I activate the channel to 100% im only getting about 6v out. I take this reading by keeping the positive end of the tester on the 12v screw terminal at the top and place the negative on the output screw terminal.

    Can anyone help?
    Attached Images Attached Images

  6. #6
    Join Date
    Jun 2009
    Location
    Ottawa, Ontario, Canada
    Posts
    2,816
    Post Thanks / Like

    Default Re: DC SSR only working at half

    What are you using to trigger the DCSSR? Any chance it's doing a PWM at about 50%? (Just looking to rule out the silly .. but sometimes overlooked solutions)

    How about a picture of the underside, so we can double check the circuit?
    Standard Disclaimers apply:
    "Product may not appear as shown, your mileage may vary, I'm not a doctor nor do I play one on television, these are not the droids you seek"

  7. #7
    Join Date
    Oct 2008
    Location
    San Jose, CA
    Posts
    9,556
    Post Thanks / Like

    Default Re: DC SSR only working at half

    It appears you etched your own boards - good for you! Can you list exactly which parts you used for the MOSFET and opto? Just wondering if the FET is not turning on completely or something...
    Brian

    Christmas in San Jose! - WEB - FB - VIDEOS
    Halloween in San Jose! - FB
    2014 Halloween Show - Homemade tombstones, Video Projection - not much new this year...
    2014 Christmas Show - 5x E681-12, 1x6804, 4x Ren48LSD, 30x42 TLS3001 pixel MT/Star, 4x Rainbow Floods, 12x DIYC Floods, SuperPixelStar, 3x Pixel Arches, PixaBulb House outline

    Ignorance is Temporary - Stupidity is Forever...

  8. #8
    Join Date
    Feb 2009
    Location
    Scotland, UK
    Posts
    389
    Post Thanks / Like

    Default Re: DC SSR only working at half

    Ive set it to 100% and my output is still 6v, Ive attached a picture of the bottom hope it helps

    Thanks for all your help
    Attached Images Attached Images

  9. #9
    Join Date
    Feb 2009
    Location
    Scotland, UK
    Posts
    389
    Post Thanks / Like

    Default Re: DC SSR only working at half

    Ive used 78L05 for my voltage reg, ive got 680ohm resistors between the opto and input, ive got a 10k ohm on the 12v into the mosfet, and a 470 ohm between the opto and mosfet and im using a RFD14N05L for the mosfet and also a 100nF cap.

    thanks stephen

  10. #10
    Join Date
    Feb 2009
    Location
    Scotland, UK
    Posts
    389
    Post Thanks / Like

    Default Re: DC SSR only working at half

    Oh and the opto is a k847p

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •