PDA

View Full Version : Build Errors



StickyWicket
03-21-2016, 08:27 PM
I have followed the instructions to get the source code cloned off of git. When I try to build the project (with no changes) I am getting a bunch of errors like this:

Error 10 Metadata file 'C:\vixen\Release\Common\Controls.dll' could not be found C:\vixen\Modules\App\Curves\CSC Curves
Error 11 Metadata file 'C:\vixen\Release\Common\Controls.dll' could not be found C:\vixen\Modules\PostFilter\ColorBreakdown\CSC ColorBreakdown
Error 12 Metadata file 'C:\vixen\Release\Common\Controls.dll' could not be found C:\vixen\Modules\App\ColorGradients\CSC ColorGradients
Error 13 Metadata file 'C:\vixen\Release\Modules\App\Curves.dll' could not be found C:\vixen\Modules\App\ColorGradients\CSC ColorGradients
Error 14 Metadata file 'C:\vixen\Release\Modules\OutputFilter\ColorBreakd own.dll' could not be found C:\vixen\Modules\Property\Color\CSC Color
Error 15 Metadata file 'C:\vixen\Release\Common\Controls.dll' could not be found C:\vixen\Modules\Property\Color\CSC Color


There are a total of 136 errors almost all referring to missing dll's

I am running VS2013.

Could I get a bit of assistance to get this working so hopefully I can give back to the project.

jchuchla
03-21-2016, 08:37 PM
Did you build them all?


--Jon Chuchla--

Sent from my iPhone using Tapatalk

StickyWicket
03-21-2016, 08:44 PM
Did you build them all?


--Jon Chuchla--

Sent from my iPhone using Tapatalk

I have tried Build Solution and Rebuild Solution.

StickyWicket
03-23-2016, 09:04 PM
For anyone who may come across this issue, I was running VS2103 and didn't have the .NET Framework 4.5.2 installed which caused all of the errors. Once I installed that it built successfully.

Inventicon
12-04-2016, 09:50 PM
I'm running into the same kind of problem as StickyWicket. Attempts to build the whole solution in Visual Studio 2013 have failed. I do have .NET Framework 4.5.2 but there is still no success.
I don't know if what i'm doing is right.

I'm trying to make a module but have not found any documentation on how to do so.
Could I get pointed into the right direction for some kind of information or forum post I missed as well?

jchuchla
12-04-2016, 10:19 PM
Generally when you're getting started you need to clean the solution and rebuild all. You'll want to set the target to release (for some reason debug doesn't work right) and make sure you're building for the right architecture.


Sent from my iPhone using Tapatalk Pro

Inventicon
12-04-2016, 10:25 PM
You sir, are a wizard! I feel so stupid for not trying to build with Release!

Thanks!