PDA

View Full Version : Trying to get my HIFIBerry to work



Keith R
12-06-2015, 04:30 PM
I have posted at the FPP site and sometimes they speak a language I don't understand. I have the Sainsmart card here (http://www.sainsmart.com/sainsmart-hifi-dac-audio-sound-card-module-i2s-interface-for-raspberry-pi-2-b.html). I have plugged it in and have viewed and run the script for the HIFIBerry. After running the script and either rebooting or not, I do not have the option in the pull down window for the dac+ in the audio output device of the FPP Settings tab.

If I go to the SSH Shell in the Help Folder and run the command 'sudo nano /etc/modules' to edit the /etc/modules file after logging in, I get the following. I have no idea how to get this to work, as the sound from the Pi is less than adequate for my show. I have ordered a USB sound card, but I feel this may not even work. Other than this, my show is working pretty nice from the FPP. Anyone using this card and got it to work, please give me some insight as to what I can do to get the Pi to recognize the card.
Thanks

JerryPlak
12-06-2015, 04:54 PM
I updated my pi-2 very 1.7 then run the scrip as it took about 30 to 40 min to do everything I did a reboot. It's working great for me.

JerryPlak
12-06-2015, 04:55 PM
That ver. 1.7

budude
12-06-2015, 08:46 PM
My PI 2 w/SainSmart card is running a late 1.6 version with no issues. I had to configure the 'media/settings' file manually and reboot the PI to get them to work.

AudioOutput = 0
AudioMixerDevice = Digital

Just setting from the GUI did not work right.

I set the volume at 45 as well - anything beyond 50 created some distortion.

jeffl
12-06-2015, 09:59 PM
Also check out post #9 in this thread. I posted the steps I used. Hopefully they will help.

http://falconchristmas.com/forum/index.php?topic=3652.new;topicseen#new

Keith R
12-06-2015, 11:06 PM
Jeff,
This is what I was looking for. Unfortunately, I can't do an underscore (./Enable_HiFiBerry.sh) between Enable and HIFIBerry. I have tried 3 different keyboards and I had this issue inside the SSH before.

Copy and paste doesn't work either.

jeffl
12-07-2015, 12:03 AM
Hmm.. I had that issue on the keyboard attached to my LOR show computer (Windows XP) SSH into the PI. I thought it was the keyboard but now I just tested it and it works in windows so it's not the keyboard (although it's an old one). One thing I would try is a different browser and see if the "_" will work. If not I would post a separate question on the issue and hopefully the Captain will see it.

jeffl
12-07-2015, 12:08 AM
I just tried Firefox and it didn't work. IE surprisingly did work. I typically use Chrome but I didn't have much luck with Chrome on Windows XP. So I would try IE as it might be good for something after all. :)

budude
12-07-2015, 12:55 AM
Just type ./Enable (don't hit enter!) and then hit Tab - it should complete the rest for you - then just hit enter...

Keith R
12-08-2015, 12:15 AM
Issue solved! I could not even go to the SSH in IE (I normally use Firefox), but in Chrome, not only was I able to log in, I was able to get the HIFI going manually, per the instructions you provided on the FPP site. Thanks to Brian and Jeff for getting this going. I will swap out the PI's after tonight's show and we will see what the sound is like.
The answers on this site are so much better than "Did you read this or that?" When you can't do something, and you can't figure out the workaround, you ask.
The browser was the answer I needed. Thanks again.

bdeditch
01-10-2016, 02:55 AM
Issue solved! I could not even go to the SSH in IE (I normally use Firefox), but in Chrome, not only was I able to log in, I was able to get the HIFI going manually, per the instructions you provided on the FPP site. Thanks to Brian and Jeff for getting this going. I will swap out the PI's after tonight's show and we will see what the sound is like.
The answers on this site are so much better than "Did you read this or that?" When you can't do something, and you can't figure out the workaround, you ask.
The browser was the answer I needed. Thanks again.

Could you please explain to a newbie here how you get into SSH? I want to add this board and right now I am not sure I can do it, cannot understand the procedure.

jeffl
01-10-2016, 12:20 PM
Just choose the following menu options.

Help -> SSH

Then use these credentials.

Login: fpp
Password: falcon

bdeditch
01-11-2016, 06:05 PM
Just choose the following menu options.

Help -> SSH

Then use these credentials.

Login: fpp
Password: falcon

Ok then where does the code need to be entered, is it like a notepad entry?

tucsonlights
01-11-2016, 06:31 PM
Just copy and paste the code into the ssh session. After pasted hit enter and reboot.

bdeditch
01-11-2016, 06:37 PM
Just copy and paste the code into the ssh session. After pasted hit enter and reboot.


OK so I would guess first thing is to back up the SD card and then do all of this, thank you I will try it soon.

jeffl
01-11-2016, 06:48 PM
I would advise making images of both the USB drive and flash drive before doing this. That way if you destroy things along the way like I did, multiple times, you can easily get back to where you started.

Win32 Disk Imager
ImageUSB by PassMark Software

Both of these tools are free to use.

jeffl
01-11-2016, 06:49 PM
Also check out post #9 in this thread. I posted the steps I used. Hopefully they will help.

http://falconchristmas.com/forum/ind...;topicseen#new