PDA

View Full Version : I need help with LED strings



Keithaj
11-07-2014, 07:08 PM
OK I know enough about electronics to build most things but I am having a world of trouble with LED strings and their operation. Here is the deal. On my gutters I want to put a run of LED lights that contains 6 strings (Green, Blue, Amber, Purple, Yellow and Red) they are set up each as a separate run with a common return (the common is the positive side which is common on the board. Each string is in series and I did the calculations for the resistor for a 48volt supply. I am using two of the DC ssr from Labrat (8 total channels with 2 unused). My problem is that each string runs fine by its self but if two string go on at the same time they drop out and just glow. What am I doing wrong? My supply has 8 amps so there should be enough to drive it all. I am stumped and could use some help.

kmalsom
11-07-2014, 07:24 PM
Does each string have is own resistor, and what voltages are the strings? What is the voltage on the positive side wher we iit connects to the strings? I assume the positive goes to all the strings and doesn't go through the string before choosing to the nest string?

Keithaj
11-07-2014, 07:31 PM
Each color channel is on its own circuit of the DC SSRs and is 48v. I am using D5NK60 MOSFETs which are rated a 650v and 5a. There are 14 LEDs in each color string. I used an online resistor calculator for the proper value for the resistors. They are as follows Blue 3volt - 330 Ohms, Green2.2volt - 1000 Ohms, Red 1.8volt - 1200, Amber 2volt - 1000 Ohms, Yellow 2volt - 1000 Ohms, Purple 3.3volt - 100Ohms. Also the resistors 1/2 watt and they run cool with none of them getting hot.

slovanredneck
11-07-2014, 07:47 PM
How much current to each of the strings draw? What gauge wire are you using and length? I'm wondering if maybe your common has to much voltage drop.

Keithaj
11-07-2014, 08:28 PM
I am not sure of the total current for each string but it can't be more than .1 amp. I am using 22 AWG wire for the common and 24 for the strings.

P. Short
11-08-2014, 12:46 PM
What controllers and/or SSR are you using? Those MOSFETs require more than 5V gate drive in order to work well, they are not logic-level parts.

Never mind about the controller/ssr question - I see the answer now.

P. Short
11-08-2014, 01:00 PM
I think that using a higher-voltage regulator on the board (perhaps 10V or 12V) in place of the LM7805/LM78L05 would help a lot. Perhaps Ernie or someone else might have something to say on this.

Keithaj
11-08-2014, 04:36 PM
P. Short,I did preliminary test using a 12v regulator and I had success! I checked the specs on the MOSFETs and they need about 4.5v the 12v gives all of them what they need. I will do a full test in the next few days and let you know. For now I am pumped!

MartinMueller2003
11-08-2014, 06:36 PM
without knowing the current through the string, there is no way you could calculate a resistsnce value.

Keithaj
11-15-2014, 08:24 PM
MAJOR success! The lights are now functioning great and the load is no problem with several strings hooked up. Now I just need to get them up. I'm in the Minneapolis area and we got 14 in of snow and cold weather to go with it. My roof is a little too icy now to get up there. They say that some warmer weather is coming but I will believe it when I see it. For now I'm getting things ready.
Thank you so much P. Short for your assistance. Martin, I have found a website which is great in finding the proper resistor value for LED strings. The site is http://led.linear1.org/led.wiz