PDA

View Full Version : False warning window about cahannels configuration



Petulka77
10-14-2014, 11:54 PM
I am currently tuning synchronization of physical pixels with HLS mapping.
Every time when I make a change in "Prepare Channels for Output" (i.e. changing order) and then select "Test by Manually Turning Lights ON and OFF" I get this false warning popup:
25107
I am sure the channels are set correctly an I am sure it false alarm.
As a proof: when I save the sequence and exit HLS and reopen it. Then trying to do "Test by Manually Turning Lights ON and OFF" again it works for me (with previously made changes).

Would it be possible to fix it? Closing and opening my sequence with large number of pixels it's pretty time consuming when trying tune pixel mapping.

Also closing the "Manual test" window takes HLS 2.5 minutes in my sequence. I also checked HLS.exe windows process during that time and it's just idle (0% CPU usage). I am not sure what takes so long if HLS does not do anything. Would it be possible to tune this up?

Thank you.

JHinkle
10-15-2014, 12:16 AM
Comment in error.

Joe

JHinkle
10-15-2014, 12:48 AM
Well -- I responded too early --- thought I was going to bed but your statement bothered me.

I tested on YOUR sequence --- everything works as designed.

That error message is posted when you performed an operation that MIGHT affect an output ... Like manage COM Ports, Manage Raw Channels.

I don't watch and check every little thing you do --- so when you DO SOMETHING that has of chance of changing a Universe from performing OUTPUT -- I clear the OK flag -- and you get the message.

You only have to OUTPUT - Select Ouput Method and Compile for Show -- hit OK and your system is checked and the flag is set.

When you get that message --- think about what you have modified and will will find the process that is clearing the flag.

E1.31 has a specification as to what must be accomplished when a E1.32 channel is shut down.

It involves sending several messages to each Universe controller with delays in-between.

I may look at adding a NON-STANDARD option to ignore specification shut-down so it will go faster for you.

Joe

JHinkle
10-15-2014, 12:59 AM
I released 23E -- removed the E131 specified shut-down requirement.

I don't think the DIY community controllers care --- I don't know -- so see if your controller complains.

Joe

Petulka77
10-15-2014, 09:02 PM
Hi Joe.

Sorry for keeping you up late last night. I appreciate your help.
Your fix for closing the Manual Output test works for me. It now takes just 2s to close it. :rolleyes:
Also your suggestion to do the compile clears the flag and let me jump to manual test. Thanks for that too.

How does the pondering on : "Sorting ability in Manual output test" go?

JHinkle
10-15-2014, 09:28 PM
I'm tied up the next couple of days with life --- will look this weekend.

Something does not sound right as I thout I listed then in Universe/Channel order.

Joe