PDA

View Full Version : Having a problem programing pic. Was working...



Robo
07-07-2014, 04:59 PM
I bought some new controllers so I need to reflash the PICs. I have a PicKit2 that I used last year to flash pics, 16f688, for my renard boards. Near the end of the season last year when I opened PicKit2 it came up with this highlighted in yellow "The PICkit 2 has no Operating System. Use the Tools menu to download an OS." When I clicked on "Download PICkit2 OS under tools. It takes me to a blank firmware folder. I tried inserting the small orginal J1 ICSP adaptor with Updated software disk. I tried using Hex PK2V023200 file from the disk. Not sure if that's the right procedures but it Downloads and verifies. Everything seems normal. I follow every step from Waynes tuts and everything gets verified no problems. I repeat for all my chips but once installed in the renards they don't work. I have confirmed that the controllers work with other known working chips. I'm I missing something? I have been using this link for the operational code http://www.doityourselfchristmas.com/wiki/index.php?title=SS24#Firmware. Any thoughts? Thanks Rob

Wayne J
07-07-2014, 10:23 PM
Give this pdf a try, it will walk you through downloading the OS for the PK2.
http://www.doityourselfchristmas.com/wiki/images/3/38/How_to_program_a_PIC.pdf

Robo
07-07-2014, 11:02 PM
Thanks Wayne. Question though, everything good until I get to page 8. It's suppose to show PIC Device Found. But mine says [Parts in this family are not auto-detect]. Should I be clicking on something in the Device Family tab? Also correct me if I'm wrong I should be using ss operational firmware not Renard-dmx.