PDA

View Full Version : Vertical matrix and external PP effects



angus40
07-02-2014, 01:38 PM
The vertical matrix works perfectly if using Hls PP editor but there seems to be an issue with using external pp effects .

In this video I show a horizontal bar effect created in hls pp editor

The red effect was created using the Hls PP editor.

The green effect is converted to a external pp effect within hls .

This does not happen with a mega tree only vertical matrix and external PP effects .

Also could you re apply the modify( this allowed users to ramp in or fade out ) to a pp , this feature seems to get broken or removed every so often with all your new releases .


Cheers



https://www.youtube.com/watch?v=5mx2pSYuFkc&feature=youtu.be

JHinkle
07-03-2014, 10:46 AM
I can't recreate your issue.

Please be very detailed as to how to create it.

Explain -- How created PP -- what number strings/Pixels per string --- Hoe defined Hor Bar effect in PP editor --- How exported to external effect (I think HLS only exports to PNG - not NC format) -- how applied new external effect back into HLS.

Thanks.

Joe

angus40
07-03-2014, 03:21 PM
Matrix size = 294 strings 29 pixels on each string

the exported png image sequence looks perfect .

I have not dumped the external pp on rgb to see if it looks correct or not .

here is a demo .


https://www.youtube.com/watch?v=sMvkn8fwS4E&feature=youtu.be

JHinkle
07-04-2014, 12:33 PM
This process works for a MegaTree - right?

I thought this was tested and used as a MegaTree.

If the V-Matrix is defined as Vertical Strings on a specific size --- then it should work also.

If you defined the matrix as Horizontal strings on X size -- then the conversion back into HLS would be reversed -- as you stated in your video.

Please check to see if this is the case.

Check the channel assignment (upper right button in the PP editor). If your "Preview" horizontal pixel lines are defined as a continuous string then your channel mapping has to be changed to match the vertical string concept.


Thanks.

Joe

angus40
07-04-2014, 07:11 PM
You are probably correct as usual Joe ( this is most likely something i have not set correctly ) , I am having trouble seeing the forest for the trees with this 1 though .

I have set my string/channels vertically just like a mega tree

294 strings with 29 pixels each .

JHinkle
07-04-2014, 07:35 PM
Zip up and send me the project so I can take a look.

angus40
07-04-2014, 08:21 PM
ok thanks ,

I created a no audio sequence and sent .